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1  Safety and regulatory information
The product documentation helps you use the product safely and efficiently. Follow the
instructions provided here and in the following chapters.

Intended use

The product is intended for the development, production and verification of electronic
components and devices in industrial, administrative, and laboratory environments.
Use the product only for its designated purpose. Observe the operating conditions and
performance limits stated in the data sheet.

Where do I find safety information?

Safety information is part of the product documentation. It warns you of potential dan-
gers and gives instructions on how to prevent personal injury or damage caused by
dangerous situations. Safety information is provided as follows:
● In Chapter 1.1, "Safety instructions", on page 11. The same information is provi-

ded in many languages as printed "Safety Instructions". The printed "Safety
Instructions" are delivered with the product.

● Throughout the documentation, safety instructions are provided when you need to
take care during setup or operation.

1.1  Safety instructions

Products from the Rohde & Schwarz group of companies are manufactured according
to the highest technical standards. To use the products safely, follow the instructions
provided here and in the product documentation. Keep the product documentation
nearby and offer it to other users.

Use the product only for its intended use and within its performance limits. Intended
use and limits are described in the product documentation such as the data sheet,
manuals and the printed "Safety Instructions". If you are unsure about the appropriate
use, contact Rohde & Schwarz customer service.

Using the product requires specialists or specially trained personnel. These users also
need sound knowledge of at least one of the languages in which the user interfaces
and the product documentation are available.

Never open the casing of the product. Only service personnel authorized by
Rohde & Schwarz are allowed to repair the product. If any part of the product is dam-
aged or broken, stop using the product. Contact Rohde & Schwarz customer service at
http://www.customersupport.rohde-schwarz.com.

Lifting and carrying the product

The maximum weight of the product is provided in the data sheet. To move the product
safely, you can use lifting or transporting equipment such as lift trucks and forklifts. Fol-
low the instructions provided by the equipment manufacturer.

Safety instructions

http://www.customersupport.rohde-schwarz.com
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Choosing the operating site

Only use the product indoors. The product casing is not waterproof. Water that enters
can electrically connect the casing with live parts, which can lead to electric shock,
serious personal injury or death if you touch the casing. If Rohde & Schwarz provides
accessories designed for your product, e.g. a carrying bag, you can use the product
outdoors.

Unless otherwise specified, you can operate the product up to an altitude of 2000 m
above sea level. The product is suitable for pollution degree 2 environments where
nonconductive contamination can occur. For more information on environmental condi-
tions such as ambient temperature and humidity, see the data sheet.

Setting up the product

Always place the product on a stable, flat and level surface with the bottom of the prod-
uct facing down. If the product is designed for different positions, secure the product so
that it cannot fall over.

If the product has foldable feet, always fold the feet completely in or out to ensure sta-
bility. The feet can collapse if they are not folded out completely or if the product is
moved without lifting it. The foldable feet are designed to carry the weight of the prod-
uct, but not an extra load.

If stacking is possible, keep in mind that a stack of products can fall over and cause
injury.

If you mount products in a rack, ensure that the rack has sufficient load capacity and
stability. Observe the specifications of the rack manufacturer. Always install the prod-
ucts from the bottom shelf to the top shelf so that the rack stands securely. Secure the
product so that it cannot fall off the rack.

Connecting to power

The product is an overvoltage category II product. Connect the product to a fixed
installation used to supply energy-consuming equipment such as household applian-
ces and similar loads. Keep in mind that electrically powered products have risks, such
as electric shock, fire, personal injury or even death.

Take the following measures for your safety:
● Before switching on the product, ensure that the voltage and frequency indicated

on the product match the available power source. If the power adapter does not
adjust automatically, set the correct value and check the rating of the fuse.

● Only use the power cable delivered with the product. It complies with country-spe-
cific safety requirements. Only insert the plug into an outlet with protective conduc-
tor terminal.

● Only use intact cables and route them carefully so that they cannot be damaged.
Check the power cables regularly to ensure that they are undamaged. Also ensure
that nobody can trip over loose cables.

● If the product needs an external power supply, use the power supply that is deliv-
ered with the product or that is recommended in the product documentation or a
power supply that conforms to the country-specific regulations.

Safety instructions
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● Only connect the product to a power source with a fuse protection of maximum
20 A.

● Ensure that you can disconnect the product from the power source at any time.
Pull the power plug to disconnect the product. The power plug must be easily
accessible. If the product is integrated into a system that does not meet these
requirements, provide an easily accessible circuit breaker at the system level.

Cleaning the product

Use a dry, lint-free cloth to clean the product. When cleaning, keep in mind that the
casing is not waterproof. Do not use liquid cleaning agents.

Meaning of safety labels

Safety labels on the product warn against potential hazards.

Potential hazard

Read the product documentation to avoid personal injury or product damage.

Electrical hazard

Indicates live parts. Risk of electric shock, fire, personal injury or even death.

Hot surface

Do not touch. Risk of skin burns. Risk of fire.

Protective conductor terminal

Connect this terminal to a grounded external conductor or to protective ground. This connec-
tion protects you against electric shock if an electric problem occurs.

1.2  Labels on R&S SGU

Labels on the casing inform about:
● Personal safety, see "Connecting to power" on page 12.
● Product and environment safety, see Table 1-1.
● Identification of the product, see the serial number on the rear panel.
Table 1-1: Labels regarding R&S SGU and environment safety

Labeling in line with EN 50419 for disposal of electrical and electronic equipment after the prod-
uct has come to the end of its service life. For more information, see Chapter 16, "Maintenance,
storage and disposal", on page 228.

1.3  Warning messages in the documentation

A warning message points out a risk or danger that you need to be aware of. The sig-
nal word indicates the severity of the safety hazard and how likely it will occur if you do
not follow the safety precautions.

Warning messages in the documentation



Safety and regulatory informationR&S®SGU100A

14User Manual 1176.7726.02 ─ 10

WARNING

Potentially hazardous situation. Could result in death or serious injury if not avoided.

CAUTION

Potentially hazardous situation. Could result in minor or moderate injury if not avoided.

NOTICE

Potential risks of damage. Could result in damage to the supported product or to other
property.

1.4  Korea certification class B

이 기기는 가정용(B급) 전자파 적합기기로서 주로 가정에서 사용하는 것을 목적으로 하
며, 모든 지역에서 사용할 수 있습니다.

Korea certification class B
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2  Welcome
The R&S SGU is an upconverter in the frequency range of 10 MHz to 40 GHz.

Optimized for use in automated test equipment (ATE), the instrument offers fast settling
times in an exceptionally small form factor and low power consumption. The R&S SGU
has LO connectors for coupling multiple generators to a common LO source and can
be equipped with a mechanical step attenuator.

2.1  Key features

The key features of the R&S SGU include the following:

● Compact size and low power consumption
● Remote connection via PCI Express, minimizing the setup time

Alternatively, LAN or USB connections available
● Coherent LO input and output connectors, also usable as MIMO input/output and

phase coherent I/Q demodulation
● Linux operating system
● Graphical user interface R&S SGMA-GUI to set up and control one or more

R&S SGU instruments simultaneously from one remote computer, available for
Windows and Linux systems

2.2  What's new

This manual describes firmware version FW 5.00.232.xx and later of the
R&S®SGU100A.

Compared to the previous version, it provides the new features listed below:
● Upgrading to R&S SGU firmware versions 5.00.vvv.vv and later, see "Upgrading to

firmware versions 5.00.vvv.vv and later" on page 29.
● Extended "Configure Instruments" settings including scanning the subnet, setting

the IP address and the prefix length, see Chapter 8.1.2.1, "Configure instruments",
on page 60.

● Password management including user password and security password settings,
see Chapter 10.5, "Security", on page 110.

● Editorial changes, major changes are as follows:
– Safety and regulatory information updated, see Chapter 1, "Safety and regula-

tory information", on page 11.
– Getting started updated, see Chapter 3, "Preparing for use", on page 19,

Chapter 4, "Instrument tour", on page 35, Chapter 5, "Trying out the Instru-
ment", on page 40 and Chapter 6, "Instrument control", on page 47.

– Transporting added, see Chapter 15, "Transporting", on page 227.

What's new
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– Maintenance, storage and disposal added, see Chapter 16, "Maintenance,
storage and disposal", on page 228.

2.3  Documentation overview

This section provides an overview of the R&S SGU user documentation. Unless speci-
fied otherwise, you find the documents on the R&S SGU product page at:

www.rohde-schwarz.com/manual/sgu100a

2.3.1  Getting started manual

Introduces the R&S SGU and describes how to set up and start working with the prod-
uct. Includes basic operations, typical measurement examples, and general informa-
tion, e.g. safety instructions, etc. A printed version is delivered with the instrument.

2.3.2  User manual and help

Contains the description of all instrument modes and functions. It also provides an
introduction to remote control, a complete description of the remote control commands
with programming examples, and information on maintenance, instrument interfaces
and error messages. Includes the contents of the getting started manual.

The contents of the user manuals are available as help in the R&S SGU. The help
offers quick, context-sensitive access to the complete information.

All user manuals are also available for download or for immediate display on the Inter-
net.

2.3.3  Service manual

Describes the performance test for checking the rated specifications, module replace-
ment and repair, firmware update, troubleshooting and fault elimination, and contains
mechanical drawings and spare part lists.

The service manual is available for registered users on the global Rohde & Schwarz
information system (GLORIS, https://gloris.rohde-schwarz.com).

2.3.4  Instrument security procedures

Deals with security issues when working with the R&S SGU in secure areas. It is avail-
able for download on the Internet.

Documentation overview

http://www.rohde-schwarz.com/manual/sgu100a
https://gloris.rohde-schwarz.com
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2.3.5  Basic safety instructions

Contains safety instructions, operating conditions and further important information.
The printed document is delivered with the instrument.

2.3.6  Data sheets and brochures

The data sheet contains the technical specifications of the R&S SGU. It also lists the
options and their order numbers and optional accessories.

The brochure provides an overview of the instrument and deals with the specific char-
acteristics.

See www.rohde-schwarz.com/brochure-datasheet/sgu100a

2.3.7  Release notes and open source acknowledgment (OSA)

The release notes list new features, improvements and known issues of the current
firmware version, and describe the firmware installation.

The open source acknowledgment document provides verbatim license texts of the
used open source software.

See www.rohde-schwarz.com/firmware/sgu100a

2.3.8  Application notes, application cards, white papers, etc.

These documents deal with special applications or background information on particu-
lar topics.

See www.rohde-schwarz.com/application/sgu100a.

2.4  Typographical conventions

The following text markers are used throughout this documentation:

Convention Description

"Graphical user interface ele-
ments"

All names of graphical user interface elements on the screen, such as
dialog boxes, menus, options, buttons, and softkeys are enclosed by
quotation marks.

[Keys] Key and knob names are enclosed by square brackets.

Filenames, commands,
program code

Filenames, commands, coding samples and screen output are distin-
guished by their font.

Input Input to be entered by the user is displayed in italics.

Typographical conventions

http://www.rohde-schwarz.com/brochure-datasheet/sgu100a
http://www.rohde-schwarz.com/firmware/sgu100a
http://www.rohde-schwarz.com/application/sgu100a
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Convention Description

Links Links that you can click are displayed in blue font.

"References" References to other parts of the documentation are enclosed by quota-
tion marks.

2.5  Notes on screenshots

When describing the functions of the product, we use sample screenshots. These
screenshots are meant to illustrate as many as possible of the provided functions and
possible interdependencies between parameters. The shown values may not represent
realistic usage scenarios.

The screenshots usually show a fully equipped product, that is: with all options instal-
led. Thus, some functions shown in the screenshots may not be available in your par-
ticular product configuration.

Notes on screenshots



Preparing for useR&S®SGU100A

19User Manual 1176.7726.02 ─ 10

3  Preparing for use
Here, you can find basic information about setting up the product for the first time.

3.1  Lifting and carrying

See also "Lifting and carrying the product" on page 11.

► Use the carrying handles at the side for lifting and carrying the R&S SGU.
The handles at the front are only for pushing and pulling the instrument when
mounting in a rack, see Chapter 3.4.2, "Mounting the R&S SGU in a rack",
on page 21.

3.2  Unpacking and checking

1. Unpack the R&S SGU carefully.

2. Retain the original packing material. Use it to protect the control elements and con-
nectors when transporting or shipping the R&S SGU later.
See also Chapter 15, "Transporting", on page 227.

3. Using the delivery notes, check the equipment for completeness.

4. Check the equipment for damage.

If the delivery is incomplete or equipment is damaged, contact Rohde & Schwarz.

3.3  Choosing the operating site

Specific operating conditions ensure proper operation and avoid damage to the prod-
uct and connected devices. For information on environmental conditions such as ambi-
ent temperature and humidity, see the data sheet.

See also "Choosing the operating site" on page 12.

Electromagnetic compatibility classes

The electromagnetic compatibility (EMC) class indicates where you can operate the
product. The EMC class of the product is given in the data sheet.
● Class B equipment is suitable for use in:

– Residential environments
– Environments that are directly connected to a low-voltage supply network that

supplies residential buildings

Choosing the operating site
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● Class A equipment is intended for use in industrial environments. It can cause
radio disturbances in residential environments due to possible conducted and radi-
ated disturbances. It is therefore not suitable for class B environments.
If class A equipment causes radio disturbances, take appropriate measures to
eliminate them.

3.4  Setting up the R&S SGU

See also:
● "Setting up the product" on page 12
● "Intended use" on page 11

3.4.1  Placing the R&S SGU on a bench top

To place the product on a bench top

1. Place the product on a stable, flat and level surface. Ensure that the surface can
support the weight of the product. For information on the weight, see the data
sheet.

2. WARNING! A stack of products can fall over and cause injury. Never stack more
than three products on top of each other. Instead, mount them in a rack.
Stack as follows:

● If the products have foldable feet, fold them in completely.
● It is best if all products have the same dimensions (width and length). If the

products have different dimensions, stack according to size and place the
smallest product on top.

● Do not exceed the permissible total load placed on the product at the bottom of
the stack:
– 50 kg when stacking products of identical dimensions (left figure).
– 25 kg when stacking smaller products on top (middle figure).

Setting up the R&S SGU
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Left = Stacked correctly, same dimensions
Middle = Stacked correctly, different dimensions
Right = Stacked incorrectly, too many products

3. NOTICE! Overheating can damage the product.
Prevent overheating as follows:

● Keep a minimum distance of 10 cm between the fan openings of the product
and any object in the vicinity.

● Do not place the product next to heat-generating equipment such as radiators
or other products.

3.4.2  Mounting the R&S SGU in a rack

To prepare the rack

1. Observe the requirements and instructions in "Setting up the product" on page 12.

2. NOTICE! Insufficient airflow can cause overheating and damage the product.
Design and implement an efficient ventilation concept for the rack.

To mount the R&S SGU in a rack

1. Use an adapter kit that fits the dimensions of the R&S SGU to prepare the instru-
ment for rack mounting.

a) Order the rack adapter kit designed for the R&S SGU. For the order number,
see data sheet.

b) Mount the adapter kit. Follow the assembly instructions provided with the
adapter kit.

2. Push the R&S SGU onto the shelf until the rack brackets fit closely to the rack.

3. Tighten all screws at the rack brackets with a tightening torque of 1.2 Nm to secure
the R&S SGU in the rack.

To unmount the R&S SGU from a rack

1. Loosen the screws at the rack brackets.

2. Remove the R&S SGU from the rack.

3. If placing the R&S SGU on a bench top again, unmount the adapter kit from the
R&S SGU. Follow the instructions provided with the adapter kit.

Setting up the R&S SGU
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3.5  Considerations for test setup

Cable selection and electromagnetic interference (EMI)

Electromagnetic interference (EMI) can affect the measurement results.

To suppress electromagnetic radiation during operation:
● Use high-quality shielded cables, especially for the following connector types:

– SMA/SMB
Double-shielded SMA/SMB cables.
How to: Chapter 3.8, "Connecting to RF 50Ω", on page 23

– USB
Double-shielded USB cables.
How to: Chapter 3.13.4, "Connecting a controller via USB", on page 33.

– LAN
At least CAT6 STP cables.
How to: Chapter 3.7, "Connecting to LAN", on page 23

● Always terminate open cable ends.
● Ensure that connected external devices comply with EMC regulations.

Signal input and output levels

Information on signal levels is provided in the data sheet. Keep the signal levels within
the specified ranges to avoid damage to the R&S SGU and connected devices.

Preventing electrostatic discharge (ESD)

Electrostatic discharge is most likely to occur when you connect or disconnect a DUT.

► NOTICE! Electrostatic discharge can damage the electronic components of the
product and the device under test (DUT).
Ground yourself to prevent electrostatic discharge damage:

a) Use a wrist strap and cord to connect yourself to ground.
b) Use a conductive floor mat and heel strap combination.

3.6  Connecting to power

For safety information, see "Connecting to power" on page 12.

1. Plug the AC power cable into the AC power connector on the rear panel of the
instrument. Only use the AC power cable delivered with the R&S SGU.

2. Plug the AC power cable into a power outlet with ground contact.

The required ratings are listed next to the AC power connector and in the data
sheet.

Connecting to power
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There is no need to set the voltage manually or change fuses.

3.7  Connecting to LAN

Network environment

Before connecting the product to a local area network (LAN), consider the following:
● Install the latest firmware to reduce security risks.
● For internet or remote access, use secured connections if applicable.
● Ensure that the network settings comply with the security policies of your company.

Contact your local system administrator or IT department before connecting your
product to your company LAN.

● When connected to the LAN, the product may potentially be accessed from the
internet, which may be a security risk. For example, attackers might misuse or
damage the product.

To connect to LAN

The connector is on the rear panel.

► Connect the LAN socket via an RJ-45 cable to the LAN.

By default, the R&S SGU is configured to use DHCP (dynamic host configuration pro-
tocol) and no static IP address is configured.

3.8  Connecting to RF 50Ω

The connector is on the rear panel.

To prepare for connecting to RF 50Ω

1. NOTICE! Damaged or not clean connections can lead to RF insertion loss and mis-
match, and even premature wear of the connectors.
Before connecting to the port, inspect the RF connector visually to check that it is
clean, undamaged and mechanically compatible.
See the application note 1MA99 for information on how to handle and maintain the
RF port, to minimize measurement deviations and ensure its longevity.

2. NOTICE! Risk of instrument damage. Excessive reverse power or DC voltage at
the RF 50Ω connector can damage the instrument.
Make sure that the values do not exceed the reverse power and DC limits as given
in the data sheet.

3. If switched-on, deactivate the RF output of the R&S SGU, before connecting an RF
cable to the RF 50Ω connector.

Connecting to RF 50Ω
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On the front panel, press the [RF ON] key.

To connect to screwable connectors

Additional to the RF 50Ω connector, the following procedure holds for all screwable
connectors of the R&S SGU. Screwable connectors include connector types as listed
in Table 3-1.

1. Use a high-quality cable that matches the connector type.
See "Cable selection and electromagnetic interference (EMI)" on page 22.

2. NOTICE! Risk of instrument damage and connector damage. Excessive tightening
can damage the cables and the connectors. However, if you do not tighten the con-
nectors enough, the measurement results can be inaccurate.
To connect the cable with the connector, proceed as follows:

a) Carefully align the connector of the cable and the connector along a common
axis.

b) Mate the connectors along the common axis until the male pin of the inner con-
nector engages with the female socket of the outer connector.

c) Turn the nut of the outer connector until the connectors are firmly coupled.
d) Torque the nut to the specified limit using a calibrated torque wrench. Hold the

opposite connector part stationary with a spanner.
For torque limits of the most relevant connector types, see Table 3-1. For more
information, see chapter "Handling" of the application note 1MA99.

3. Torque the nut to the specified limit using a calibrated torque wrench. Hold the
opposite connector part stationary with a spanner.

Table 3-1: Connector types and torque limits

Type Torque limit Nut opening

 lb-Inch Nm Inch mm

SMA, SMB 5 0.56 5/16 8

K, 2.92 mm 8 0.9 5/16 8

To prevent RF output switch-off

► NOTICE! If you set a too high output level without a load connected to the instru-
ment, the reverse power can exceed a limit forcing the R&S SGU to switch off the
RF output.
Connect a load with sufficient return loss.

3.9  Connecting to non-screwable connectors

Non-screwable connectors of the R&S SGU are BNC type connectors on the rear
panel.

Connecting to non-screwable connectors
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► To connect the RF cable with the RF 50Ω connector, proceed as follows:

a) Carefully align the connector of the cable and the RF 50Ω connector along a
common axis.

b) Mate the connectors along the common axis until the male pin of the connector
of the cable engages with the female socket of the RF 50Ω connector.

3.10  Switching on or off

The following table provides an overview of power states, LEDs and power switch posi-
tions.
Table 3-2: Overview of power states

State LED Position of power switch

Off  gray [0]

Standby  orange [I]

Ready  green [I]

To switch on the R&S SGU

The R&S SGU is off but connected to power. See Chapter 3.6, "Connecting to power",
on page 22.

1. Set the switch on the power supply to position [I].
The switch is on the rear panel.

The LED of the [POWER ON/STANDBY] key is orange.

2. Press the [POWER ON/STANDBY] key.
Key and LED are on the front panel.

The LED changes to green. The R&S SGU boots.

When starting for the first time, the R&S SGU starts with the default settings. When
restarting the instrument, the settings depend on the instrument configuration
before shut-down.
See Chapter 8.1.1, "File menu", on page 59.

To perform functional checks

When the instrument is switched on, it automatically monitors main functions. You can
query erroneous functions.

See Chapter 14, "Error messages and troubleshooting", on page 223.

Switching on or off
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To switch between standby and ready state

► Press the [POWER ON/STANDBY] key briefly to switch the instrument from the
standby to ready state or vice versa.

In ready state, the button is green. The instrument is ready for operation. All mod-
ules are power-supplied and the R&S SGU initiates its startup procedure.
In standby state, the button is orange. The standby power mode keeps the power
switch circuits and the remote control system active.

To start up and boot

The instrument boots the operating system and starts the instrument firmware. During
the booting process, the green [POWER ON/STANDBY] key blinks. If the previous ses-
sion was terminated regularly, the instrument uses the last setup with the relevant
instrument settings.

Once the startup procedure has been terminated, the instrument is ready for operation.

In the R&S SGMA-GUI, select "Instrument > Preset" function to return the instrument
to its defined reset/preset state, if the current setup is no longer relevant.

To customize the start settings, use the "SGMA-GUI > File > Save As/Open" function.

To shut down the product

The product is in the ready state.

► Press the [POWER ON/STANDBY] key.

The operating system shuts down. The LED changes to orange.

In standby state, the power switch circuits are active. To deactivate them, disconnect
the instrument from the power supply.

To disconnect from power

The R&S SGU is in the standby state.

1. NOTICE! Risk of data loss. If you disconnect the product from power when it is in
the ready state, you can lose settings and data. Shut it down first.
Set the toggle switch on the power supply to position [0].

The LED of the [POWER ON/STANDBY] key is switched off.

2. Disconnect the R&S SGU from the power source.

3.11  Checking default settings

When the instrument is switched on, it is not the preset state that is active, but rather
the instrument state that was set before the instrument was switched off. It is recom-
mended that you use the "SGMA-GUI > Instrument > Preset" function to return the

Checking default settings
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instrument to its defined preset state every time a new configuration is required or the
current setup is no longer relevant.

The R&S SGU offers a two-stage preset concept:
● Preset the instrument to a predefined state.

The "SGMA-GUI > Instrument Name > Preset" function calls up a defined instru-
ment setup. All parameters and switching states are preset. The default instrument
settings provide a reproducible initial basis for all other settings. However, functions
that concern the integration of the instrument into a measurement setup are not
changed.

● Preset the instrument to its factory settings.
The instrument can also be forced to load its default factory settings. To access the
corresponding dialog box, select the "SGMA-GUI > Instrument Name > Setup >
Factory Preset" function.
For more information and an overview of the settings affected by the factory preset
function, see Chapter 10.8, "Factory preset", on page 117.

User-defined instrument states can be stored and called up using the functions
"SGMA-GUI > File > Save As/Open".

3.12  Working with Linux operating system

The instrument uses an embedded Linux operating system, optimally adapted to the
instrument.

Accessing the operating system
No access to the operating system is required for normal operation.
All necessary system settings can be made in the "Setup" dialog.

3.13  Connecting an external PC and devices

For control and operation, the R&S SGU requires a connection to an external device.
The external device, e.g. an external PC, controls the R&S SGU via remote control or
manual operation via the R&S SGMA-GUI software installed on the external PC.

Both the remote control and the manual operation of the instrument require an external
controller. For the prerequisites and the instructions on how to configure an external
controller for remote control, refer to the user manual. A brief introduction to the remote
control capabilities is provided in Chapter 12, "Network operation and remote control",
on page 129.

This section gives an introduction on how to configure the external PC for manual
operation. See Chapter 3.13.1, "Installing the R&S SGMA-GUI software", on page 28.

Connecting an external PC and devices
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In addition to connecting an external controller, you can connect other external devi-
ces, e.g. a memory stick. The following interfaces are on the rear panel of the
R&S SGU:

● "LAN": Chapter 3.13.2, "Connecting a remote PC via LAN", on page 30
● "PCIe": Chapter 3.13.3, "Connecting a controller via PCI Express", on page 33
● "USB In": Chapter 3.13.4, "Connecting a controller via USB", on page 33

3.13.1  Installing the R&S SGMA-GUI software

The R&S SGMA-GUI software is a graphical user interface program for one or more
instruments. It runs on a remote PC.

The R&S SGMA-GUI software is provided as separate installation package for the dif-
ferent operating systems. The latest version of the software together with the release
notes is available for download at:

http://www.rohde-schwarz.com/product/SGU100A.html > "Downloads" > "Software"

This page always offers the latest information on your R&S SGMA-GUI.

The R&S SGMA-GUI installation package for Windows 64-bit operating system con-
sists of the file SGMA-GUI_<version_number>.exe. The version number within the
file name (<version_number>=v.vv.vvv.vv) varies with each update.

To install the R&S SGMA-GUI, check that you PC and drivers fulfill the following hard-
ware and software requirements.
Table 3-3: Hardware and software requirements

Requirement Remark

Operating system:

Windows 10, 1607 "Anniver-
sary Edition" and later

Install R&S SGMA-GUI on one of the supported operating systems. Also,
make sure that Microsoft offers support for the version of the operating sys-
tem.

Note: Any other Windows version or other operating systems are not sup-
ported. During installation, the operation system is checked. The installation
is terminated if this requirement is not fulfilled.

System type:
● 64-bit operating system
● x64-based or x86-based

processor

You can only run the latest software on a 64-bit operating system.

R&S VISA VISA drivers can be obtained on the Rohde & Schwarz website:

http://www.rohde-schwarz.com/rsvisa

CPU At least Pentium or compatible, as from 1 GHz (recommended).

VGA color display resolution At least 800*600 pixels

Installing a new software version

1. Download the R&S SGMA-GUI software.

2. In Windows Explorer, navigate to the download folder of the installation file
SGMA-GUI_V.VV.VVV.VV.exe (<version_number>=v.vv.vvv.vv).

Connecting an external PC and devices
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3. Open the installation file using administrator rights.

4. Follow the instructions in the installation wizard.

After the installation of the R&S SGMA-GUI software, two icons will be shown in your
Windows menu: one is the standard version and one for which the remote command of
the software through SCPIs is disabled. The SCPI disabled version allows you to install
and use the R&S SGMA-GUI on other instruments, without interfering with the remote
control of the host instrument.

Start the version that is required for your application.

Upgrading to firmware versions 5.00.vvv.vv and later

For upgrading the R&S SGU to firmware versions 5.00.vvv.vv and later, proceed as fol-
lows:

1. Download the *.rsu file for R&S SGU firmware version 4.30.046.300.

2. Install this firmware version before installing a firmware version 5.00.vvv.vv and
later.
Follow the step-by-step description in the release notes document, see Chap-
ter 2.3.7, "Release notes and open source acknowledgment (OSA)", on page 17.

3. Download and install a firmware version 5.00.vvv.vv and later.
Follow the step-by-step description in the release notes document, see Chap-
ter 2.3.7, "Release notes and open source acknowledgment (OSA)", on page 17.

Uninstalling an old software version

You can uninstall a previous version of the software before the installing a new soft-
ware version, but this step is not mandatory.

1. To uninstall this version, go to "Start > Settings > Control Panel > Add/Remove
Programs".

2. Select the entry SGMA-GUI_V.VV.VVV.VV.

The script file identifies and removes all currently installed R&S SGMA-GUI soft-
ware items.

Connecting an external PC and devices
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3.13.2  Connecting a remote PC via LAN

The R&S SGU is equipped with a network interface and can be connected to an Ether-
net LAN (local area network). The interface can be used, for example:

● To connect an external computer for manual control of the instrument by the R&S
SGMA-GUI software.

● To operate the device by a remote control program.
See Chapter 12, "Network operation and remote control", on page 129.

This section describes how to configure the LAN interface. It covers the following top-
ics:

● Connecting to the network...................................................................................... 30
● Assigning the IP address........................................................................................ 31
● Adding instruments to R&S SGMA-GUI..................................................................32

3.13.2.1  Connecting to the network

There are two methods to establish a LAN connection to the instrument:

● A non-dedicated network (Ethernet) connection from the instrument to an existing
network.

● A dedicated network connection (Point-to-point connection) between the instru-
ment and a single computer.

In both cases, an IP address has to be assigned to the instrument and the computer,
see Chapter 3.13.2.2, "Assigning the IP address", on page 31.

Setting up a non-dedicated network (LAN) connection

► See Chapter 3.7, "Connecting to LAN", on page 23.

Setting up a dedicated network connection

If your network does not support DHCP, set a dedicated network connection between a
stand-alone PC and a R&S SGU.

Prerequisite: The external PC and the R&S SGU are turned on and running.

1. Start the R&S SGMA-GUI.

2. NOTICE! Risk of network failure.
Consult your network administrator before performing the following tasks:
● Connecting the instrument to the network
● Configuring the network
● Changing IP addresses
Errors can affect the entire network.
Connect the computer and the R&S SGU with a LAN network cable.

3. Wait for about one minute for the automatic assignment of IP addresses to com-
plete.

4. R&S SGMA-GUI main panel, select "Setup > Instruments".

Connecting an external PC and devices
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5. In the "Configure Instruments" dialog, click "Scan".

The new instrument appears with a Zeroconf IP address 169.254.xx.yy.

6. To assign a static IP address to the instrument, see "Assigning a static IP address
to the R&S SGU" on page 31.

7. To assign a static IP address to the PC, see "Assigning a static IP address to your
Windows-PC network card" on page 32.

8. To edit the instrument settings, see Chapter 8.4.2.6, "How to edit instruments",
on page 76.

3.13.2.2  Assigning the IP address

Depending on the network capacities, the TCP/IP address information for the instru-
ment can be obtained in different ways.
● If the network supports dynamic TCP/IP configuration using the Dynamic Host

Configuration Protocol (DHCP), all address information can be assigned automati-
cally.

● If the network does not support DHCP, the instrument tries to obtain the IP address
via Zeroconf (APIPA) protocol. If this attempt does not succeed or if the instrument
is set to use, alternate TCP/IP configuration, the addresses must be set manually,
see "Setting up a dedicated network connection" on page 30.

The R&S SGU uses the Zeroconf IP addresses 169.254.xxx.yyy, where xxx takes val-
ues between 1...254 and yyy the values in the value range 1...255; the subnet mask is
always 255.255.0.0. The IP address of the host must be within the same address area
for Zeroconf.

Assigning a static IP address to the R&S SGU

Prerequisites: A connection is established between the R&S SGU and the controller
with installed SGMA-GUI.

For how to set up a LAN connection, see Chapter 3.13.2.1, "Connecting to the net-
work", on page 30.

For how to set up a USB connection, see "Setting up a USB connection from a PC to
the R&S SGU" on page 33.

1. Open "SGMA-GUI > Instrument > Setup > Network Settings" dialog.

2. Set the "Address Mode" to "Static".

3. Enter the "IP Address", for example 192.168.0.1..

4. Enter the "Subnet mask", for example 255.255.255.0.

5. Enter the "Default Gateway", for example 192.168.0.1.

Connecting an external PC and devices
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Assigning a static IP address to your Windows-PC network card

1. Obtain the IP address and subnet mask for the R&S SGU and the IP address for
the local default gateway from your network administrator. If necessary, also obtain
the name of your DNS domain and the IP addresses of the DNS and WINS servers
on your network. If you use more than one LAN connector, you need separate
address information for each connector.

2. Press the "Windows" key to access the operating system.

3. Open the "Control Panel" by selecting "Start > Settings > Control Panel".

4. Select "Network and Sharing Center".

5. In the left panel, click "Change adapter settings".

6. Select the network adapter that you want to change. Click "Change settings of this
connection".

7. On the "Networking" tab, click "Internet Protocol Version 4 (TCP/IPv4)". Select
"Properties".

8. Select "Use the following IP address".

9. Enter the address information as obtained from the network administrator.

10. If necessary, you can also select "Use the following DNS server addresses" and
enter your own DNS addresses.

For more information, refer to your Windows system help.

3.13.2.3  Adding instruments to R&S SGMA-GUI

For information on how to install the R&S SGMA-GUI software, refer to Chapter 3.13.1,
"Installing the R&S SGMA-GUI software", on page 28.

1. For each new instrument perform the following steps:

a) Connect the instrument to the network.
b) Press the [POWER ON/STANDBY] key to switch on the instrument.
c) Wait until the [POWER ON/STANDBY] LED is green and not blinking.
d) Press the [ID] key on the front panel of the instrument.

2. Start the SGMA-GUI on a computer connected to the same network.

3. Open the "Instruments" dialog.

4. Select "Scan".

Note: This step is performed automatically on the first start and can also be omit-
ted for instruments with a direct LAN connection to the computer.

All instruments are added automatically to the main panel of the SIGMA-GUI.

Connecting an external PC and devices
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3.13.3  Connecting a controller via PCI Express

Using the "PCIe" interface for remote control of the R&S SGU requires extended
knowledge. See Chapter 12.3, "Advanced remote control using PCIe", on page 140.

3.13.4  Connecting a controller via USB

The USB interface on the rear panel of the R&S SGU allows you to connect either a
USB device or use the R&S SGU as a device and connect it to a controller.

Connecting a controller (host PC or compatible signal generator)

If you connect a controller (host PC or compatible signal generator) to the R&S SGU,
the R&S SGU acts as a USB device.

To connect the controller to the USB interface of the R&S SGU, always connect the
USB type Micro-B connector to the R&S SGU. Refer to the documentation of the con-
troller to find out which USB connector type you can connect to the controller.

The Figure 3-1 illustrates schematically the required connector type to emphasize on
the different connector shape.

Figure 3-1: USB type Micro-B connectors

An external PC with installed R&S SGMA-GUI is required for manual operation of the
R&S SGU.

Setting up a USB connection from a PC to the R&S SGU

If your network does not support DHCP, you can set a USB connection between a PC
and a R&S SGU.

Prerequisite: the computer and the R&S SGU are turned on and running.

1. Start the R&S SGMA-GUI.

2. Connect the computer and the R&S SGU with a USB cable.

In the "Setup > Instruments > Configure Instruments" table, the new instrument
appears automatically.
If it does not appear, open the "Setup > Instruments > Configure Instruments" dia-
log and select "Scan".

3. If your network does not support DHCP, you can now set a static IP address to
your computer.

a) To assign a static IP address to the instrument, see "Assigning a static IP
address to the R&S SGU" on page 31.

Connecting an external PC and devices
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b) To assign a static IP address to the PC, see "Assigning a static IP address to
your Windows-PC network card" on page 32.

c) To edit the instrument settings, see Chapter 8.4.2.6, "How to edit instruments",
on page 76.

Connecting a USB device

If you connect a USB device (memory stick, CD-ROM, an instrument) to the R&S SGU,
the R&S SGU acts as a host.

To connect a USB device to the interface of the R&S SGU, always connect the
USB type Micro-A connector to the R&S SGU. Refer to the documentation of the USB
device to find out which USB connector type you can connect to the USB device.

The Figure 3-2 illustrates schematically the required connector type to emphasize on
the different connector shape.

Figure 3-2: USB type Micro-A connectors

If you connect an R&S SGS to an R&S SGU via a USB cable, perform the steps as
described in Chapter 7.2, "Connecting an R&S SGS and an R&S SGU", on page 51.

Using a USB adapter
You can use a USB adapter to customize the connectors of a USB cable to the require-
ments of the instrument.
For example, use a Type-A / Micro-A adapter to customize a standard USB cable. The
customized cable connects type A and type Micro-B connectors for the connection of
an R&S SGS (acting as a host) to an R&S SGU (acting as a USB device).
Also, you can use a Type-A / Micro-B adapter to establish a connection to the instru-
ment. To check, whether the adapter you have is suitable or not you can connect a
USB stick with an LED through the adapter to the instrument. If the LED of the USB
stick lights up after a connection to the instrument then you can use this adapter for
further applications with the instrument.

Connecting an external PC and devices
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4  Instrument tour
This chapter explains the control elements and the connectors of the R&S SGU. The
views of the front panel and the rear panel help you to get familiar with the instrument
and to perform first steps. For specifications of the interfaces, see the data sheet.

The meanings of the labels on the R&S SGU are described in Chapter 1.2, "Labels on
R&S SGU", on page 13.

4.1  Front panel tour

This section provides an overview of control elements on the front panel of the
R&S SGU. The front panel contains LEDs to inform you about the status of the instru-
ment, in particular for remote control of the R&S SGU.

The connectors of the R&S SGU are on the rear panel.

1 2 3 4 5 6

Figure 4-1: R&S SGU front panel controls

1 = [POWER ON/STANDBY]
2 = [RF ON]
3 = [LO IN]
4 = [ERROR / WARNING]
5 = [LAN]
6 = [ID]

[POWER ON/STANDBY]
The [POWER ON/STANDBY] key switches the instrument from the standby to the
ready state or vice versa.
The LED above the [POWER ON/STANDBY] key indicates the instrument state, see
Table 3-2.
How to:
● Chapter 3.10, "Switching on or off", on page 25
● "To switch between standby and ready state" on page 26

[RF ON]
The [RF ON] key switches the RF signal on or off. If activated, the key is green.

Front panel tour
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Table 4-1: Overview of RF signal states

[RF ON] state LED Remark

On  green RF signal output at the RF 50Ω connector.

Off  gray No RF signal output.

How to: Chapter 3.8, "Connecting to RF 50Ω", on page 23

[LO IN]
The [LO IN] LED indicates the compatibility of the level of the local oscillator (LO) input
signal with the correct operation of the R&S SGU.
Table 4-2: Overview of local oscillator input signal states

[LO IN] state LED Remark

Correct LO input  green The level of the LO input signal is in the range of correct oper-
ation.

Error  red The level of the LO input signal is too high or too low.

Off  gray The R&S SGU is in a bypass mode.

[ERROR / WARNING]
The [ERROR / WARNING] LED indicates the status of the R&S SGU.
Table 4-3: Overview of [ERROR / WARNING] key states

[ERROR /
WARNING] state

LED Remark

Error  red Error occurred, e.g. temperature exceeded or power failure.

Running process  blinking orange Indicates a running process (e.g calibration, self-test).

No error  gray No errors or warnings occurred.

See also Chapter 14, "Error messages and troubleshooting", on page 223.

[LAN]
The [LAN] key indicates the LAN connection state.
Pressing the [LAN] key resets the network settings, e.g., "IP Adress Mode" is reset to
"DHCP".
Table 4-4: Overview of LAN connection states

[LAN] state LED Remark

Connected  green Connected to the network.

Running process  blinking orange Resets the network settings, applies the default settings.

Error  red Network error occurred.

Off  gray The internal reference signal is used.

Front panel tour
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How to:
● Chapter 3.7, "Connecting to LAN", on page 23
● Chapter 3.13.2, "Connecting a remote PC via LAN", on page 30

[ID]
The [ID] key allows you to identify your R&S SGU, e.g. in complex test setups with
more instruments.
The following applies if the R&S SGU is connected to a remote controller with
R&S SGMA-GUI installed:
● Press the [ID] key identify your R&S SGU on the remote controller. In the dialog

"SGMA-GUI > Setup > Instruments > Configure Instruments > Edit Instrument", the
R&S SGU is active.

● Set "Edit Instrument > Device Identify > On" to identify your R&S SGU from the
remote controller. The LED of the [ID] key is orange and blinking.

Table 4-5: Overview of [ID] key states

[ID] state LED Remark

Identification  blinking orange Identification of the R&S SGU.

Off/Inactive  gray No identification.

4.2  Rear panel tour

This section provides an overview of the connectors on the rear panel of the instru-
ment. For technical data of the connectors, refer to the data sheet.

1 2 3 4 5

78 6

Figure 4-2: R&S SGU rear panel controls and connectors

1 = AC power supply connector and power switch
2 = PCIe
3 = USB In
4 = LAN
5 = RF 50Ω
6 = TRIG
7 = LO IN, LO OUT
8 = I/Q

AC power supply connector and power switch
Mains power switch for performing the following tasks:
● Connecting the internal power supply to the power source
● Disconnecting the internal power supply from the power source

Rear panel tour
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How to: Chapter 3.6, "Connecting to power", on page 22

LAN
RJ-45 connector to connect the R&S SGU to a LAN for remote control.
How to:
● Chapter 3.7, "Connecting to LAN", on page 23
● Chapter 3.13.2, "Connecting a remote PC via LAN", on page 30
If the instrument acts as an extension to a signal generator, to an R&S SGS for
instance, the LAN interface can also be used for remote control of the R&S SGU.
See also Chapter 7.1.3, "Controlling the R&S SGU with an R&S signal generator",
on page 51.

PCIe
PCIe (Peripheral Component Interconnect Express) single lane interface for remote
control with optimized speed.
How to: Chapter 12.3.4, "Connecting the controller and the instrument", on page 144.

USB In
USB (universal serial bus) type Micro-B connector for remote control via various exter-
nal devices.
How to: Chapter 3.13.4, "Connecting a controller via USB", on page 33

RF 50Ω
K-type female connector for output of the RF signal.
How to: Chapter 3.8, "Connecting to RF 50Ω", on page 23

LO IN, LO OUT
SMA type connectors for local oscillator input and output signals and alternatively also
in MIMO setups.
Local oscillator input and output:
● "LO IN": Input for external LO signals
● "LO OUT": Output of internal LO signals.
How to: "To connect to screwable connectors" on page 24

TRIG
SMA female multipurpose connector for input and output signals, e.g., for the following
signals: "Trigger", "Marker 1/2", "Clock In/Out", "Sync In/Out".
Also, use the "TRIG" connector for input of an external pulse modulator signal.
How to: "To connect to screwable connectors" on page 24

I/Q
Requires R&S SGU-B120V/-B140V.
SMA female type connectors for input and output of I/Q signals.
"I/Q In" connectors are for input of external analog I/Q signals. The signals are fed
directly into the I/Q modulator.
"I/Q Out" connectors are for direct output of analog I/Q signals.
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How to: "To connect to screwable connectors" on page 24

Rear panel tour



Trying out the InstrumentR&S®SGU100A

40User Manual 1176.7726.02 ─ 10

5  Trying out the Instrument
If an R&S SGU is connected to a signal generator, the instrument acts as an extension
to the signal generator extending its frequency range.

This section provides an example on how to configure the instrument to convert a con-
tinuous wave (CW) signal.

5.1  Extending R&S SGS with the R&S SGU

If you connect the R&S SGU to a compatible Rohde & Schwarz signal generator, you
need a controller. This controller talks to the signal generator and configures the
R&S SGU.

In the following example, the instrument the R&S SGMA-GUI software controls an
R&S SGS and an R&S SGU. The R&S SGU is equipped with the frequency option
R&S SGU-B120.

Configuring the R&S SGU

This step-by-step instruction describes how to configure the R&S SGU to upconvert a
CW signal. An R&S SGS generates the CW signal. As a prerequisite for this example
the R&S SGMA-GUI software has to be installed on a remote PC.

Figure 5-1: Example of a test setup for upconverting a CW signal generated by the R&S SGS

For higher setting/ measuring speeds, use a PCIe switch and PCIe connections.

1. Connect the test equipment as shown on Figure 5-1:

a) Connect the R&S SGS, R&S SGU and the controller to a LAN switch.
b) Connect the "RF 50Ω" of the R&S SGS to the "LO IN" of the R&S SGU.

Extending R&S SGS with the R&S SGU
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c) Connect the "TRIG" connectors of the R&S SGS and the R&S SGU.
d) Connect the "RF 50Ω" of the R&S SGU to the RF input connector of the signal

analyzer.

2. Switch on the R&S SGS and the R&S SGU.

Wait until the [POWER ON/STANDBY] keys are green and not blinking.

3. If connected in a company network, press the [ID] keys on the front panels of the
R&S SGS and the R&S SGU.

4. On the connected remote PC, start the R&S SGMA-GUI software application.

The main panel of the application and the configure instruments dialog open. Both
instruments are added automatically to the instruments list and to the main panel of
the R&S SGMA-GUI software.
The main panel provides a quick access to the main settings of the configured and
activated instruments. The display shows one row per instrument with the instru-
ment-specific settings. The rows comprise the instrument, the connection state, the
used frequency and power level and the state of the RF output and the modulator.

In the R&S SGMA-GUI main panel, the green indicator indicates a connection
between the instrument and the remote PC. It also indicates that the software rec-
ognizes the instrument.

5. To restore the default configuration of this instrument, select "Instrument Name >
Preset".

6. Select "SGMA-GUI main panel > R&S SGS > Extension".

The "Extension" dialog opens.

Extending R&S SGS with the R&S SGU
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Tip: Instrument does not appear in the extension dialog. If the R&S SGU is not
automatically shown in this dialog, press "Scan > Start" to find the instrument.

7. Select the R&S SGU from the list.

8. Set "Available Instruments > Select > On" to enable it as an extension.

A green status indicator "Connected" indicates the successfully established remote
connection between the R&S SGS ant the R&S SGU. The R&S SGMA-GUI indi-
cates the extended frequency range of the R&S SGS and the activated extension
mode.

9. Select "Test Signal Connections > Test" to trigger a check of all required signal
connections.

Extending R&S SGS with the R&S SGU
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The diagram displays the connection state of the tested connections.

10. Select "SGMA-GUI > R&S SGS > Freq = 40 GHz", "Lev = -30 dBm".

11. Select "SGMA-GUI > R&S SGS > RF > State > On" to enable the output of the CW
signal.

The extension adopts these values and states automatically. Also, it generates a
CW signal with RF = 40 GHz and Level = -20 dBm.

The signal is output at the "RF 50Ω" connector on the rear panel of the R&S SGU.

Extending R&S SGS with the R&S SGU
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Identifying a specific instrument
If several instruments are active in the R&S SGMA-GUI, use one of the device identifi-
cation functions to identify a specific device:
● Select "SGMA-GUI > Instrument Name > Setup > Remote > Remote Channels >

Device Identify". On the front panel, the LED of the [LAN] key is green and blinks.
● Press the [ID] key on the instrument's front panel. The "Edit Instrument" dialog of

the respective instrument opens.

5.2  R&S SGU as a Standalone Upconverter

This section provides an example on how to configure the instrument to convert a con-
tinuous wave (CW) signal. The signal in this example is provided by an incompatible
signal generator (local oscillator).

In the following example, the instrument is manually operated via the R&S SGMA-GUI
software. The R&S SGU in this example is a base unit equipped with the frequency
option R&S SGU-B120.

Configuring the R&S SGU to convert a CW signal

As a prerequisite for this example, the R&S SGMA-GUI software has to be installed on
a remote PC and the local oscillator has to be prepared for use.

Figure 5-2: Example of a setup of the R&S SGU as an upconverter

1. Connect the test equipment as shown in Figure 5-2. Additional connections may be
needed to fulfill the requirements of the connected local oscillator. To find out what
connections are needed refer to its user manual.

2. Switch on the R&S SGU.

R&S SGU as a Standalone Upconverter
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The [POWER ON/STANDBY] key has to be green and not blinking.

3. Press the [ID] key on the front panel the R&S SGU (only required if the compo-
nents are connected via a company network).

4. On the connected remote PC, start the R&S SGMA-GUI software application.

The main panel of the application and the configure instruments dialog open. The
R&S SGU is added automatically to the instruments list and to the main panel of
the R&S SGMA-GUI software.
The main panel provides a quick access to the main settings of the configured and
activated instruments. The display shows one row per instrument with the instru-
ment specific settings. The rows comprise the instrument, the connection state, the
used frequency and power level and the state of the RF output and the modulator.

5. In the R&S SGMA-GUI main panel, the green indicator in front of the instrument's
name confirms that there is a connection between the instrument and the remote
PC and that the instrument is recognized by the software.

6. In the R&S SGMA-GUI main panel, select the row corresponding to the instrument
to be configured and select "Instrument Name > Preset" to restore the predefined
instrument's settings.

7. Select "SGMA-GUI > R&S SGU > Freq = 15 GHz", "Lev = -10 dBm", "RF > On".

R&S SGU as a Standalone Upconverter
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8. Select "SGMA-GUI > Instrument Name >Ext. Local Oscillator". Read the required
frequency and level values for the LO.

9. Change the settings of the LO to the required values.

10. Select "SGMA-GUI > Instrument Name > Ext. Local Oscillator > Confirm External
LO Settings" to apply the changes.

The 15 GHz signal is output at the "REF OUT" connector at the rear panel of the
R&S SGU.

Identifying a specific instrument
If several instruments are active in the R&S SGMA-GUI, use one of the device identifi-
cation functions to identify a specific device:
● Select "SGMA-GUI > Instrument Name > Setup > Remote > Remote Channels >

Device Identify". The green [LAN] LED on the front panel of the instrument blinks.
● Press the [ID] key on the instrument's front panel. The "Edit Instrument" dialog of

the respective instrument opens.

R&S SGU as a Standalone Upconverter
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6  Instrument control
As a rule, the R&S SGU is operated exclusively via programmatic remote control from
a connected PC. For service and diagnostic tasks, and for manual configuration, a
graphical user interface (R&S SGMA-GUI) is provided which runs on the remote PC.

Also, some basic functionality is provided via the keys on the front panel of the instru-
ment (see Chapter 4.1, "Front panel tour", on page 35).

6.1  Manual operation via R&S SGMA-GUI

The R&S SGMA-GUI software application can be installed on a PC with Windows or
Linux operating system. This program allows you to control several devices of the
SGMA product family at the same time and to monitor the device status during remote
control. R&S SGMA-GUI requires one of the external interfaces described in Chap-
ter 3.13, "Connecting an external PC and devices", on page 27.

6.1.1  Introduction to the user interface

After the start of R&S SGMA-GUI, the main dialog of the application is displayed.

The main dialog with an overview of the configured instruments is the operating and
control interface for the whole program. From here, all program functions are accessi-
ble.

The menus and dialogs are built using elements like selection lists, check boxes, and
entry fields. A blue frame indicates that the selected item is active. Entries can be
made in the highlighted element.

The main dialog comprises two main areas:
● On the top of the main panel, there are bars: the menu bar, the tool bar and the

info bar with the corresponding "Info" button.
The menu bar provides access to the functions related to the software application
itself, like saving current configurations, retrieving information about the installed
software version or configuring the connected instruments.
The messages displayed in the info line indicate information, warnings, and errors.
They are displayed in different colors depending on their importance and display
duration. Use the "Info" button to open a dialog with information on the messages
in greater detail.

Manual operation via R&S SGMA-GUI
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● The central part of the R&S SGMA-GUI main dialog is the main panel that shows
the list of all active instruments.
The main panel is the core element for the manual operation and provides quick
access to the main settings of the configured instruments. The display shows one
row per active instrument. Each row comprises the instrument's name and state,
the used frequency and level, the state of the RF output and the modulator and the
kind of used frequency reference.
The buttons with the instrument's symbolic name on it provides access to menus
and dialogs for further instrument configuration. Refer to the user manual for a
detailed description of all parameters and functions provided for configuration.

A detailed description of the R&S SGMA-GUI, in-depth information on how to work with
the application and on how to operate the R&S SGU is provided in the user manual.

6.1.2  How to use the help system

The R&S SGMA-GUI is equipped with a context-sensitive help function. A help page is
available for each parameter and can be called anytime during instrument operation.

Calling context-sensitive and general help

► To display the general help dialog box, select the "SGMA-GUI > Help > Contents"
or use the F1 key.

The help dialog is displayed. A topic containing information about the current menu
or the currently opened dialog box and its function is displayed.

Contents of the help dialog box

The help dialog box contains two main areas:
● "Contents" - contains a table of help contents
● "Topic" - contains a specific help topic

Manual operation via R&S SGMA-GUI
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The help system also provides an "Index", "Find" and "Zoom" functions that are
accessed with the corresponding buttons.

Navigating in the table of contents and in the help topics

1. To move through the displayed contents entries, use the mouse or the [Up/Down]
keys. Entries that contain further entries are marked with a plus sign.

2. To display a help topic, double click on the topic name or press the [ENTER] key.

3. To jump to the linked topic, press the link text.

4. Use the "Previous" or "Next" links to jump to the corresponding topic.

5. Use the "Scroll Right" or "Scroll Left" buttons to shift the indicated area of the navi-
gation window to the left or right.

Using the index

1. Select "SGMA-GUI > Help > Index" or use the "Go to Index" button in the "Help"
display.

2. Enter the first characters of the topic that you are interested in. The entries starting
with these characters are displayed.

3. Press the [ENTER] key to display the help topic.

The corresponding help topic is displayed.

Manual operation via R&S SGMA-GUI
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7  System overview
The R&S SGU is an instrument intended either for the modulation of IQ signals or as
an upconverter in the frequency range of 10 MHz to 40 GHz.

Optimized for use in automated test equipment (ATE), the instrument offers fast settling
times in an exceptionally small formfactor and low power consumption. The R&S SGU
can be equipped optionally with a mechanical step attenuator.

7.1  Setups for instrument control

The R&S SGU is an instrument designed for the automated test equipment (ATE)
needs. To maintain the small size, the instrument is not equipped with a display and
hence additional equipment is required to control the instrument.

This section provides an overview of the possible configuration setups for controlling
the R&S SGU.

7.1.1  Manual operation from the R&S SGMA-GUI

The following example represents a basic configuration of the R&S SGU, operated
manually by the configuration software R&S SGMA-GUI. The configuration software is
installed on a remote PC and controls several instruments. The instruments are con-
nected to the remote PC over different remote control interfaces. Any combination of
the used interfaces is possible.

Figure 7-1: Configuration example: manual control from R&S SGMA-GUI

For information about the manual control, refer to:
● Chapter 8, "Understanding the R&S SGMA-GUI software", on page 58
● Chapter 9, "Upconverter settings", on page 89
● Chapter 10, "General instrument settings and instrument setup", on page 105

7.1.2  Remote control from a controller

The remote control provides access to the instrument's settings from a remote com-
puter (external controller) by remote commands. To automate often repeating settings
and sequences, these settings are grouped in the remote control programs, i.e. appli-
cation programs.

Setups for instrument control
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An instrument can be connected to the controller via any of the supported interfaces
LAN, USB or PCIe.

Figure 7-2: Configuration example: remote control from a controller

For information about remote control, refer to Chapter 12, "Network operation and
remote control", on page 129.

7.1.3  Controlling the R&S SGU with an R&S signal generator

If an R&S SGU is connected to a compatible R&S Signal Generator (e.g. R&S SGS), it
extends its frequency range. In this setup, a controller does not need to access the
R&S SGU directly. Instead, the compatible R&S Signal Generator acts as a controller
to the R&S SGU. The generator performs all required settings automatically depending
on the required output signal parameters.

The Figure 7-3 shows a configuration example of the R&S SGU, directly controlled by
an R&S SGS. For a detailed description of the connecting possibilities, refer to Chap-
ter 7.2, "Connecting an R&S SGS and an R&S SGU", on page 51.

Figure 7-3: R&S SGU as an extension to an R&S SGS

7.2  Connecting an R&S SGS and an R&S SGU

If an R&S SGU is connected to an R&S SGS, the R&S SGU acts as an extension to
the R&S SGS extending its frequency range. In this setup, a controller does not need
to access the R&S SGU directly. Instead, the R&S SGS acts as a controller to the R&S
SGU. The generator performs all required settings automatically depending on the
required output signal parameters.

Connecting an R&S SGS and an R&S SGU
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This chapter gives an overview of how to connect the instruments. It covers the follow-
ing topics.

● Using a direct LAN connection................................................................................52
● Connecting to a company network..........................................................................53
● Connecting via a PCIe switch................................................................................. 56

7.2.1  Using a direct LAN connection

The R&S SGS and the R&S SGU can be connected through a direct connection as
shown in Figure 7-4.

Direct connection of an R&S SGS and an R&S SGU

Figure 7-4: Direct connection of an R&S SGS and an R&S SGU

1. Connect the R&S SGS and the R&S SGU directly using one of the following
options:

a) USB cable. Use a type Micro-A connector for R&S SGS and a type Micro-B
connector for R&S SGU. See also Chapter 3.13.4, "Connecting a controller via
USB", on page 33.

b) LAN cable.
c) PCIe cable. Refer to Chapter 12.3.4, "Connecting the controller and the instru-

ment", on page 144 for cable requirements and setup information.

2. Switch on the R&S SGS and the R&S SGU.

The R&S SGS automatically identifies the connected R&S SGU as its extension
and starts the extension mode.

For a direct PCIe connection, an automatic identification of the R&S SGU as an exten-
sion is only available for an R&S SGS with a " Controller > Revision" 5 or higher. For a
description on how to set the PCIe identification manually, see Chapter 11.7, "How to
set a PCIe direct connection", on page 127.
You can check the "Controller > Revision" of your instrument in the "SGMA-GUI >
Instrument Name > Hardware Config" dialog.

Connecting an R&S SGS and an R&S SGU
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If instrument is not automatically added as an extension
You can do that manually in the "SGMA-GUI > R&S SGS Name > Extension" dialog.
If the R&S SGU is not listed in the list of "Available Instruments", you can press "Scan
> Start" to find the instrument.

7.2.2  Connecting to a company network

This step-by-step instruction describes how to connect an R&S SGS and an R&S SGU
in a company network. As a prerequisite for this example the R&S SGMA-GUI software
has to be installed on a remote PC.

Figure 7-5: Connection of an R&S SGS and an R&S SGU in a company network

1. Connect the test equipment as shown in Figure 7-5:

a) Connect the R&S SGS, the R&S SGU and the controller to the company net-
work.

b) Connect the "RF 50Ω" of the R&S SGS to the "LO IN" of the R&S SGU.

Connecting an R&S SGS and an R&S SGU
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2. Switch on the R&S SGS and the R&S SGU.

Wait until the [POWER ON/STANDBY] keys are green and not blinking.

3. Press the [ID] keys on the front panels of the R&S SGS and the R&S SGU.

4. On the connected remote PC, start the R&S SGMA-GUI software application.

The main panel of the application and the configure instruments dialog open. Both
instruments are added automatically to the instruments list and to the main panel of
the R&S SGMA-GUI software.

Note: If you connect the instruments to the company network for the first time, this
process can take several minutes.

5. In the R&S SGMA-GUI main panel, the green indicator in front of the instrument's
name confirms that there is a connection between the instrument and the remote
PC. Also, it confirms that the software recognizes the instrument.

6. Select "SGMA-GUI main panel > R&S SGS > Extension".

The "Extension" dialog opens.

Connecting an R&S SGS and an R&S SGU
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Tip: Instrument does not appear in the extension dialog. If the R&S SGU is not
automatically shown in this dialog press "Scan > Start" to find the instrument.

7. Select the R&S SGU from the list.

8. Set "Available Instruments > Select > On" to enable it as an extension.

A green status indicator "Connected" indicates the successfully established remote
connection between the R&S SGS ant the R&S SGU. The R&S SGMA-GUI indi-
cates the extended frequency range of the R&S SGS and the activated extension
mode.

9. Select "Test Signal Connections > Test" to trigger a check of all required signal
connections.

Connecting an R&S SGS and an R&S SGU
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The diagram displays the connection state of the tested signal connections. If the
test connections are correct (shown by an uninterrupted blue line), you can start
using the R&S SGS and the R&S SGU in extension mode.

Tip: If your connection is marked as faulty, check whether the cables are connec-
ted properly. Check also if the connection cables are functioning properly.

Figure 7-6: A faulty connection between an R&S SGU and an R&S SGS

7.2.3  Connecting via a PCIe switch

The R&S SGS and the R&S SGU can be connected through a PCIe switch as shown
in Figure 7-7. This setup is recommended for achieving the highest setting/ measuring
speeds.

PCIe switch connection of an R&S SGS and an R&S SGU

Figure 7-7: Connection of an R&S SGS and an R&S SGU through a PCIe switch

1. Connect the PCIe switch to a switched off computer with a single lane PCIe cable.

2. Connect the R&S SGS and the R&S SGU to the PCIe switch.

3. Switch on the R&S SGS and the R&S SGU.

Wait until the [POWER ON/STANDBY] keys are green and not blinking.

4. Switch on the computer.

5. On the computer start one of the following:

a) The R&S SGMA-GUI
b) An application program for remote control of the instruments

6. Manually (or remotely) activate the R&S SGU as an extension to the R&S SGS.

Connecting an R&S SGS and an R&S SGU
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The logical connection between an R&S SGS and an R&S SGU is established by the
driver layer of a program (e.g. the R&S SGMA-GUI) or the library PCIeController.dll
(Linux: libpciecontroller.so) of a remote control program on the PC. Make sure that
such a program runs on the PC so that an R&S SGS is able to communicate with an
R&S SGU.

Connecting an R&S SGS and an R&S SGU
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8  Understanding the R&S SGMA-GUI soft-
ware
This section gives a detailed description of the R&S SGMA-GUI user interface and
information on how to work with it. The main panel with the overview of the configured
instruments is the operating and control interface for the whole program. From here, all
program functions are accessible. This panel is displayed after the start of R&S SGMA-
GUI. The software always loads the previously used settings, so you can continue your
work in the next session.

● Operating menu and toolbar................................................................................... 58
● Info dialog and messages in the info bar................................................................ 68
● Main panel...............................................................................................................70
● Working with R&S SGMA-GUI................................................................................73
● Remote control of R&S SGMA-GUI........................................................................ 81

8.1  Operating menu and toolbar

On the top of the main panel, there is the menu bar, the toolbar and the info bar with
the corresponding "Info" key. Some of the functions are accessible via the toolbar with
its icons below the menu selection line.

The dialogs are built using elements, e.g., selection lists, checkboxes, and entry fields.
A blue frame indicates that the selected item is active. In a highlighted element, entries
can be made.

Operating menu and toolbar
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Table 8-1: Content of the operating menu

File Setup Help

 New Instruments About

 Open Software Contents

Save Reset SGMA-GUI Index

 Save as Remote  

Exit   

Shut down instruments and exit   

8.1.1  File menu

The R&S SGMA-GUI employs the standard Save/Recall file management function and
allows you to save and reload settings in/to a file with a user-defined name and loca-
tion (see also Chapter 8.4.1, "Saving and loading settings", on page 73).

In the following, the "File" menu of the R&S SGMA-GUI is described in detail. It incor-
porates standard functions.

New
Resets R&S SGMA-GUI and all connected instruments to their preset settings.

Open
Opens the standard file open browser for loading a saved R&S SGMA-GUI file
(*.savrcl). The file contains the user-specific settings of a session, such as instru-
ments configured in the software. The complete settings of a session can be saved
and loaded.
Only files of this type are selectable.
Note: Instrument-specific settings, e.g. frequency and level settings, are saved locally
on the particular instrument itself. These instruments settings are saved automatically
in a predefined directory and loaded by default when starting the instrument again.
The files with instrument settings are not accessible.

Save
Standard quick save of the settings of the current session if a filename previously has
been applied. If not, the "Save As" dialog is opened.

Save as
Opens the standard file save browser for saving the settings of the current session.
R&S SGMA-GUI files have the file extension .savrcl so the name typed in is equip-
ped with this extension. The complete settings of a session are saved.

Exit
Quits the R&S SGMA-GUI. The current settings of the instrument's session are saved
and loaded by default when starting the software again.
Note: The instruments configured in the R&S SGMA-GUI are not shut down.

Operating menu and toolbar
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Shut down instruments and exit
Quits the R&S SGMA-GUI and switches the connected instruments to the standby
state (see also Chapter 11.3, "How to switch between operating states", on page 123).

8.1.2  Setup menu

Access:

► Select "SGMA-GUI > Setup"

The setup menu provides access to dialogs for setting the general settings of the
software, like dialogs for managing the connected instruments or dialogs providing
information about the installed options.

Settings

● Configure instruments.............................................................................................60
● Add/Edit instruments...............................................................................................64
● Software..................................................................................................................66
● Reset SGMA-GUI....................................................................................................67
● Remote....................................................................................................................67

8.1.2.1  Configure instruments

This dialog is the central point for managing the instrument that is configured and oper-
ated via the R&S SGMA-GUI. New instruments can be created and appended to the
list of available instruments. Connection settings can be edited, instruments can be
removed from the list or they can be deactivated, but kept in the list for further use.

Operating menu and toolbar
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Refer to Chapter 8.4.2, "Handling instruments in the R&S SGMA-GUI", on page 73 for
information on how to configure and manage instruments in R&S SGMA-GUI.

Available Instruments....................................................................................................61
Scan.............................................................................................................................. 62
New............................................................................................................................... 62
Delete............................................................................................................................62
Clear..............................................................................................................................62
Edit................................................................................................................................ 62
Export............................................................................................................................62
Scan LAN instruments with host name prefix............................................................... 63
Scan Subnet..................................................................................................................63
IP Address.....................................................................................................................63
Prefix Length................................................................................................................. 63

Available Instruments
This section comprises a list of configured instruments. Each instrument is represented
by a "Symbolic Name" which is also displayed in the main panel and an "Instrument
Type". It is also displayed whether the instrument is activated in the R&S SGMA-GUI
and hence displayed in the main panel or not.

Operating menu and toolbar
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Remote command: 
:INSTruments:COUNt? on page 84
:INSTruments:NAME on page 85
:INSTruments:TYPE on page 88
:INSTruments:ACTive[:STATe] on page 83

Scan
Triggers a scan function and searches for instruments connected to the remote com-
puter via all the available interfaces. During the scan process, a progress bar is dis-
played.
Tip: The first initialization of a newly connected instrument in a network and the instru-
ment's request to the DHCP server for an IP address may take some time. During this
time, the instrument does not respond to the query sent by the scan function. If the
instrument does not appear in the list of "Available Instruments", trigger the scan func-
tion again after some minutes.
Remote command: 
:INSTruments:SCAN on page 86

New
Calls the Add/Edit instruments dialog.

Delete
Removes the selected instrument from the list of Available Instruments.

Clear
Removes all instruments from the list of Available Instruments.

Edit
Calls the Add/Edit instruments dialog.

Export
Opens the standard file save browser for saving the list of the available instruments in
a mapping file. The mapping files have the file extension .map so the filename typed in
is automatically equipped with this extension.
A mapping file provides a cross-reference between the instruments' symbolic names
and their respective remote control parameters. The information in the mapping file is
grouped in rows, where one row corresponds to one configured instrument. The rows
have the following structure:
<InstrumentType> <SymbolicName> <IP_Address/Hostname>
<RemoteChannel> <SerialNumber>

Operating menu and toolbar
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Figure 8-1: Mapping file example

Tip: In a remote control application program, address the instruments by their symbolic
names and retrieve the remain required settings from the mapping file. This workflow is
especially useful for frequent exchange of instruments.
Remote command: 
:INSTruments:MAPPing:FILE on page 85

Scan LAN instruments with host name prefix
Sets the prefix the searched host names begin with. Use this function to limit the
amount of the searched instruments and to speed up the scan process.
For example, set this field to "RsSGS, RsSGU, RsSGT", if you want to search for all
available instruments.
If your instrument is not listed in the "Avalable Instruments" dialog, leave the field
empty and execute another scan.
Remote command: 
:INSTruments:SCAN:HNPRefix on page 86

Scan Subnet
Activates scanning of the subnet.
If you click "Scan" the scanning procedure includes instruments detected in the subnet.
Remote command: 
:INSTruments:SCAN:SNET[:STATe] on page 87

IP Address
Sets the IP address with the subnet.
Remote command: 
:INSTruments:SCAN:SNET:IPADdress on page 86

Prefix Length
Sets the prefix length in bits.
Remote command: 
:INSTruments:SCAN:SNET:PLENgth on page 87
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8.1.2.2  Add/Edit instruments

The dialog provides access to the main instrument's settings, such as "Symbolic
Name", "Instrument Type" and connection settings.

Refer to Chapter 8.4.2, "Handling instruments in the R&S SGMA-GUI", on page 73 for
information on how to configure and manage instruments in R&S SGMA-GUI.

Instrument Nr.
Automatically assigned number that indicates the instrument's index in the list of "Avail-
able Instruments".

Symbolic Name
Selects the alias name of the instrument.
Remote command: 
:INSTruments:NAME on page 85

Instrument Type
Selects the instrument's family.
Remote command: 
:INSTruments:TYPE on page 88

Active
Activates/deactivates the display of the instrument's settings in the main panel.
Note: Only instruments in an active state can be controlled from the R&S SGMA-GUI.

Operating menu and toolbar
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Remote command: 
:INSTruments:ACTive[:STATe] on page 83

Exclusive Access
Checks whether the instrument is locked by another user and if not locks the instru-
ment.
When an instrument is locked, it is reserved for manual and remote operation. Locking
means, that you can operate the instrument exclusively from the remote PC on which
the R&S SGMA-GUI is running or from which the SCPI command is sent.
For interfaces using VISA, i.e. for LAN and USB, enabling the "Exclusive Access" trig-
gers the standard viLock request. For remote control over PCIe or Socket, the lock
request is performed on a higher application level.
Tip: We recommend that you lock the instrument before further configuration. Locked
instruments are not found by the scan function. Unlock the instrument to allow opera-
tion from another remote PC.
Note: The two functions "Exclusive Access" and monitoring are mutually exclusive.
Disable "Exclusive Access" if the instrument is monitored by an external PC.
Remote command: 
:INSTruments:EACCess[:STATe] on page 84
:LOCK? on page 173
:UNLock on page 174

Device Identity
Triggers the device identification function. The [LAN] LED on the front panel of the
selected instrument blinks.
See also Chapter 8.4.4, "Bidirectional instrument identification", on page 77.

Hardware Channel
Selects the hardware interface used by the remote channel.
Remote command: 
:INSTruments:REMote:CHANnel on page 85

Instrument Name / IP Address
Enters the IP address or the host name of the connected instrument.
See also Chapter 8.4.3, "Finding out the default hostname of the instrument",
on page 76.
Remote command: 
:INSTruments:REMote:NAME on page 86

GPIB Address
Enters the GPIB address of the connected instrument.
See also Chapter 12.1.5, "GPIB interface (IEC/IEEE bus interface)", on page 137.
Remote command: 
:INSTruments:GPIB:ADDRess on page 85
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Board Number
Identifies the GPIB bus card of the controller to that the adapter is connected.
See also Chapter 12.1.5, "GPIB interface (IEC/IEEE bus interface)", on page 137.
Remote command: 
:INSTruments:GPIB:BOARd on page 85

Serial Number
Enters the serial number as instrument's identification while using the USB or PCIe
interfaces for remote control.
Remote command: 
:INSTruments:SERial on page 87

Ok
Confirms the settings and closes the dialog.

Apply
Confirms the settings.

Cancel
Discards settings and closes the dialog.

8.1.2.3  Software

Querying information about the installed options and software version

► Select "Setup > Software".

The "Versions / Options" info dialog opens, showing program information.

Software
Displays information on:
"Package" Installed software packages.
"Version" Release of the software package.
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Show Open Source Acknowledgments
Accesses the list of the used open source software packages and the corresponding
verbatim license texts.

Versions
Shows the installed software platform and its version.

8.1.2.4  Reset SGMA-GUI

Resets R&S SGMA-GUI to its factory preset settings.

The connected instruments are not affected by this preset.
To preset one specific instrument to its factory preset settings, select "SGMA-GUI >
Instrument Name > Setup > Factory Preset". Refer to Chapter 10.8, "Factory preset",
on page 117 for an overview of the settings affected by this function.

8.1.2.5  Remote

Access: "SGMA-GUI > Setup > Remote".

SCPI Port
Sets the port number of the LAN interface for remote control with TCP/IP socket proto-
col.
Set different port numbers to control different software from the same application, e.g.
R&S SGMA-GUI and R&S WinIQSIM2.
Remote command: 
:SYSTem:COMMunicate:SOCKet:PORT on page 214

8.1.3  Help

The R&S SGMA-GUI is equipped with a context-sensitive help function. A help page
can be called anytime during software operation.

The context-sensitive page which is opened with the [F1] key is part of a comprehen-
sive help system.

It is possible to move from this context-sensitive page to any page of the help system.
An overview of the contents of the online help can be reached via the menu "SGMA-
GUI > Help > Contents".

A search for keywords within the help function is available via menu item "SGMA-GUI
> Help > Index".

Operating menu and toolbar
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8.2  Info dialog and messages in the info bar

A few operating states and the current messages are displayed in the info line. For
information on messages in greater detail and their management, an "Info" dialog can
be opened.

8.2.1  Info dialog

The "Info" dialog provides a list of currently active permanent messages and a detailed
description of each message. The messages are color-coded according to their level.

Accessing the info dialog

► In the "R&S SGMA-GUI main panel", select the "Info" key.

The "Info" dialog opens.

1

2

3

1 = Info line
2 = List of current messages with short description
3 = Detailed description of a selected message

The upper part of the "Info" dialog lists the currently active permanent messages. See
the following table for explanation of the displayed information.

Info dialog and messages in the info bar
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Parameter Description

"LEV" Message level. Messages referring to a logical component of R&S SGMA-GUI, e.g.,
Unicode, are marked in red color, info messages are marked in black color.
The following level messages can occur:
● Err: Error message
● Info: Information message
● Sys: System message
● Crit: Critical message

For detailed information on the message types, see Chapter 8.2.2, "Understanding the
messages in the info bar", on page 69.

"SCPI" Indicates the SCPI error code.

Text A list of all currently permanent messages in the order of their occurrence, i.e., the most
recent message is displayed first.

The keys in the lower part of the "Info" dialog provide quick access to some functions
for managing these messages. For a detailed description on how to clear error mes-
sages or display a history of all messages, refer to Chapter 8.4.5, "Managing mes-
sages in the info dialog", on page 80.

Function Description

"Delete" Clears the highlighted message. This key is available only if the history of the mes-
sages is displayed.

"Delete All" Clears all messages.

This key is available only if the history of the messages is displayed.

"Del. volatile" Clears all brief messages. This key is available only if the history of the messages
is displayed.

"Show History/Static" Calls the list of all messages that have occurred since instrument switch-on. The
most recent messages are displayed at the top of the list. When the key is pressed
again, the list of current messages is displayed.

Refer to Chapter 8.4.5, "Managing messages in the info dialog", on page 80 for infor-
mation on how to manage messages.

8.2.2  Understanding the messages in the info bar

Messages indicate information, warnings, and errors. They are displayed in the info
line in different colors depending on their importance and display duration. The follow-
ing messages are displayed:
● Error

There are two options:
– Critical errors are errors that prevent the instrument from working, e.g. an HW

failure. Critical errors are displayed in red color.
– System errors are errors that concern the operating system, e.g., wrong file

path. System errors are displayed in black color.
● Information

Info dialog and messages in the info bar
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The information, e.g., file not found, is displayed in black color.
● Warning

A warning indicates a less significant error and is displayed in black color.
● Brief message

Brief messages report automatic settings in the program, e.g. switching on illegal
entries that are not accepted by the program, e.g., range violations. They are dis-
played in the info line on a yellow background. They are displayed on top of status
information or permanent messages.
Brief messages usually do not demand user actions and disappear automatically
after a short period of time. They are saved in the history, however.

● Permanent messages
Permanent messages are displayed if an error occurs that impairs further program
operation. The error signaled by a permanent message must be eliminated before
correct software operation can be ensured.
The message is displayed until the error is eliminated. It covers the status display
in the info line. After error elimination, the message automatically disappears and is
also recorded in the history.

8.3  Main panel

The main panel of the R&S SGMA-GUI provides quick access to the main settings of
the configured instruments. The display shows one row per instrument and comprises
the instrument name and state. It also shows the used frequency and power level, the
states of the RF output and modulator and the used reference source.

Click one of the keys with an instrument name on it to access the menu tree with fur-
ther settings for the corresponding instrument. For a detailed description of the provi-
ded settings, see:
● Chapter 10, "General instrument settings and instrument setup", on page 105 for

general settings
● Chapter 9, "Upconverter settings", on page 89 for R&S SGU settings.

Main panel
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Settings

Instrument/Connection State.........................................................................................71
Maximum Frequency.....................................................................................................72
Pulse Modulation ..........................................................................................................72
Instrument Name/ IP Address....................................................................................... 72
Frequency..................................................................................................................... 72
RF On/Off......................................................................................................................72
Mod State......................................................................................................................72
PEP............................................................................................................................... 72
Level/Level Offset..........................................................................................................72

Instrument/Connection State
The three colors of the state indicator in front of the instrument's name distinguish
between the following states:
● Gray: the instrument is configured and activated in the R&S SGMA-GUI but there is

no connection to the instrument.
● Green: the instrument is active, the connection is working and the instrument can

be manually and remotely operated.
● Red: the instrument is in one of the following states:

– Standby state
To operate the instrument manually, it has to be switched to ready state (see
"To return the instrument from standby to ready state" on page 124).

– Instrument locked
The red state indication together with the message "Instrument Locked" in the
"Info" line indicates that the instrument is locked for Exclusive Access from
another SGMA-GUI or controller.

– The instrument is performing a time consuming operation, e.g. a selftest.

Main panel
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Maximum Frequency
The numbers in the rectangular box  on the left of the instrument's name indicate the
maximum frequency of the instrument.

Pulse Modulation
A  sign on the left of the instrument's name indicates that the pulse modulation is
switched on.

Instrument Name/ IP Address
Displays the alias name of the instrument and the IP address, as set by the parameters
in "SGMA-GUI > Setup > Instruments > Add/Edit Instruments" dialog.
Click the key to access a menu tree for configuring the available instrument's settings,
e.g. "Level" settings.

Frequency
Sets the RF frequency at the RF output connector of the selected instrument.
Remote command: 
[:SOURce]:FREQuency[:CW|FIXed] on page 193

RF On/Off
Activates and deactivates the RF output signal.
The current state of the RF output (activated and deactivated) is indicated in the main
panel with the different block color (blue or gray) and the status "On/Off".
Remote command: 
:OUTPut[:STATe] on page 192

Mod State
Switches the I/Q modulation on and off.
Remote command: 
[:SOURce]:IQ:STATe on page 194

PEP
Displays the Peak Envelope Power (PEP) of the RF signal of the selected instrument.
The value is calculated as follows:
"PEP" = Level + Crest Factor
Remote command: 
[:SOURce]:POWer:PEP? on page 201

Level/Level Offset
Sets the RF level at the RF output connector of the selected instrument.
If you set a level offset, it will be indicated in the R&S SGMA-GUI main panel by a
change in the name of this parameter from "Level" to "Level Offset".

Main panel



Understanding the R&S SGMA-GUI softwareR&S®SGU100A

73User Manual 1176.7726.02 ─ 10

Note: The SCPI command [:SOURce]:POWer[:LEVel][:IMMediate][:
AMPLitude] sets the level of the "Level" display, that means the level containing off-
set while [:SOURce]:POWer:POWer sets the level at the RF output connector.

Remote command: 
[:SOURce]:POWer[:LEVel][:IMMediate][:AMPLitude] on page 200
[:SOURce]:POWer:POWer on page 202

8.4  Working with R&S SGMA-GUI

This section explains how to work with the R&S SGMA-GUI software and perform con-
figuration tasks for manual operation of the instruments.

8.4.1  Saving and loading settings

To proceed work with a particular configuration of the instruments in the R&S SGMA-
GUI, it is useful to save the used settings and load them again later.

How to save and load settings

1. Select "SGMA-GUI main panel > File > Save As".

2. Navigate to the desired directory.

3. Enter the filename.
The software adds the file extension *.savrcl automatically.

4. Select "Save".

The current settings of the software are saved to the selected file.

5. To load settings from a file, select "SGMA-GUI main panel > File > Open"

6. Navigate to the storage directory of the saved file.

7. Select this file.

Loads the saved settings to the R&S SGMA-GUI and the main panel displays the
saved configuration of the instrument.

8.4.2  Handling instruments in the R&S SGMA-GUI

This section provides information on how to configure and manage instruments in the
R&S SGMA-GUI.

For reference information about all provided settings in the user interface, refer to the
corresponding sections:
● Chapter 8.1.2.1, "Configure instruments", on page 60 and Chapter 8.1.2.2, "Add/

Edit instruments", on page 64
● Chapter 8.1.2.3, "Software", on page 66
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Chapter 8.1.2.4, "Reset SGMA-GUI", on page 67

8.4.2.1  How to add new instruments automatically

1. For each new instrument perform the following steps:

a) Connect the instrument to the network.
b) Switch on the instrument.
c) Press the [ID] key on the front panel of the instrument.

2. Start the SGMA-GUI on a computer connected to the same network.

All instruments are added automatically to the main panel of the SGMA-GUI.

8.4.2.2  How to add new instruments manually

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".

The Configure Instruments dialog opens.

2. Select the "New" key.

The Add Instrument dialog opens to register a new instrument.

3. In the "Symbolic Name" field, enter an alias name of your choice, e.g.
SGU-100021.

4. In the "Instrument Type" field, select the device family to connect to.

5. To select the hardware interface, select "Remote Control > Hardware Channel".

6. For LAN or Socket interfaces, select "Remote Control > Instrument Name / IP
Address".

7. Enter the IP address or the hostname of the connected instrument, e.g.
rssgu100a100021.
See also Chapter 8.4.3, "Finding out the default hostname of the instrument",
on page 76.

8. For USB or PCIe interfaces, select "Remote Control > Serial Number".

9. Enter the serial number of the connected instrument, e.g., 100021.

10. Set "Active > On" to activate the instrument. Only active instruments are displayed
in the R&S SGMA-GUI main panel.

11. To apply the settings, you have two options:

● Click "OK".
The dialog also closes.

● Click "Apply".
● The dialog remains opened.
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12. Click the "Cancel" key to discard settings and to close the dialog.

8.4.2.3  How to scan for new instruments

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".

The Configure Instruments dialog opens.

2. Click the "Scan" key to trigger the instrument to scan all remote channel interfaces
for connected instruments.

Tip: To limit the amount of the searched instruments and to speed up the scan
process, select "Configure Instruments > Scan LAN instruments with hostname
prefix" and enter the prefix the searched hostnames begin with.
The scan function searches only for instruments whose hostnames begin with the
selected prefix.

The" Available Instruments" list all instruments that are connected to one of the
available interfaces, switched on and not locked by a control instrument.
The R&S SGMA-GUI obtains all information for connecting to the instrument, so
further configuration is not necessary.

8.4.2.4  How to activate instruments for control

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".

The "Available Instruments" in the Configure Instruments dialog lists all instruments
configured in the software.

2. Select the new or deactivated instrument.

3. To activate the instrument, select "Active > On".

Tip: Only active instruments are displayed in the R&S SGMA-GUI main panel.

8.4.2.5  How to reserve the instrument for control

1. Open the "SGMA-GUI > Setup > Instruments > Configure Instruments" dialog.

2. Select the instrument in the list of "Available Instruments".

3. Select "Edit".

4. In the "Edit Instrument" dialog, enable "Exclusive Access".

5. Alternatively, send the SCPI command :INSTruments:EACCess[:STATe] from
the external PC that has an R&S SGMA-GUI software installation.

The instrument is reserved for control from this external PC and cannot be
accessed from any other controller. A scan function started from another controller
finds the instrument but the instrument is indicated as locked.
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The two functions "Exclusive Access" and monitoring are mutually exclusive.
The "Exclusive Access" must be disabled to remote control or monitor the instrument
form another external PC (see Chapter 12.7, "Monitoring remote control operation with
R&S SGMA-GUI", on page 160).

8.4.2.6  How to edit instruments

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".

The Configure Instruments dialog opens and lists the "Available Instruments".

2. Select the instrument, that you want to edit.

3. Click the "Edit" key.

The Edit Instrument dialog opens.

4. Change the settings.

5. Confirm with "Ok".

The edited settings are applied.

8.4.2.7  How to delete an instrument

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".
The Configure Instruments dialog opens.

2. Select the instrument, that you want to delete.

3. Click the "Delete" key.

The selected instrument is deleted from the list of "Available Instruments".

8.4.2.8  How to delete all instruments

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".
The Configure Instruments dialog opens.

2. Click the "Clear" key.

All instruments are deleted from the list of "Available Instruments".

8.4.3  Finding out the default hostname of the instrument

The default hostname of the instrument is a non-case-sensitive string built as follows:

● hostname = <instrument name><serial number>
● <serial number> is the individual serial number of the instrument.
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● <instrument name> is the complete name of the instrument, written without
spaces.

How to query the hostname of the instrument

1. Find the individual serial number on rear of the instrument, e.g. 100021.

2. Build the default hostname.

For the R&S SGU with serial number 100021, the default hostname is
rssgu100a100021.

For instructions on how to change the default hostname, refer to Chapter 11.4, "How to
use computer names", on page 125.

8.4.4  Bidirectional instrument identification

In practice, instruments are integrated into a large network or placed in racks together
with several other instruments of the same kind. It can be difficult to find out, which of
the instruments configured in the R&S SGMA-GUI corresponds to which physical
instrument. Also, localizing all instruments operated by the current controller.

The R&S SGMA-GUI and the instrument provide the "Device Identification" function for
this purpose.

How to find an instrument in the R&S SGMA-GUI

► If you activate several instruments in the R&S SGMA-GUI, press the [ID] key on
the instrument's front panel to trigger device identification.

The "Edit Instrument" dialog of this instrument opens.

Working with R&S SGMA-GUI
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Field "Edit Instrument > Symbolic Name" displays the name of the instrument as
shown in the R&S SGMA-GUI main panel.
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Dialog "Edit Instrument" does not appear
If this dialog does not open, perform the following:
● Check whether the instrument is correctly connected to the external PC on which

you work with the R&S SGMA-GUI.
● Check if the instrument is configured in the R&S SGMA-GUI and perform, if neces-

sary, the steps described in Chapter 8.4.2, "Handling instruments in the R&S
SGMA-GUI", on page 73.

● Select "SGMA-GUI > Setup > Instruments", check the state of the instrument in the
"Configure Instruments > Available Instruments" table and activate it, if disabled.

How to identify an instrument in an instrument set

1. To identify the instrument in an instrument set, use one of the device identification
functions:

● Select "SGMA-GUI > Setup > Instruments > Available Instruments > Instrument
> Edit > Edit Instrument".

● Select "SGMA-GUI > Instrument Name > Setup > Remote > Remote Chan-
nels".

● Select "SGMA-GUI > Instrument Name > Setup > LXI Status".

Working with R&S SGMA-GUI
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2. Select "Device Identify" to trigger identification.

The green [LAN] LED on the front panel of the instrument blinks.

8.4.5  Managing messages in the info dialog

How to get additional information on the message

► In the "Info" dialog, click a message to select it.

In the lower section of the dialog, additional information on the highlighted mes-
sage is displayed.

How to display all messages

► In the "Info" dialog, click the "History" key.

A history of all messages that have occurred since the R&S SGMA-GUI software
was started is listed in the upper dialog pane. The most recent message is dis-
played first.

How to delete an error message

1. In the "Info" dialog, select the highlighted message and

2. Click the "Delete" key.

Tip: This key is available only when the history of the messages is displayed.

The highlighted message is cleared.

How to delete all error messages

► In the "Info" dialog, click the "Delete All" key.

Tip: This key is available only when the history of the messages is displayed.

All messages are cleared.

How to delete all brief messages

► In the "Info" dialog, click the "Del. volatile" key.

Tip: This key is available only when the history of the messages is displayed.

All brief messages are cleared.

How to call the history

1. In the "Info" dialog, click the "History" key.
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A list of all messages that have occurred since the instrument switch-on is dis-
played. The most recent messages are displayed at the top of the list.

2. Click the "History" key once more.
The history lists current instrument messages.

8.5  Remote control of R&S SGMA-GUI

This section focuses on remote control of the R&S SGMA-GUI software. Also, all
remote-control commands are presented in detail with their parameters and the ranges
of numerical values.

Prerequisites for remote control of R&S SGMA-GUI

Remote control of R&S SGMA-GUI requires the following:
● A remote PC is connected to the SGMA instrument.
● The remote PC and the SGMA instrument are switched on.
● A connection between remote PC and the SGMA instrument is established
● The security setting "System Config > Setup > Security > SCPI over LAN" is

enabled.

For more information, see Chapter 3.13, "Connecting an external PC and devices",
on page 27.

For general information on remote control of Rohde & Schwarz products via SCPI,
refer to www.rohde-schwarz.com/rc-via-scpi.

8.5.1  Programming examples

The corresponding sections of the same title provide simple programming examples for
the R&S SGU. The purpose of the examples is to present all commands for a given
task. In real applications, one would rather reduce the examples to an appropriate sub-
set of commands.

The programming examples have been tested with a software tool which provides an
environment for the development and execution of remote tests. To keep the examples
as simple as possible, only the "clean" SCPI syntax elements are reported. Non-exe-
cutable command lines (for example comments) start with two characters //.

At the beginning of the most remote control programs, an instrument preset/reset is
recommended to set the R&S SGU to a definite state. The commands *RST and
SYSTem:PRESet are equivalent for this purpose. *CLS also resets the status registers
and clears the output buffer.

The programming examples address the following tasks:
● Example "Searching for SGMA instruments" on page 82
● Example "Scanning a subnet for SGMA instruments" on page 82
● Example "Evaluating scan results" on page 82

Remote control of R&S SGMA-GUI
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● Example "Configuring SGMA instruments" on page 83

Example: Searching for SGMA instruments
// Search for SGMA instruments using the scan function. It detects instruments
// that are connected to the remote computer via all of the available interfaces.
INSTruments:SCAN 1
*OPC?

// Query the number of available instruments.
INSTruments:COUNt?
// Response: 3
// Query instrument types.
INSTruments:TYPE?
// Response: SGU,SGS,SGT
// Query the symbolic names.
INSTruments:NAME?
// Response: SGU-100002,SGS-100006,SGT-100008
// Query the serial numbers. 
INSTruments:SERial?
// Response: 100002,100006,100008
// Query the remote channel used.
INSTruments:REMote:CHANnel?
// Response: LAN,USB,PCIe
// Query the hostname/IP address.
INSTruments:REMote:NAME?
// Response: rssgu100a100002, rssgs100a100006, rssgt100a100008

// You can also define a hostname prefix to filter detected SGMA instruments.
:INSTruments:SCAN:HNPRefix "rssg"
// The scan returns only instruments with hostname beginning with "rssg".
:INSTruments:SCAN 1

Example: Scanning a subnet for SGMA instruments
// Set the IP address of an instrument of the subnet.
INSTruments:SCAN:SNET:IPADdress 10.111.1.11
// Set the prefix length of the subnet.
INSTruments:SCAN:SNET:PLENgth 20
// Higher prefix lengths accelerate the scan but lower the ability to detect all
// instruments within the subnet.
INSTruments:SCAN 1

Example: Evaluating scan results
// Check the instrument state and activate instruments, if required.
INSTruments:ACTive:STATe?
// Response: 0,1,1
INSTruments:ACTive:STATe ON,OFF,OFF
// Activates the first instrument in the list, i.e. the instrument SGS-100006.

// Export the configuration into a mapping file.
INSTruments:MAPPing:FILE "d:\mapping_files\mapping.map"

Remote control of R&S SGMA-GUI



Understanding the R&S SGMA-GUI softwareR&S®SGU100A

83User Manual 1176.7726.02 ─ 10

// Enable exclusive access for the selected instrument.
INSTruments:EACCess:STATe?
// Response: 0,0,0
INSTruments:EACCess:STATe ON,OFF,OFF
// Locks the first instrument.

Example: Configuring SGMA instruments
// Clear the device list and add new instruments manually.
INSTruments:CLEar
INSTruments:NAME "MYSGT100A","MYSGS100A","MYSGU100A"
// Define the instrument types.
INSTruments:TYPE "SGT","SGS"
// Specify the remote interface and name or address for the instruments in the
// device list.
INSTruments:REMote:CHANnel LAN,USB,GPIB
INSTruments:REMote:NAME "10.124.1.247","RSSGS100A1000025", 
INSTruments:USB:SERial 0,0,100025
INSTruments:GPIB:ADDRess 0,0,28
INSTruments:GPIB:BOARd 0,0,0

8.5.2  R&S SGMA-GUI commands

This section comprises the SCPI commands provided for remote control of the R&S
SGMA-GUI software.

:INSTruments:ACTive[:STATe]........................................................................................... 83
:INSTruments:CLEar........................................................................................................ 84
:INSTruments:COUNt?..................................................................................................... 84
:INSTruments:EACCess[:STATe]........................................................................................84
:INSTruments:GPIB:ADDRess...........................................................................................85
:INSTruments:GPIB:BOARd..............................................................................................85
:INSTruments:MAPPing:FILE............................................................................................ 85
:INSTruments:NAME........................................................................................................ 85
:INSTruments:REMote:CHANnel....................................................................................... 85
:INSTruments:REMote:NAME............................................................................................86
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:INSTruments:SCAN:HNPRefix......................................................................................... 86
:INSTruments:SCAN:SNET:IPADdress............................................................................... 86
:INSTruments:SCAN:SNET:PLENgth................................................................................. 87
:INSTruments:SCAN:SNET[:STATe]................................................................................... 87
:INSTruments:SERial........................................................................................................87
:INSTruments:TYPE......................................................................................................... 88

:INSTruments:ACTive[:STATe] <State>

Enables/disables the instrument for the R&S SGMA-GUI. The main panel of this soft-
ware displays only activated instruments.
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Parameters:
<State> List of BOOL-values

<StateInstr#1>,<StateInstr#2>,...
0, 1, ON, OFF

Example: See Example "Evaluating scan results" on page 82.

Manual operation: See "Available Instruments" on page 61
See "Active" on page 64

:INSTruments:CLEar

Clears all instruments in the device list.

Parameters:
<Count> float

Range: 0  to  12

Example: See Example "Configuring SGMA instruments" on page 83.

Usage: Event

:INSTruments:COUNt?

Queries the number of the currently available instruments.

Return values: 
<Count> float

Range: 0  to  12

Example: See Example "Searching for SGMA instruments" on page 82.

Usage: Query only

Manual operation: See "Available Instruments" on page 61

:INSTruments:EACCess[:STATe] <State>

"Locks" the instruments, meaning the instrument is reserved and can be operated
exclusively from the remote PC that sent this SCPI command.

Tip: It is recommended to lock the instrument prior to further configuration.

Parameters:
<State> List of BOOL-values

<LockInstr#1>,<LockInstr#2>,...
0,1,OFF,ON

Example: See Example "Evaluating scan results" on page 82.

Manual operation: See "Exclusive Access" on page 65
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:INSTruments:GPIB:ADDRess <Serial>

Sets the GPIB address of the connected instrument.

Parameters:
<Serial> List of Numbers

Example: See Example "Configuring SGMA instruments" on page 83.

Manual operation: See "GPIB Address" on page 65

:INSTruments:GPIB:BOARd <Board>

Identifies the GPIB bus card the controller uses.

Parameters:
<Board> List of Numbers

Example: See Example "Configuring SGMA instruments" on page 83.

Manual operation: See "Board Number" on page 66

:INSTruments:MAPPing:FILE <File>

Saves the list of the available instruments in a mapping file. Mapping files are stored
with the predefined file extension .map; the file extension may be omitted.

The file is saved in the default directory. Use the command MMEM:CDIRectory to
change the default directory or specify the complete path.

Parameters:
<File> string

Example: See Example "Evaluating scan results" on page 82.

Manual operation: See "Export" on page 62

:INSTruments:NAME <Name>

Selects the alias name of the instruments, i.e. sets the "Symbolic Name".

Parameters:
<Name> <SymbolicNameInstr#1>,<SymbolicNameInstr#2>,...

Example: See Example "Searching for SGMA instruments" on page 82.

Manual operation: See "Available Instruments" on page 61
See "Symbolic Name" on page 64

:INSTruments:REMote:CHANnel <Channel>

Sets the hardware interface used by the remote channel.
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Parameters:
<Channel> List of CHAR-Data

<Channellnstr#1>,<Channellnstr#2>,...
The available interfaces are: LAN, USB, SOCKET, PCIe, GPIB,
HiSLIP

Example: See Example "Searching for SGMA instruments" on page 82.

Manual operation: See "Hardware Channel" on page 65

:INSTruments:REMote:NAME <Name>

Enters the IP Address or the host name of the connected instrument.

Parameters:
<Name> <Hostname/IP-AddressInsr#1>,<Hostname/IP-Addres-

sInsr#2>,...

Example: See Example "Searching for SGMA instruments" on page 82.

Manual operation: See "Instrument Name / IP Address" on page 65

:INSTruments:SCAN <State>

Triggers a scan function and searches for instruments connected to the remote com-
puter via all of the available interfaces.

Parameters:
<State> number

1 = triggers the scan function, 0 = aborts the running scan proc-
ess
The query command returns 1 as long as scan is running; 0 indi-
cates completed scan process.

Example: See Example "Searching for SGMA instruments" on page 82.

Manual operation: See "Scan" on page 62

:INSTruments:SCAN:HNPRefix <Prefix>

Sets the prefix the searched host names begin with.

Parameters:
<Prefix> string

Example: See Example "Searching for SGMA instruments" on page 82.

Manual operation: See "Scan LAN instruments with host name prefix" on page 63

:INSTruments:SCAN:SNET:IPADdress <Address>

Sets the IP address of an instrument within a subnet.
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Use the IP address to optimize scanning for instruments within a subnet.

Parameters:
<Address> string

Example: See Example "Scanning a subnet for SGMA instruments"
on page 82.

Manual operation: See "IP Address" on page 63

:INSTruments:SCAN:SNET:PLENgth <Number>

Sets the prefix length of the subnet mask.

Use the prefix length to optimize scanning for instruments within a subnet. A higher
value accelerates the scanning procedure but lowers the ability to detect all instru-
ments within the subnet.

Parameters:
<Number> integer

Range: 18  to  30
*RST: 18
Default unit: bit

Example: See Example "Scanning a subnet for SGMA instruments"
on page 82.

Manual operation: See "Prefix Length" on page 63

:INSTruments:SCAN:SNET[:STATe] <State>

Activates scanning of a subnet with given IP address and prefix length of the subnet.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: n.a. (no preset. default: OFF)

Example: See Example "Scanning a subnet for SGMA instruments"
on page 82.

Manual operation: See "Scan Subnet" on page 63

:INSTruments:SERial <Serial>

Enters the serial number as instrument's identification while using the USB interface for
remote control.

Parameters:
<Serial> <SerialNumberInstr#1>, <SerialNumberInstr#2>,...

Example: SeeExample "Configuring SGMA instruments" on page 83.

Manual operation: See "Serial Number" on page 66
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:INSTruments:TYPE <Type>

Sets the instrument type.

Parameters:
<Type> List of CHAR-Data

<TypeInstr#1>,<TypeInstr#2>,...

Example: See Example "Configuring SGMA instruments" on page 83.

Manual operation: See "Available Instruments" on page 61
See "Instrument Type" on page 64

8.5.3  List of R&S SGMA-GUI commands
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:INSTruments:CLEar........................................................................................................................................84
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9  Upconverter settings
This section summarizes the settings necessary to configure the instrument for signal
generation. The description in this section follows the menu tree structure of the graph-
ical user interface. Each of the discussed topics follows a common structure, providing
basic background information and reference to the user interface.

For step-by-step instructions for fulfilling typical tasks, refer to Chapter 11, "Performing
configuration tasks", on page 120.

● Frequency settings..................................................................................................89
● Level and power-on settings................................................................................... 90
● I/Q modulation and signal impairment.....................................................................96
● Pulse modulation...................................................................................................100
● External local oscillator settings............................................................................102
● Trigger connector settings.....................................................................................103
● Preset....................................................................................................................104

9.1  Frequency settings

Depending on the installed options, the instrument provides an adjustable output fre-
quency in the frequency range of 10 MHz to 40 GHz.

Access:

► Select "SGMA-GUI > Instrument Name > Frequency".

Configuring the RF frequency

1. To change the RF frequency of the selected instrument, perform one of the follow-
ing:

a) Select "SGMA-GUI main panel > Freq".
b) Select "SGMA-GUI > Instrument Name > Frequency/Phase > Frequency".

2. Confirm the changes of the RF frequency in the External local oscillator settings
dialog.

Frequency
Sets the RF frequency at the RF output connector of the selected instrument.
Remote command: 
[:SOURce]:FREQuency[:CW|FIXed] on page 193

Frequency settings
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9.2  Level and power-on settings

This section explains the level settings of the R&S SGU. The instrument can be equip-
ped optionally with an active electronic step attenuator (R&S SGU-B26).

Configuring RF level

1. To change the RF level of the selected instrument, perform one of the following:

a) Select "SGMA-GUI main panel > Level".
b) Select "SGMA-GUI > Instrument Name > Level > RF Level > Level".

2. Confirm the changes of the RF level in the External local oscillator settings menu.

9.2.1  RF level

Access:

► Select "SGMA-GUI > Instrument Name > Level > RF Level".

This dialog comprises settings like the RF level and level limit.

Level/Level Offset
Sets the RF level at the RF output connector of the selected instrument.
If you set a level offset, it will be indicated in the R&S SGMA-GUI main panel by a
change in the name of this parameter from "Level" to "Level Offset".

Level and power-on settings
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Note: The SCPI command [:SOURce]:POWer[:LEVel][:IMMediate][:
AMPLitude] sets the level of the "Level" display, that means the level containing off-
set while [:SOURce]:POWer:POWer sets the level at the RF output connector.

Remote command: 
[:SOURce]:POWer[:LEVel][:IMMediate][:AMPLitude] on page 200
[:SOURce]:POWer:POWer on page 202

Offset
Sets a level offset.
This value represents the level shift of a downstream instrument, as, for example, an
attenuator or an amplifier, and is indicated in the status bar of the display. It does not
change the level at the RF output.
Remote command: 
[:SOURce]:POWer[:LEVel][:IMMediate]:OFFSet on page 201

Mode
Allows you to optimize the RF output signal for applications, where improved harmonic
distortion or improved wideband noise is required.
"Normal" In normal mode, the generator provides an RF output signal with high

signal to noise ratio and low distortion, according to the data sheet.
"Low Noise" This setting forces the generator to optimize the signal to noise ratio.
"Low Distortion"

In this mode, the generator reduces distortions of the RF signal to a
minimum.

Remote command: 
[:SOURce]:POWer:LMODe on page 200

Setting Characteristic
Selects the characteristic for the level setting. For some general applications, the
instrument operation can be optimized by choosing one of the predefined level setting
characteristics.
"Auto" The instrument provides the highest dynamic range and the fastest

setting times according to the data sheet.
The RF signal is shortly blanked when you switch on the step attenu-
ator.

"Uninterrupted Level setting"
Suppresses level blanking at frequency and level changes.
This mode reduces the dynamic range of the instrument. The step
attenuator is fixed.

"Strictly Monotone"
Provides level setting without discontinuities. All electronic switches in
the RF path are clamped. The operation mode is useful for applica-
tions using level searching algorithms.
This mode further reduces the dynamic range of the instrument.

Level and power-on settings
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"Constant-VSWR"
Suppresses output impedance variations at the "RF 50Ω" connector
due to switching off the step attenuator. The step attenuator is fixed.
This mode reduces the dynamic range of the instrument.

Remote command: 
[:SOURce]:POWer:SCHaracteristic on page 200

Level Range
Displays the level range within which the level setting is expected to work properly. The
range limits depend on several parameters like "Mode", "Setting Characteristic", the I/Q
signal's crest factor and other parameters.
Remote command: 
[:SOURce]:POWer:RANGe:LOWer? on page 202
[:SOURce]:POWer:RANGe:UPPer? on page 202

Limit
Sets the level limit.
The value specifies the upper limit of the level at the "RF 50Ω" connector. A message
appears if an attempt is made to set a level above this limit and the level at the RF out-
put is confined to the upper limit. However, the level indication is not influenced.
The value is not affected by an instrument preset function. This parameter is influenced
only by the Factory preset and its factory value is equal to the upper limit.
Remote command: 
[:SOURce]:POWer:LIMit[:AMPLitude] on page 201

Readjust
Recalculates the instrument internal settings optimized for the current level. Not
required for automatic modes.
Remote command: 
[:SOURce]:POWer:ALC:SONCe on page 199

Level and power-on settings
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9.2.2  Attenuator

Access:

► Select "SGMA-GUI > Instrument Name > Level > Attenuator".

This dialog comprises the settings for the power-on behavior of the instrument.

Mode
Sets the attenuator mode at the RF output.
"Auto" Standard mode.

The electronically switching attenuator switches with a ~ 6 dB step
width at optimized switching points. The entire level range is availa-
ble. The level setting is performed by continuous electronic level con-
trol combined with switching the step attenuator.

"Fixed" The level settings are made without switching the attenuator. When
this operating mode is switched on, the attenuator is fixed in the cur-
rent position to provide level settings without interruption. The result-
ing variation range is defined and displayed under Level Range.
Note: The function is effective when automatic level control is activa-
ted ("ALC State = On"). If the normal variation range is overranged or
underranged, level errors increase considerably and the warning
"Level under/overrange" appears in the info line. The spectral purity
of the output signal decreases with high attenuation.

Remote command: 
:OUTPut:AMODe on page 191

Level Range
Requires "Attenuator > Mode = Fixed".
Displays the level range in which the level is set without interruption.
Remote command: 
:OUTPut:AFIXed:RANGe:LOWer? on page 192
:OUTPut:AFIXed:RANGe:UPPer? on page 193
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SATT Switch-Over Offset
Sets the switch-over offset value of the attenuator.
Remote command: 
[:SOURce]:POWer:ATTenuation:SOVer[:OFFSet] on page 199

RF-Off-Mode
Determines the attenuator's state after the instrument is switched off.
In default setting, the electronic step attenuator switches to highest attenuation when
RF is off. By setting the RF-Off mode, the electronic step attenuator can be fixed to
keep the output impedance constant during RF off.
Remote command: 
[:SOURce]:POWer:ATTenuation:RFOFf:MODE on page 199

9.2.3  Power-On/EMF settings

Access:

► Select "SGMA-GUI > Instrument Name > Level > Power-On/EMF".

This dialog comprises the settings for the power-on behavior of the instrument.

Power-On State
Selects the state which the RF output takes after the instrument is switched on.
"RF Off" The output is deactivated when the instrument is switched on.
"Previous Setting"

When the instrument is switched on, the output takes the same state
as it had when the instrument was switched off.

Remote command: 
:OUTPut[:STATe]:PON on page 192

Level and power-on settings
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9.2.4  ALC

Access:

► Select "SGMA-GUI > Instrument Name > Level > ALC".

Automatic level control can be used with almost all applications, especially I/Q
modulation. Deactivate it only for certain settings in the baseband and when you
activate I/Q impairments ("Impairments > On").
By default, the instrument operates in "Table & On" mode to provide the highest
level accuracy and fastest setting time. Level control can be switched to "Off
(Table)" or "On" for particular applications. The "Off (Table)" state (level control Off)
is recommended if in CW mode the signal/intermodulation ratio is to be improved
for multi-transmitter measurements.

State
Sets the internal level control.
"Table & On" Default mode.

First sets the level to the target value using the internal level table.
Then activates the level control circuit to achieve maximum level
accuracy.

"On" Internal level control is permanently activated.
If "On" and "Attenuator Mode Fixed" is selected, the level is recalibra-
ted for every level and frequency setting.

"Off (Table)" Internal level control is performed according to the ALC table.
Remote command: 
[:SOURce]:POWer:ALC[:STATe] on page 198

Detector Sensitivity
Allows you to fix the internal level detector. We recommend that you use the Auto
mode (default).
"Auto" Automatic detector selection. Recommended mode of operation.
"Low" Low sensitivity detector selected.

This setting is intended for signals with high internal electronic levels.
"Med" Medium sensitivity detector selected.

This setting corresponds to normal mode. It is intended for signals
with medium internal electronic levels.

Level and power-on settings
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"High" High sensitivity detector selected.
Selects the detector path with high sensitivity, intended for signals
with low internal electronic levels.

"Fix" Fixes the last set sensitivity setting.

9.3  I/Q modulation and signal impairment

The R&S SGU offers I/Q modulation with external analog I/Q signals. I/Q modulation
with an external analog I/Q signal is possible for the instrument equipped with fre-
quency options R&S SGU-B120V/-B140V.

The external signal is input via the "I/Q In" connectors and transferred to the I/Q modu-
lator.

Before the signal is fed into the I/Q modulator, the signal can be impaired. Impairment
at this point along the signal flow is offered to allow error correction of the supplied sig-
nal or set dedicated impairments.

9.3.1  I/Q impairments

Signal impairments are well-defined arithmetic modifications of the data. Every data
sample is modified in the same way. The purpose of adding impairments to the data
stream is to simulate frequent sources of distortions in a real signal-processing chain to
generate a test signal with dirty transmitter conditions.

9.3.1.1  Gain and gain imbalance

An I/Q gain is a multiplication of all I/Q amplitudes by a common factor. The effect is
equivalent to two identical I and Q gain factors. The effect of an increased gain factor
in the I/Q constellation diagram is shown below.

Figure 9-1: Effect of an increased amplitude in the I/Q constellation diagram

I/Q modulation and signal impairment



Upconverter settingsR&S®SGU100A

97User Manual 1176.7726.02 ─ 10

An I gain multiplies the I amplitudes by a factor, leaving the Q amplitudes unchanged.
A Q gain has the opposite effect. Different I and Q gain factors result in an I/Q imbal-
ance. The imbalance is usually due to different gains of the amplifiers in the I and Q
channels of the I/Q modulator. The effect of a positive and negative gain imbalance is
shown below.

Figure 9-2: Negative gain imbalance (left) and positive (right) gain imbalance in the I/Q constellation
diagram

9.3.1.2  I and Q offset

An I offset adds a constant value to all I amplitudes, leaving the Q amplitudes
unchanged. A Q offset has the opposite effect. A combination of I and Q values results
in an I/Q offset, which is usually due to carrier feedthrough in the I/Q modulator. Possi-
ble reasons are interfering signals at the RF carrier frequency, e.g. an unsuppressed
RF carrier subchannel. The effect of a positive I and Q offset in the I/Q constellation
diagram is shown below.

Figure 9-3: I offset (left) and Q offset (right) in the I/Q constellation diagram

I/Q modulation and signal impairment
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9.3.1.3  Quadrature offset

Changes the phase angle between the I and Q vectors from the ideal 90 degrees,
while the amplitudes are maintained. A positive quadrature offset results in a phase
angle greater than 90 degrees. The effect of a positive quadrature offset in the I/Q con-
stellation diagram is shown below.

Figure 9-4: Positive quadrature offset in the I/Q constellation diagram

9.3.2  General I/Q settings

Access:

► Select "SGMA-GUI > Instrument Name > I/Q Settings > General".

Comprises the settings for setting the state and the analog wideband I/Q input.

Mod State
Switches the I/Q modulation on and off.
Remote command: 
[:SOURce]:IQ:STATe on page 194

Crest Factor
Sets the crest factor of the I/Q modulation signal.

I/Q modulation and signal impairment
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The crest factor gives the difference in level between the peak envelope power (PEP)
and average power value (RMS) in dB. This value is necessary for the generation of
the correct output power at the RF output, i.e. the instrument uses the PEP value to
compensate the average power.
The maximum input voltage at the I/Q input is equated to the peak power and is used
as the "reference" for setting the level of the output signal. The signal does not usually
supply the peak power at a constant level. It supplies lower average power. The crest
factor specifies how many decibel (dB) the software has to add internally to reach cor-
rect output power.
Remote command: 
[:SOURce]:IQ:CREStfactor on page 196

9.3.3  Analog impairment settings

Access:

► Select "SGMA-GUI > Instrument Name > I/Q Settings > Analog Impairments".

Comprises the settings like I/Q offset and quadrature offset.

State
Activates/deactivates I/Q impairments.
If activated, the settings for offset, gain imbalance and quadrature offset become effec-
tive.
Note: We recommend that you switch automatic level control to the "Off (Table)" mode.
Otherwise level errors can occur.
Remote command: 
[:SOURce]:IQ:IMPairment:STATe on page 196

I/Q modulation and signal impairment
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Offset
Sets the carrier offset (in percent) of the amplitudes (scaled to the peak envelope
power (PEP) for the I and/or Q signal component. An ideal I/Q modulator suppresses
the carrier offset completely (offset = 0 percent).
For more information, see Chapter 9.3.1.2, "I and Q offset", on page 97.
Remote command: 
[:SOURce]:IQ:IMPairment:LEAKage:I on page 195
[:SOURce]:IQ:IMPairment:LEAKage:Q on page 195

Gain Imbalance
Sets the imbalance of the I and Q vector (see Chapter 9.3.1.1, "Gain and gain imbal-
ance", on page 96).
The entry is made in dB (default) or %, where 1 dB offset is roughly 12 % according to
the following:
Imbalance [dB] = 20log ( | GainQ | / | GainI |)

Positive values mean that the Q vector is amplified more than the I vector by the corre-
sponding percentage. Negative values have the opposite effect.
Remote command: 
[:SOURce]:IQ:IMPairment:IQRatio on page 195

Quadrature Offset
Sets the quadrature offset (see Chapter 9.3.1.3, "Quadrature offset", on page 98).
Remote command: 
[:SOURce]:IQ:IMPairment:QUADrature[:ANGLe] on page 195

9.4  Pulse modulation

The R&S SGU offers pulse modulation using external pulse signals. To receive exter-
nal pulse signals, connect the signal source to the "TRIG" connector on the rear panel
of the R&S SGU.

Pulse modulation
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9.4.1  Pulse modulation settings

Access:

► Select "SGMA-GUI > Instrument Name > Pulse Modulation".

The "Pulse Modulation" dialog contains all parameters required to configure pulse
modulation and pulse signal generation.

State
Sets the state of the pulse modulator.
Remote command: 
[:SOURce<hw>]:PULM:STATe on page 202

Polarity
Sets the polarity of the pulse modulator signal.
"Normal" The RF signal is suppressed during the pulse pause.
"Inverse" The RF signal is suppressed during the pulse.
Remote command: 
[:SOURce<hw>]:PULM:POLarity on page 203

9.4.2  Pulse connector/trigger settings

Access:

► Select "SGMA-GUI > Instrument Name > Pulse Modulation > Connector/Trigger".

Pulse modulation



Upconverter settingsR&S®SGU100A

102User Manual 1176.7726.02 ─ 10

Comprises the settings necessary to configure the signal at the multi-purpose
"TRIG" connector in the external trigger mode.

Trigger Connector Mode
Determines the signal at the input/output of the multi purpose [TRIG] connector.
"Signal Valid"

Output of high signal to mark valid frequency and level settings.
"Not Signal Valid "

Output of high signal to mark the transition state when frequency and
level change.

"Pulse Mod Ext Source"
Input for an externally provided pulse modulation signal
Used when an external pulse modulator source is provided at the
connector.

Remote command: 
:CONNector:TRIGger:OMODe on page 180

9.5  External local oscillator settings

You can also connect the R&S SGU to an incompatible signal generator (local oscilla-
tor). The controller has to change the frequency and the level of this local oscillator
(LO) to output the signal as configured from the R&S SGU. The "Local Oscillator" dia-
log provides related settings.

Access:

► Select "SGMA-GUI > Instrument Name >Ext. Local Oscillator".

When changing any parameters which affect the output signal of the combined system
of an incompatible LO and an R&S SGU, follow these steps:

Setting the signal of the R&S SGU

1. Set the parameters of the R&S SGU like frequency and level in the R&S SGMA-
GUI as needed.

2. Open the "SGMA-GUI > Instrument Name >Ext. Local Oscillator" dialog.

3. Read the settings for "Frequency" and " Level".

External local oscillator settings
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4. Apply the required changes to the LO.

5. Press the "Confirm External LO Settings" button to confirm that you have made the
settings on the LO.

The desired signal is output by the R&S SGU.

Frequency
Shows the desired frequency for the LO input signal.
Remote command: 
[:SOURce]:LOSCillator:FREQuency? on page 197

Level
Shows the desired level for the LO input signal.
Remote command: 
[:SOURce]:LOSCillator:POWer? on page 198

Confirm External LO Settings
Outputs the signal.
Remote command: 
[:SOURce]:SETTings:APPLy[:IMMediate] on page 193

9.6  Trigger connector settings

Access:

► Select "SGMA-GUI > Instrument Name > Connector".

This dialog comprises the settings for configuring the connector.

Trigger Connector Mode
Determines the signal at the input/output of the multi purpose [TRIG] connector.
"Signal Valid"

Output of high signal to mark valid frequency and level settings.
"Not Signal Valid "

Output of high signal to mark the transition state when frequency and
level change.

"Pulse Mod Ext Source"
Input for an externally provided pulse modulation signal
Used when an external pulse modulator source is provided at the
connector.

Trigger connector settings
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Remote command: 
:CONNector:TRIGger:OMODe on page 180

9.7  Preset

Calls up a defined instrument setup. Presets all parameters and switching states
including inactive operating modes. The default instrument settings provide a reprodu-
cible initial basis for all other settings. However, functions that concern the integration
of the instrument into a measurement setup are not changed.

Overview of the most important preset states

The following list gives an overview of the presets for the most important generator set-
tings. The other presets can be found in the information accompanying the remote
commands.
● "RF frequency" = 1 GHz
● "RF output" switched off
● "Modulator State" = Off

Settings that are not affected by the "SGMA-GUI > Instrument Name > Preset" func-
tion:
● Power on settings ("Level" dialog)
● Network settings ("Setup" dialog)
● Password and settings protected by passwords ("Setup" dialog)

To preset the R&S SGMA-GUI itself and all configured instruments to their predefined
state, use the "SGMA-GUI > File > New" function.

SCPI command:

:SYSTem:PRESet on page 174

Preset
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10  General instrument settings and instrument
setup
This section describes the settings which do not directly affect signal generation.

Access:

1. Select "SGMA-GUI > Instrument Name > Setup".

2. Select the required dialog.

Settings

● Hardware configuration.........................................................................................105
● Software / options................................................................................................. 107
● Install SW options................................................................................................. 109
● Protection..............................................................................................................109
● Security................................................................................................................. 110
● Network settings....................................................................................................113
● Remote channels.................................................................................................. 116
● Factory preset....................................................................................................... 117
● Eco mode.............................................................................................................. 118
● Standby and restart...............................................................................................118
● Diagnostic and tests..............................................................................................119

10.1  Hardware configuration

Querying information about the installed assemblies

► Select "SGMA-GUI > Instrument Name > Setup > Hardware Config".

In the "Hardware Config" dialog, the installed assemblies together with their var-
iants and revision states can be displayed for servicing purposes.

Hardware configuration
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The dialog is a table that lists the installed assemblies. It is divided into the sec-
tions:
● "Common Assembly"
● "RF Assembly"

Settings

Assembly.....................................................................................................................106

Assembly
The tables list the installed assemblies.
"Assembly" Name of the assembly
"Part Number" Part number of the assembly
"Serial Number"

Serial number of the assembly
"Revision" Revision state of assembly
Remote command: 
:SYSTem:HARDware:ASSembly<dir>:SNUMber? on page 215

Hardware configuration
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10.2  Software / options

Querying information about the installed options and software version

► Select "SGMA-GUI > Instrument Name > Setup > Software/Options".

The "Software/Options" dialog shows the firmware version of the instrument soft-
ware and all installed hardware and software options.

The dialog is divided into the following sections:
● "Firmware"
● "Hardware"
● "Software"
● "Loaded Modules"

Software / options
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Software options purchased at a later stage can be activated with a keycode. The acti-
vation code is supplied with the software option. An instruction on how to install options
is described in the service manual. You can install most hardware options at an author-
ized Rohde & Schwarz service center.

Settings

Software...................................................................................................................... 108
Hardware / Software/WinIQSIM.................................................................................. 108
Loaded Modules..........................................................................................................108
Show Open Source Acknowledgments.......................................................................108
LucasFonts RSCorpid EULA.......................................................................................108

Software
Shows the software/firmware version and the version of the software platform.
Note: Your instrument is delivered with the latest firmware version available. Firmware
updates and the release notes are provided on the Internet at the download site of the
instrument's home page. This home page always offers the latest information on your
instrument, e.g. also on changes of the firmware update procedure.

Hardware / Software/WinIQSIM
The tables in the sections "Hardware" and "Software" list the installed hardware and
software options.
"Option" Short name of the option
"Designation" Name of the option
"Licenses" Number of licenses
"Expiration Date"

For regular options, "Permanent" is indicated in this column. Some
options are available as trial versions. This column shows their expi-
ration date. After this date, the option is no longer available on the
instrument.

Loaded Modules
Section "Loaded Modules" is provided for service purposes. It lists all loaded software
modules with their versions and offers a short description of each module.

Show Open Source Acknowledgments
Accesses the list of the used open-source software packages and the corresponding
verbatim license texts.
For R&S SGMA-GUI, the list shows the open-source acknowledgement for software
with Windows® operating system.
For R&S SGU/SGS/SGT, the list shows the open-source acknowledgement for soft-
ware with Linux® operating system.

LucasFonts RSCorpid EULA
Accesses copyright information on LucasFonts font type RSCorpid EULA.

Software / options
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10.3  Install SW options

Newly purchased software options are enabled in the "Install SW-Option" dialog. They
are ready to operate after they are enabled by a key code supplied with the option.

Only if the instrument is equipped with an older firmware version, a firmware update
before enabling the software option can be required. The information on the valid firm-
ware versions for the purchased software option is provided together with the option.

See:
● Chapter 11.5, "How to install a new firmware version on the instrument",

on page 125 for information on how to perform firmware update
● Chapter 11.6, "How to activate options", on page 127 for instruction on how to

install new options

The firmware update is also described in the service manual.

10.4  Protection

The "Protection" dialog provides access to the unlocking of protected service functions
(authorized personnel of R&S service departments only).

Unlocking protected service functions

1. Select "SGMA-GUI main panel > Instrument Name > Setup > Protection".

The "Protection" dialog provides access to the unlocking of protected service func-
tions (authorized personnel of R&S service departments only).

2. To deactivate the protection, enter the correct password. After booting the instru-
ment, protection levels 1 to 4 are active.
Enter "Protection Level 1 > Password > 123456".

Protection Level 1 is activated.

Protection
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Settings

Protection Level / Password........................................................................................110

Protection Level / Password
"Protection Level 1" can be activated to expand the functionality of the internal adjust-
ment. The password is 123456.
The other protection levels 2 to 4 provide access to protected service functions. Only
the authorized personnel of R&S service departments can access these functions.

10.5  Security

The R&S SGU employs a security concept based on user and security password. The
security password is required for changing several critical settings, like performing firm-
ware updates. Access to the passwords and mass storage security settings is provided
in the "Security" dialog.

Access:

► Select "SGMA-GUI > Instrument Name > Setup > Security".

The dialog is divided into the password sections and the security settings section. In
the password section, the passwords for securing a controlled access to the instrument
are defined and changed.

A change of passwords for the operating system and security password requires the
entry of the old and new password and the conformation of the new password. All set-
tings are only accepted after the "Change Password" button is pressed.

Security
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The settings of this dialog are not accessible over remote control (e.g. SCPI com-
mands).

Settings

User Password............................................................................................................ 112
└ User Name.................................................................................................... 112
└ Old Password................................................................................................112
└ New Password.............................................................................................. 112
└ Confirm Password.........................................................................................112
└ Change Password.........................................................................................112

Security Password.......................................................................................................112
└ Old Password................................................................................................112
└ New Password.............................................................................................. 112
└ Confirm Password.........................................................................................112
└ Change Password.........................................................................................113

Security Settings..........................................................................................................113
└ USB Storage................................................................................................. 113

Security
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└ LAN Interface................................................................................................ 113
└ Security Password........................................................................................ 113
└ Accept........................................................................................................... 113

User Password
The user name and password are required for remote access to the instrument via
VNC, FTP or SAMBA.
Note: It is highly recommended to change the default user password before connect-
ing the instrument to the network.
Note: Note that you cannot reset the password to factory state.
If you encounter problems with the password, contact the Rohde & Schwarz customer
support, see Chapter 14.5, "Contacting customer support", on page 226.

User Name ← User Password
Indicates the user name used for access to the Linux operating system and valid for
VNC, FTP and SAMBA access.

Old Password ← User Password
Enter the currently used user password. The default password is "instrument".

New Password ← User Password
Enter the new user password.

Confirm Password ← User Password
Enter the new password for conformation.
The new password is only valid after the "Change Password" button is pressed.

Change Password ← User Password
Changes the password accordingly.

Security Password
The security password is, for example, required when changing the status of the USB
and LAN interface or other security settings.
Note: It is highly recommended to change the default security password before con-
necting the instrument to the network.
Note: Note that you cannot reset the password to factory state.
If you encounter problems with the password, contact the Rohde & Schwarz customer
support, see Chapter 14.5, "Contacting customer support", on page 226.

Old Password ← Security Password
Enter the currently used security password. The default password is '123456'.

New Password ← Security Password
Enter the new security password. The security password can only contain decimal
characters.

Confirm Password ← Security Password
Enter the new password for conformation.

Security
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The new password is only valid after the "Change Password" button is pressed.

Change Password ← Security Password
Changes the password accordingly.

Security Settings
Comprises the settings for enabling and disabling the USB and LAN interfaces. The
setting requires the entry of the security password and is only accepted after the
"Accept" button is pressed.

USB Storage ← Security Settings
Enables/disables the access to external USB storage media.
The instrument does not recognize any device connected to the USB interface when
the interface is disabled.
To apply the change: enter the security password and confirm with "Accept". Otherwise
the change has no effect.
Note: Remove all USB memory devices before disabling the USB storage. If any USB
memory device remains connected, disabling is blocked, and the instrument returns a
warning message.

LAN Interface ← Security Settings
Enables/disables the LAN interface.
Note: It is not possible to access the instrument via LAN while the LAN connection is
disabled.
An enabled LAN connection is a prerequisite for the remote control of the instrument
via VNC, FTP or SAMBA.
To disable the LAN interface enter the security password and confirm with "Accept".
Otherwise the change has no effect.

Security Password ← Security Settings
Enters the password that is required to enable or to disable the settings protected by a
security password. The default is '123456'.
Note: It is highly recommended to change the default security password before con-
necting the instrument to the network. To change the security password, select
"SGMA-GUI > Instrument Name > Setup > Security > Change Security Password".
The settings are only accepted after the "Accept" button is pressed.

Accept ← Security Settings
Accept a new entry or selection and change the settings accordingly.

10.6  Network settings

The instrument is equipped with a network interface and can be connected to an Ether-
net LAN (local area network). The "Network Settings" dialog provides access to the
network settings.

Network settings
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Access:

► Select "SGMA-GUI > Instrument Name > Setup > Network Settings".

The dialog provides access to the network settings, like settings about the general net-
work environment and specific identification of the computer in the network. The dialog
also displays an indication whether the instrument is connected to the network or not.

Settings

Restart Network...........................................................................................................114
Hostname.................................................................................................................... 114
MAC Address.............................................................................................................. 115
Address Mode............................................................................................................. 115
IP Address...................................................................................................................115
Subnet Mask................................................................................................................115
Default Gateway..........................................................................................................116
Apply............................................................................................................................116

Restart Network
Shuts down the network connection of the instrument and then re-establishes the con-
nection.
This function can be used to resolve network problems.
Note: Only the connection of the instrument to the network restarts, the network itself
is not affected.

Hostname
Displays the individual computer name of the instrument.

Network settings
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A predefined name is indicated and can be used for network connections, see Chap-
ter 8.4.3, "Finding out the default hostname of the instrument", on page 76.
It is recommended that a connection of the instrument to the network is coordinated
with the network administrator. Connection errors can affect the entire network.
Remote command: 
:SYSTem:COMMunicate:NETWork[:COMMon]:HOSTname on page 212

MAC Address
Indicates the MAC address of the network adapter.

Address Mode
Selects if the IP address is assigned automatically or manually.
It is recommended that a connection of the instrument to the network is coordinated
with the network administrator. Connection errors can affect the entire network.
Note: Lost LAN connection to an instrument.
If the connection to an instrument configured to use static IP addresses is lost, press
the [LAN LED] on the instrument front panel.
Pressing triggers a reset of the assignment mode ("Address Mode > Auto (DHCP)".
"Auto (DHCP)" The IP address is assigned automatically.

The network used must support automatic assignment of IP address
via DHCP or APIPA (Zeroconf) to use this function.

"Static" The IP address is assigned manually.
Remote command: 
:SYSTem:COMMunicate:NETWork:IPADdress:MODE on page 211

IP Address
Displays the IP address. To enter the IP address manually, select "Address Mode >
Static".
If there is manual input of the IP address, it is recommended that a connection of the
instrument to the network is coordinated with the network administrator. Connection
errors can affect the entire network.
Remote command: 
:SYSTem:COMMunicate:NETWork:IPADdress on page 211

Subnet Mask
Displays the subnet mask. To enter the subnet mask manually, select "Address Mode >
Static".
This number is used together with the IP address to identify the network segment the
instrument is in.
It is recommended that a connection of the instrument to the network is coordinated
with the network administrator. Connection errors can affect the entire network.
Remote command: 
:SYSTem:COMMunicate:NETWork[:IPADdress]:SUBNet:MASK on page 213

Network settings
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Default Gateway
Displays the IP address of the default gateway. To enter the default gateway manually,
select "Address Mode > Static".
This address identifies the router on the same network as the instrument that is used to
forward traffic to destinations beyond the local network.
It is recommended that a connection of the instrument to the network is coordinated
with the network administrator. Connection errors can affect the entire network.
Remote command: 
:SYSTem:COMMunicate:NETWork[:IPADdress]:GATeway on page 212

Apply
Applies the network settings to the instrument.

10.7  Remote channels

Access:

► Select "SGMA-GUI > Instrument Name > Setup > Remote".

The "Remote" dialog provides access to the settings for remote control.

Settings

Visa Resource Strings.................................................................................................116
Device Identity.............................................................................................................117

Visa Resource Strings
Indicates the VISA resource strings used for remote control of the instrument. A sepa-
rate string is provided for remote control via the different interfaces.

Remote channels
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Note: For background information and description of the syntax of the VISA resource
strings, refer to the description of the corresponding interface in Chapter 12.1, "Remote
control interfaces and protocols", on page 129.
Remote command: 
:SYSTem:COMMunicate:HISLip:RESource? on page 213
:SYSTem:COMMunicate:NETWork:RESource? on page 213
:SYSTem:COMMunicate:SOCKet:RESource? on page 214
:SYSTem:COMMunicate:USB:RESource? on page 215
:SYSTem:COMMunicate:PCIexpress:RESource? on page 213

Device Identity
Triggers the device identification function. The [LAN] LED on the front panel of the
selected instrument blinks.
See also Chapter 8.4.4, "Bidirectional instrument identification", on page 77.

10.8  Factory preset

The "Factory Preset" dialog provides a function to reset the instrument's settings to
their factory states.

Access:

1. Select "SGMA-GUI > Instrument Name > Setup > Factory Preset".

2. Select "Execute Factory Preset".

The instrument's settings are reset to their factory states. Security settings and
user data are not affected.

Settings

Execute Factory Preset............................................................................................... 117

Execute Factory Preset
Reset the instrument's settings to their factory state.
Note: Because "Factory Preset" resets the "Remote Channel Settings" and "Network
Settings" to the default values, executing factory preset via remote control can termi-
nate the connection to the instrument, if these settings had been configured to values
different to the default ones.

Factory preset
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The factory preset function resets nearly all instrument settings. In addition to the regu-
lar preset, a "Factory Preset" resets also the following values:
● Power on settings ("Level" dialog)
● Network settings including hostname ("Setup > Network Setting" dialog)
● Remote Channel settings ("Setup > Remote Channel" dialog)
● Eco mode state ("Setup > Eco Mode" dialog)
To maintain security, password settings and all settings protected by these passwords
like disabled USB and LAN connections are not changed.
Not affected by the "Factory Preset" are also user data, lists or instrument settings
files, created, for example, with the "File Save As" function.
Remote command: 
:SYSTem:FPReset on page 175

10.9  Eco mode

This energy-saving mode is available only for instruments equipped with
optionR&S SGU-B140/B140V.

Access:

► Select "SGMA-GUI > Instrument Name > Setup > Eco Mode".

With enabled "Eco Mode 1", the doubler stage in a 40 GHz instrument is perma-
nently switched off to reduce power consumption and the maximum frequency is
limited to 20 GHZ. An enabled "Eco Mode" is indicated by a green coloring of the
frequency range in the R&S SGMA-GUI.

The state of this parameter is not affected by an instrument "Preset". This parame-
ter is influenced only by the Factory preset.

SCPI command:

10.10  Standby and restart

See Chapter 11.3, "How to switch between operating states", on page 123.

Standby and restart



General instrument settings and instrument setupR&S®SGU100A

119User Manual 1176.7726.02 ─ 10

10.11  Diagnostic and tests

This section describes the settings provided for diagnostic and test purposes.

Access:

► Select "SGMA-GUI > Instrument Name > Setup > Diagnostic / Test".

The selection provides the following settings.

Settings

● Keyboard tests...................................................................................................... 119

10.11.1  Keyboard tests

Access:

► Select "SGMA-GUI > Instrument Name > Diagnostic Tests > Keyboard Test".

Use this function to check the proper operation of all front panel elements.

If "Keyboard Test" is enabled, all front panel LEDs except the [POWER ON] are
orange.

The exact test procedure is described in the service manual.

SCPI command:

:TEST:KEYBoard[:STATe] on page 218

Diagnostic and tests
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11  Performing configuration tasks
This section provides a general explanation on how to operate the instrument manually
via the R&S SGMA-GUI software.

We assume, that the R&S SGU is connected to a remote PC. The R&S SGMA-GUI
software is installed on this remote PC and the instrument has to be added to the list of
"Available Instruments".

For information on how to fulfill these requirements, refer to:
● Chapter 3.13.2.1, "Connecting to the network", on page 30
● Chapter 3.13.1, "Installing the R&S SGMA-GUI software", on page 28
● Chapter 3.13.2.3, "Adding instruments to R&S SGMA-GUI", on page 32

11.1  How to generate I/Q signals

Options R&S SGS-B112V and R&S SGU-B120V/-B140V are required for the I/Q mod-
ulation.

To generate an I/Q modulated signal with higher frequency

In this example, the R&S SGU acts as an extension to the R&S SGU extending its fre-
quency range to 40 GHz.

The Figure 11-1 shows an example of the test setup.

How to generate I/Q signals



Performing configuration tasksR&S®SGU100A

121User Manual 1176.7726.02 ─ 10

Figure 11-1: Example of the test setup

For higher setting/ measuring speeds, use a PCIe switch and PCIe connections.

If a common reference frequency is required, use the internal reference signal of the
signal generator and provide it to the R&S SGU and the connected signal analyzer,
e.g. the R&S FSW.

1. Connect the test equipment as shown on Figure 11-1:

a) Connect the R&S SGS, the R&S SGU and the controller to a LAN switch.
b) Connect the "I/Q OUT" of the base band signal source to the " I/Q IN" of the

R&S SGU.
c) Connect the "I/Q OUT" of the R&S SGS to the I and Q connectors of the R&S

SGS.
d) Connect the "RF 50Ω" of the R&S SGS to the "LO IN" of the R&S SGU.
e) Connect the "TRIG" connectors of the R&S SGS and the R&S SGU.
f) Connect the "RF 50Ω" of the R&S SGU to the RF input connector of the signal

analyzer.

2. Select "SGMA-GUI main panel > R&S SGS > Extension".

Tip: Steps 3 to 5 can be omitted if the R&S SGS and a single R&S SGU are con-
nected using PCIe or USB or by a direct LAN connection. In this case, the R&S
SGS automatically activates the R&S SGU.

3. Press the ID key on the front panel of the R&S SGU (only required if you connect
the components via a company network).

4. In the "Extension" dialog, trigger "Scan".

How to generate I/Q signals
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The scan function finds out the connected R&S SGU.

5. To enable the R&S SGU as an extension, proceed as follows:

a) Select the R&S SGU from the list
b) Set "Available Instruments > Select > On".

A green status indicator "Connected" indicates the successfully established remote
connection to the extension.

6. Select "Test Signal Connections > Test" to trigger a check of all required signal
connections.

The diagram displays the connection state of the tested connections.

7. Configure RF output signal settings:

a) Select "SGMA-GUI > R&S SGS > Freq = 20 GHz".
b) Select "Lev = -30 dBm".
c) Activate the RF output: Select "RF > State > On".

The extension adopts these values and states automatically. Generated is an I/Q
signal with "RF = 20 GHz" and "Level = -30 dBm".

How to generate I/Q signals
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11.2  How to restore the LAN connection

If you lose the LAN connection of the instrument, for example, after assigning a static
IP address, proceed as follows:

► On the front panel of the instrument, press the [LAN] LED for more than 3 seconds.

Pressing trigger a reset of the LAN settings. In particular, the "Address Mode"
on page 115 switches to "DHCP".

If your network supports automatic assignment of IP address, the new IP address
is assigned to the instrument automatically.

11.3  How to switch between operating states

The Figure 11-2 gives an overview of the operating states of the instruments and how
to trigger the switch-over between them.

Figure 11-2: Operating states

:RESTart, :STANdby = SCPI commands
"Setup" > "Standby", "Setup" > "Restart", "Shut Down Instru-
ments and Exit"

= R&S SGMA-GUI controls

[POWER ON/STANDBY], power switch [ I/0] = Hardkey controls on the front/rear panel of
the instrument

The Table 11-1 provides a short description of the operating states and their indication.

How to switch between operating states
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Table 11-1: Indication of the operating states

Operating
state

Description Indication

Off The instrument is shut down. All LEDs on the front panel of the instrument
are off.

Booting The instrument boots the operating system
and starts the instrument firmware.

If the previous session was terminated reg-
ularly, the instrument uses the last setup
with the relevant instrument settings.

The green [POWER ON/STANDBY] key blinks.

Standby The standby power mode keeps the power
switch circuits and the remote control sys-
tem active.

In this state, it is safe to switch off the AC
power and disconnect the instrument from
the power supply.

In the R&S SGMA-GUI, the status indicator in
front of the instrument name is red.

The orange [POWER ON/STANDBY] key is
on.

Ready

(normal
operation)

The instrument is ready for operation. All
modules are power-supplied.

In the R&S SGMA-GUI, the status indicator in
front of the instrument name is green.

The green [POWER ON/STANDBY] key is on.

To switch the instrument to standby state

► Use one of the following:

a) On the remote PC, select "SGMA-GUI > Instrument Name > Setup > Standby".
b) Press the [POWER ON/STANDBY] key on the front panel of the instrument.
c) Send the SCPI command:

:SYSTem:REBoot
The current instruments settings are automatically saved. The instrument switches
to a power-saving mode.
In the R&S SGMA-GUI, the standby state is indicated by the red state symbol in
front of the corresponding instrument's name, on the front panel, by the orange
[POWER ON/STANDBY] button.
You can still remotely control the instrument.

To return the instrument from standby to ready state

► Use one of the following:

a) On the remote PC, select "SGMA-GUI > Instrument Name > Setup > Restart".
b) Press the orange [POWER ON/STANDBY] key on the front panel of the instru-

ment.
c) Send the SCPI command:

:SYSTem:RESTart
The instrument loads the last setup with all instrument settings, switches to ready
state and is ready for normal operation.
In the R&S SGMA-GUI, the ready state is indicated by the green state symbol in
front of the instrument's name.
On the front panel, the ready state is indicated by the green [POWER ON/
STANDBY] button.

How to switch between operating states
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To switch all connected instruments to standby state and close the R&S SGMA-
GUI

► In the R&S SGMA-GUI main panel, select "File > Shut down instruments and exit".

The R&S SGMA-GUI quits and switches the connected instruments to standby
state.

For description on how to terminate work and shut down the instrument regularly, see
Chapter 3.10, "Switching on or off", on page 25.

11.4  How to use computer names

If there is a name server in the network, alternatively to the IP address each PC or
instrument connected in a LAN can be accessed via an unambiguous computer name.
Each instrument is delivered with an assigned computer name, but this name can be
changed.

For instruction on how to find out the default computer name, refer to Chapter 8.4.3,
"Finding out the default hostname of the instrument", on page 76.

To query and change a computer name

To avoid violations and to use easy identification provided by the computer name, we
recommend that you to keep the default hostname unchanged.

1. Open "SGMA-GUI > Instrument Name > Setup > Network Settings" dialog.

The computer name is displayed under "Hostname".

2. Select "SGMA-GUI > Instrument Name > Setup > Protection"

3. Enable the "Protection Level 1".

The parameter "Hostname" in the "Network Settings" dialog is now enabled for
configuration.

4. Change the "Hostname".

5. Press the [POWER ON/STANDBY] key to restart the instrument.

Note: The "Factory Preset" function restores the factory value of the parameter
"Hostname".

11.5  How to install a new firmware version on the instru-
ment

You can update the firmware of the R&S SGU.

How to install a new firmware version on the instrument
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Firmware installation via R&S SGMA-GUI

Install or update the firmware of the R&S SGU before installing or updating the soft-
ware R&S SGMA-GUI.

1. Select "SGMA-GUI main panel > Instrument Name > Setup > Maintenance > Oper-
ation > Install firmware package".

2. Press "Select Package" and navigate to the directory of the new firmware.

3. If several instruments require a firmware update, enable "Update All" to accelerate
the update procedure.

All instruments that are in active state and are connected to this controller are
updated simultaneously.

4. Enter the "Security Password".

5. Confirm the update with "Accept".

The software transfers the firmware file and automatically starts the update proce-
dure. During the update, the message "Updating Firmware" is displayed in the
"Info" line. The update process is indicated by an LED running light.

Note: The update procedure requires a restart of the instrument. The restart is per-
formed automatically. The instrument is not accessible during that time.

6. Wait until the message "Updating Firmware" disappears. After the message disap-
pears, the update is complete.

The [POWER ON/STANDBY] LED is green.

7. If necessary, install the new R&S SGMA-GUI.
For detailed description, refer to Chapter 3.13.1, "Installing the R&S SGMA-GUI
software", on page 28

8. If you connect the instrument and the controller/PC over the PCIe interface and the
external PC does not support hot-plugging, restart the external PC.

Firmware update through a session control protocol (SCP)

Install or update the firmware of the R&S SGU before installing or updating the soft-
ware R&S SGMA-GUI.

1. Connect the R&S SGU and a Windows PC to the same network.

2. On the PC, open a windows explorer window.

3. To connect to the R&S SGU, enter the name of the instrument or its IP address in
the windows taskbar.

4. Enter the user name and password to connect to the R&S SGU. The default user
name is instrument and the password is instrument.

A folder opens, containing the share and the update folder.

How to install a new firmware version on the instrument
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5. Open the update folder.

6. Copy the new firmware update file into the folder.

The update starts automatically.

Unsuccessful or erroneous firmware update
An erroneous or unsuccessful installation of firmware update package is indicated by a
combination of one orange and red LEDs on the front panel.
Refer to the service manual for a description of the displayed error code or contact the
customer support center, see Chapter 14.5, "Contacting customer support",
on page 226.

11.6  How to activate options

A firmware update before the activation of the SW option can be required.
Refer to the description of the SW option for the required firmware version.
See also Chapter 11.5, "How to install a new firmware version on the instrument",
on page 125 for instruction on how to update the firmware version.

1. Select "SGMA-GUI main panel > Instrument Name > Setup > Install SW-Options".

2. Select "Option Key".

3. Enter the key code delivered with the new option.

The new option is now enabled and ready for operation.

11.7  How to set a PCIe direct connection

To build a direct PCIe connection between an R&S SGU and an R&S SGS, which has
a "Controller > Revision" < 5, first you have to set the correct PCIe interface mode
manually. If your R&S SGS has a "Controller > Revision" 5 or higher, these settings are
done automatically.

You can check the "Controller > Revision" of your instrument in the "SGMA-GUI >
Instrument Name > Hardware Config" dialog.

To set a PCIe direct connection between an R&S SGS and an R&S SGU manually

1. Connect the R&S SGS and the R&S SGU directly using a PCIe cable. Refer to
Chapter 12.3.4, "Connecting the controller and the instrument", on page 144 for
cable requirements and setup information.

2. Switch on the R&S SGS and the R&S SGU.

How to set a PCIe direct connection
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3. Select "SGMA-GUI main panel > Instrument Name > Setup > Maintainance".

4. Select "Operation > PCIe Interface Mode".

5. Select "PCIe Interface Mode > Root Complex".

6. Restart your instrument for the changes to take place.

The PCIe connection between the R&S SGS and the R&S SGU is established and
the instruments can be used.

How to set a PCIe direct connection
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12  Network operation and remote control
As an alternative to operating the R&S SGU interactively via the R&S SGMA-GUI, you
can operate the R&S SGU also from a remote location.

Information on network operation and remote control
The following descriptions provide information required for operating the R&S SGU
remotely. The information applies to all applications and operating modes supported by
the instrument. Definitions specified in the SCPI standard are not provided.
For basic knowledge on remote control operation and additional information, see the
following documents, available on the Rohde & Schwarz website:
● Remote control via SCPI
● 1GP72: Connectivity of Rohde&Schwarz Signal Generators
● 1MA208: Fast Remote Instrument Control with HiSLIP

● Remote control interfaces and protocols...............................................................129
● Starting a remote control session..........................................................................138
● Advanced remote control using PCIe....................................................................140
● Advanced remote control using fast socket.......................................................... 145
● Status reporting system........................................................................................ 147
● LXI configuration................................................................................................... 155
● Monitoring remote control operation with R&S SGMA-GUI.................................. 160

12.1  Remote control interfaces and protocols

The instrument supports several interfaces for remote control. The following table gives
an overview.
Table 12-1: Remote control interfaces and protocols

Interface Protocols, VISA*) address string and Library Remarks

Local Area
Network
(LAN)

● HiSLIP High-Speed LAN Instrument Protocol
(IVI-6.1)
TCPIP::host address::hislip0[::
INSTR]

● VXI-11
TCPIP::host address::inst0[::INSTR]
Library: VISA

● socket communication (Raw Ethernet, simple
Telnet)
TCPIP::host address[::
LAN device name]::<port>::SOCKET
Library: VISA or socket controller

A LAN connector is located on the
rear panel of the instrument.

The interface is based on TCP/IP and
supports various protocols.

For details, see Chapter 12.1.2, "LAN
interface", on page 133

USB USBTMC
USB::<vendor ID>::<product ID>::
<serial number>[::INSTR]
Library: VISA

A USB connector is located on the
rear panel of the instrument.

For details, see Chapter 12.1.3, "USB
interface", on page 136

Remote control interfaces and protocols
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Interface Protocols, VISA*) address string and Library Remarks

PCIe Proprietary
PCIe::<vendor ID>::<product ID>::
<serial number>[::INSTR]
Library: PCIe controller

A PCIe connector is located on the
rear panel of the instrument.

For details, see Chapter 12.1.4, "PCI
Express interface", on page 136

GPIB (IEC/
IEEE Bus
Interface)

–
● GPIB::<address>[::INSTR] (no secondary

address)
VISA

The instrument is not equipped with
GPIB bus interfaces. Use a GPIB-to-
LAN or GPIB-to-USB adapter instead.

For details, see Chapter 12.1.5,
"GPIB interface (IEC/IEEE bus inter-
face)", on page 137

*) VISA is a standardized software interface library that provides input and output func-
tions to communicate with instruments. A VISA installation on the controller is a prereq-
uisite for remote control over LAN (when using VXI-11 or HiSLIP protocol) or USB.
However, no VISA installation is necessary for remote control while using socket com-
munication. For more information about VISA, refer to the user documentation.

Rohde & Schwarz provides the standardized I/O software library R&S VISA for com-
munication via TCP/IP (LAN: HiSLIP, VXI-11 and raw socket) or USB (USBTMC) inter-
faces.
R&S VISA is available for download at the Rohde & Schwarz website http://
www.rohde-schwarz.com/rsvisa.

SCPI (Standard Commands for Programmable Instruments)

SCPI commands are used for remote control. Commands that are not taken from the
SCPI standard follow the SCPI syntax rules. The instrument supports the SCPI version
1999. The SCPI standard is based on standard IEEE 488.2 and aims at the standardi-
zation of device-specific commands, error handling and the status registers. The tuto-
rial "Automatic Measurement Control - A tutorial on SCPI and IEEE 488.2" from John
M. Pieper (R&S order number 0002.3536.00) offers detailed information on concepts
and definitions of SCPI.

12.1.1  Remote control programs and libraries

The Figure 12-1 provides a schematic illustration of the remote control capabilities of
the instrument.

Remote control interfaces and protocols
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Figure 12-1: Remote control interfaces, protocols and libraries

The following examples give an overview of the dependencies between the available
libraries, the possible interfaces and protocols, and whether an instrument driver is pro-
vided. The involved parts are highlighted.
● Remote control program using VISA

Figure 12-2: Remote control program using VISA

Protocol Remote control program

Socket viOpen (..., "TCPIP:rssgu100a100010::5025::SOCKET", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

VXI-11 viOpen (..., "TCPIP:rssgu100a100010::inst0::INSTR", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

HiSLIP viOpen (..., "TCPIP:rssgu100a100010::hislip0::INSTR", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

USBTMC viOpen (..., "USB::0x0aad::0x00ce::1000010::INSTR", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

● Remote control program using instrument driver (VISA available)

Remote control interfaces and protocols
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Figure 12-3: Remote control program using instrument driver (VISA available)

Protocol Remote control program

Socket rssgu_init ("TCPIP:rssgu100a100010::5025::SOCKET", ...)
rssgu_SetFrequency (..., 2e9)

VXI-11 rssgu_init ("TCPIP:rssgu100a100010::inst0::INSTR", ...)
rssgu_SetFrequency (..., 2e9)

HiSLIP rssgu_init ("TCPIP:rssgu100a100010::hislip0::INSTR", ...)
rssgu_SetFrequency (..., 2e9)

USBTMC rssgu_init ("USB::0x0aad::0x00ce::1000010::INSTR", ...)
rssgu_SetFrequency (..., 2e9)

PCIe rssgu_init ("PCIe::0x162f::0x132e::1000010::INSTR", ...)
rssgu_SetFrequency (..., 2e9)

● Remote control program using instrument driver (VISA not available)

Figure 12-4: Remote control program using instrument driver (VISA not available)

Remote control interfaces and protocols
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Protocol Remote control program

Socket rssgu_init ("TCPIP:rssgu100a100010::5025::SOCKET", ...)
rssgu_SetFrequency (..., 2e9)

PCIe rssgu_init ("PCIe::0x162f::0x132e::1000010::INSTR", ...)
rssgu_SetFrequency (..., 2e9)

12.1.2  LAN interface

To be integrated in a LAN, the instrument is equipped with a LAN interface, consisting
of a connector, a network interface card and protocols.

For remote control via a network, the PC and the instrument must be connected via the
LAN interface to a common network with TCP/IP network protocol. They are connected
using an RJ45 cable (shielded or unshielded twisted-pair category 5). The TCP/IP net-
work protocol and the associated network services are preconfigured on the instru-
ment. Software for instrument control and (for specified protocols only) the VISA pro-
gram library must be installed on the controller.

Identifying instruments in a network
If several instruments are connected to the network, each instrument has its own IP
address and associated resource string. The controller identifies these instruments by
the resource string.

12.1.2.1  VISA resource strings

The VISA resource string is required to establish a communication session between
the controller and the instrument in a LAN. The resource string is a unique identifier,
composed of the specific IP address of the instrument and some network and VISA-
specific keywords.

TCPIP::host address[::LAN device name][::INSTR]
● TCPIP designates the network protocol used
● Host address is the IP address or host name of the device

See also Chapter 8.4.3, "Finding out the default hostname of the instrument",
on page 76.

● [::LAN device name] defines the protocol and the instance number of a subinstru-
ment:

● [::INSTR] indicates the instrument resource class (optional)

The IP address (host address/computer name) is used by the programs to identify and
control the instrument. It is automatically assigned by the DHCP server the first time
that the device is registered on the network. Alternatively, you can also assign its LAN
device name.

You can find the IP address in the "SGMA-GUI > Instrument Name > Setup > Remote"
dialog, and also adjust it manually, if necessary.

Remote control interfaces and protocols
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See below the characteristics of the VISA resource strings for the corresponding inter-
face protocols. The highlighted characters are crucial.

HiSLIP

TCPIP::host address::hislip0[::INSTR]
● hislip0 HiSLIP device name, designates that the interface protocol HiSLIP is used

(mandatory).

hislip0 is composed of [::HiSLIP device name[,HiSLIP port]] and must be assigned.

For details of the HiSLIP protocol, refer to Chapter 12.1.2.2, "HiSLIP protocol",
on page 134.

VXI-11

TCPIP::host address[::inst0][::INSTR]
● [::inst0] LAN device name, indicates that the VXI-11 protocol is used (optional).

inst0 currently selects the VXI-11 protocol by default and can be omitted.

For details of the VXI-11 protocol, refer to Chapter 12.1.2.3, "VXI-11 protocol",
on page 135.

Socket communication

TCPIP::host address::port::SOCKET
● Port determines the used port number
● SOCKET indicates the raw network socket resource class

Socket communication requires the specification of the port (commonly referred to as
port number) and of "SOCKET" to complete the VISA resource string with the associ-
ated protocol used.

The registered port for socket communication is port 5025.

See also Chapter 12.1.2.4, "Socket communication", on page 135.

Example: 
● Instrument has the IP address 10.113.11.91; the valid resource string using VXI-11

protocol is:
TCPIP::10.113.11.91::INSTR

● The DNS host name is rssgu100a100021; the valid resource string is:
TCPIP::rssgu100a100021::hislip0 (HiSLIP)
TCPIP::rssgu100a100021::inst0 (VXI-11)

● A raw socket connection can be established using:
TCPIP::10.113.11.91::5025::SOCKET

12.1.2.2  HiSLIP protocol

The High Speed LAN Instrument Protocol (HiSLIP) is the successor protocol for VXI-11
for TCP-based instruments specified by the IVI foundation. The protocol uses two TCP

Remote control interfaces and protocols
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sockets for a single connection - one for fast data transfer, the other for non-sequential
control commands (e.g. Device Clear or SRQ).

HiSLIP has the following characteristics:

● High performance as with raw socket network connections
● Compatible IEEE 488.2 support for Message Exchange Protocol, Device Clear,

Serial Poll, Remote/Local, Trigger, and Service Request
● Uses a single IANA registered port (4880), which simplifies the configuration of fire-

walls
● Supports simultaneous access of multiple users by providing versatile locking

mechanisms
● Usable for IPv6 or IPv4 networks

Using VXI-11, each operation is blocked until a VXI-11 instrument handshake returns.
However, using HiSLIP, data is sent to the instrument using the "fire and forget"
method with immediate return. Thus, a successful return of a VISA operation such as
viWrite() guarantees only that the command is delivered to the instrument's TCP/IP
buffers. There is no confirmation, that the instrument has started or finished the
requested command.

For more information see also the application note:

1MA208: Fast Remote Instrument Control with HiSLIP

12.1.2.3  VXI-11 protocol

The VXI-11 standard is based on the ONC RPC (Open Network Computing Remote
Procedure Call) protocol which in turn relies on TCP/IP as the network/transport layer.
The TCP/IP network protocol and the associated network services are preconfigured.
TCP/IP ensures connection-oriented communication, where the order of the
exchanged messages is adhered to and interrupted links are identified. With this proto-
col, messages cannot be lost.

12.1.2.4  Socket communication

An alternative way for remote control of the software is to establish a simple network
communication using sockets. The socket communication, also referred to as “Raw
Ethernet communication”, does not require a VISA installation on the remote controller
side.

The simplest way to establish socket communication is to use the built-in telnet pro-
gram. The telnet program is part of every operating system and supports communica-
tion with the software on a command-by-command basis.

Socket connections are established on a specially defined port. The socket address is
a combination of the IP address or the host name of the instrument and the number of
the port configured for remote-control. All instruments use port number 5025 for this

Remote control interfaces and protocols

http://www.rohde-schwarz.com/appnote/1MA208


Network operation and remote controlR&S®SGU100A

136User Manual 1176.7726.02 ─ 10

purpose. The port is configured for communication on a command-to-command basis
and for remote control from a program running on a connected PC.

12.1.3  USB interface

For remote control via USB connection, the PC and the instrument must be connected
via the USB interface. A USB connection requires the VISA library to be installed. VISA
detects and configures the R&S instrument automatically when the USB connection is
established. You do not have to install a separate driver.

USB resource string

The syntax of the used USB resource string is:
USB::<vendor ID>::<product ID>::<serial number>[::INSTR], where:
● USB denotes the used interface
● <vendor ID> is the manufacturer ID for Rohde&Schwarz
● <product ID> is the product identification of the R&S instrument
● <serial number> is the individual serial number on the rear of the instrument
● [::INSTR] indicates the instrument resource class (optional)

You can retrieve the USB resource string from the "SGMA-GUI > Instrument Name >
Setup > Remote" dialog.

Example: 
USB::0x0AAD::0x00ce::100021::INSTR
0x0AAD is the vendor ID for Rohde & Schwarz.
0x00ce is the product ID for the R&S SGU.
100021 is the serial number of the particular instrument.

12.1.4  PCI Express interface

A PCI Express (PCIe) connector is provided on the rear panel of the instrument.

Refer to Chapter 12.3, "Advanced remote control using PCIe", on page 140 for a
description of how to set up a remote control connection via PCIe and the permitted
cables.

Via PCI Express some commands can be sent to the instrument with optimized speed
(memory-mapped remote control), e.g. frequency or level settings. Speed optimization
allows minimum setup time.

PCIe resource string

The syntax of the used PCIe resource string is:
PCIe::<vendor ID>::<product ID>::<serial number>[::INSTR], where:
● PCIe denotes the used interface
● <vendor ID> is the manufacturer ID for Rohde & Schwarz

Remote control interfaces and protocols
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● <product ID> is the product identification of the R&S instrument
● <serial number> is the individual serial number on the rear of the instrument
● [::INSTR] indicates the instrument resource class (optional)

You can retrieve the PCIe resource string from the "SGMA-GUI > Instrument Name >
Setup > Remote" dialog.

Example: 
PCIe::0x162f::0x132e::100021::INSTR
0x162f is the vendor ID for Rohde & Schwarz.
0x132e is the product ID for the R&S SGU.
100021 is the serial number of the particular instrument.

12.1.5  GPIB interface (IEC/IEEE bus interface)

The R&S SGU is not equipped with an IEC/IEEE bus interface.

To be able to control the instrument via the GPIB bus:

1. Connect a GPIB-to-LAN or a GPIB-to-USB adapter to the instrument.

2. Use a GPIB bus cable to connect the instrument and the controller.

3. Provide the GPIB bus card, the card drivers and the program libraries for the pro-
gramming language in the controller.

4. In the "SGMA-GUI > Setup > Instruments > instrument name > Remote Control",
set the "GPIB Address".
See "GPIB Address" on page 65.

5. If the controller has several GPIB bus cards, define the used "Board Number".

GPIB address

The controller must address the instrument with the GPIB bus channel. GPIB provides
channel addresses from 0 to 30.

The GPIB resource string is GPIB::<address>[::INSTR], where:
● GPIB denotes the used interface.
● <address> indicates the used channel.
● [::INSTR] indicates the instrument resource class (optional).

Note: If the VISA implementation supports the GPIB interface, you can optionally
define the VISA instrument control resource (INSTR). It is used to define the basic
operations and attributes for a device, such as reading, writing, or triggering.

Any connected IEC bus cable must be terminated by an instrument or controller.
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12.2  Starting a remote control session

To start a remote control session, connect the instrument and the controller with a suit-
able cable and switch on both of them.

A remote control program must open a connection to the instrument, before it can send
commands to and receive device responses from the instrument.

Instrument address
To operate the instrument via remote control, it must be addressed using the defined
interface address.
See Chapter 12.1.2, "LAN interface", on page 133, Chapter 12.1.3, "USB interface",
on page 136 or Chapter 12.1.4, "PCI Express interface", on page 136 for details.

The VISA resource strings are indicated in the "SGMA-GUI main panel > Instrument
name > Setup > Remote Channels" dialog.

12.2.1  How to find the VISA resource string

To find the VISA resource strings of your instrument:

► Select "SGMA-GUI main panel > Instrument name > Setup > Remote Channels".

The "Remote Channel Settings" dialog shows all specified resource strings of the
supported remote control interfaces.

12.2.2  Remote control over LAN using socket communication

This section provides an example of how to establish a remote control connection over
telnet protocol and a simple sockets-based program example that can be further devel-
oped (see also Chapter A, "Telnet program examples", on page 229).
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Basic knowledge of programming and operation of the controller are assumed. A
description of the interface commands can be obtained from the relevant manuals.

Refer to the getting started manual for an example of how to set up remote control con-
nection over LAN using VXI-11 protocol.

To set up a Telnet connection

To control the software, only a telnet program is required. The telnet program is part of
every operating system.

1. To establish a Telnet connection with the R&S SGU, start the telnet program.

2. Enter the socket address.
The socket address is a combination of the IP address or the host name of the
R&S SGU and the number of the port configured for remote-control via telnet.
Tip: The R&S SGU uses the port number 5025 for remote connection via Telnet.

The connection to the instrument is set up and remote-control commands can be
sent.

3. Even if the cursor is not visible on the screen, enter blind a remote-control com-
mand.

4. Confirm with "Enter".
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12.3  Advanced remote control using PCIe

The PCIe bus is a high-speed serial bus, composed of point-to-point serial links. A pair
of serial links, one transmitting and one receiving link, make up a lane.

Fast settings

The PCIe interface can be utilized not only to transfer text messages, e.g., SCPI com-
mands but also to carry register based remote control messages. The latter mode is
called fast settings mode. The specially for this purpose provided instrument's driver is
mandatory for the instrument control with fast settings. This instrument driver contains
special functions for fast setup.

To use the advantage of the fast settings, the following prerequisites must be fulfilled:
● Using the PCIe interface is mandatory (see also Chapter 12.3.1, "Setting up a

remote control connection via PCIe", on page 140)
● The fast settings must be enabled with the function rssgu_useFastSettings

(see also Chapter 12.3.5, "Enabling fast settings", on page 144).

The instrument driver automatically uses the fast settings method whenever possible -
currently only for the parameters frequency, level, RF state, modulator state - and
sends SCPI messages in all other cases.

Remote control programs written for PCIe will, without modifications, also run if one of
the other control channels, LAN or USB is used.

12.3.1  Setting up a remote control connection via PCIe

To set up a remote control connection vie PCIe, perform the following steps:

1. Download the drivers: See 12.3.2.

2. Configure the controller: See 12.3.3
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3. Connect the controller and the instrument: See 12.3.4

4. Enable fast settings: See 12.3.5.

12.3.2  Downloading the drivers

All required driver files are available for download on the product page at:

http://www.rohde-schwarz.com/product/SGU100A.html > "Downloads" > "Drivers"

Provided are the following files:
● LabWindows/CVI, Linux/OSX driver rssgu (InstrumentDriver)

C source code files which provide a functional application programming interface
(API) to R&S SGU instruments. Required if you want to control an instrument via
PCIe.

● Low-Level SGU drivers
Archive file that contains the following:
– KernelDriver

C source code files from which you can build a Linux kernel mode driver for the
R&S SGU PCIe remote control interface.

– SguDriverDemo
C source code module for a demo program using the instrument driver API.

– SharedLibraries-Dlls
Shared libraries (*.dll files) for remote control channels Socket and PCIe. To
be used with the instrument driver.

● VXIplug&play x64/x86 driver rssgu
Download the required archive and extract the files on a remote PC.

12.3.3  Configuring the controller

This section lists the steps necessary to configure a controller with Linux or Windows
operating system.

12.3.3.1  Building and installing the hardware driver

The hardware driver defines the way to communicate with the instrument via PCIe
interface.

For Windows operating systems, the hardware driver is installed automatically together
with the installation of the R&S SGMA-GUI software.
See also section "Installation of R&S SGMA-GUI Software" in the getting started man-
ual.

For Linux operating system, the source code of the driver is included in the
Low-Level SGU drivers file.

Advanced remote control using PCIe
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To build and install this driver, root authority is required.

1. Copy folder KernelDriver to your hdd

2. Go to directory host.

3. On the command line, enter make.

The driver sgshost.ko is automatically built.

4. Enter make install.

Device nodes sguX are created under the folder /dev (X from 0 to 31).
The module sguhost is loaded.

5. Enter lsmod to verify the module.

12.3.3.2  Making shared libraries accessible

Two library files per operating system are included in SharedLibraries-Dlls file:
● For Linux operating system

libsocketcontroller.so and libpciecontroller.so
● For Windows operating system

SocketController.dll and PCIeController.dll
These libraries act as the dynamic link libraries for programs using the socket or PCIe
interface.

Linux operating system

► To make the libraries accessible, perform one of the following:

a) Append the environment variable LD_LIBRARY_PATH with the path of these
two files, e.g., by changing the /etc/environment file.

b) Move these two files to /usr/lib or /lib directory.

Windows operating system

► To make the libraries accessible, perform one of the following:

a) Copy these two files to the folder of your executable.
b) Copy these two files to the WINDOWS\system32 folder.

12.3.3.3  Building a program

The help file rssgu_vxi.chm shows all functions of the instrument which you can use
in your own remote control program.

An example file is provided ( SguDriverDemo.c), too.

Building the example program (Linux)

1. Copy folders InstrumentDriver and SguDriverDemo to your hard disk.
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2. Go to folder Build

3. On the command line, enter cmake ..

4. Enter make
Folder Build contains the executable SguDriverDemo.

Building the example program (Windows)

1. Copy folders InstrumentDriver and SguDriverDemo to your hard disk.

2. Open SguDriverDemo.vcproj with Visual Studio.

3. Build the program.

Running the example program

► On the command line, enter ./SguDriverDemo RESOURCESTRING [cmd].

Where
● RESOURCESTRING is the (VISA) resource string of your instrument, e.g.

TCPIP::ipaddress::5025::SOCKET or PCIE::0x162f::
0x132e::serialno::INSTR.
Where ipaddress is the IP address or hostname of your instrument and
serialno is its serial number.

● cmd is an optional command (see table).

The following table list the available commands.

Command Description

? Usage

q Quit

f value Set frequency

f? Query frequency

l value Set level

l? Query level

r value Set RF state (value = 0 | 1 | ON | OFF)

r? Query RF state

If you enter an additional optional command, SguDriverDemo executes it and
enters a loop waiting for further commands.

Example: 
TCPIP::10.111.11.44::5025::SOCKET ?
Lists the available commands.

Advanced remote control using PCIe



Network operation and remote controlR&S®SGU100A

144User Manual 1176.7726.02 ─ 10

12.3.4  Connecting the controller and the instrument

The "PCIe" connector is located on the rear panel.

Permitted PCIe cables
PCIe extension cables must fulfill the following requirements:
● Single lane connectors
● Maximum cable length of 5 m.

For example: OSS-PCIe-CBL-x1 cable from One Stop Systems or 74576-000x cable
from Molex.

Connecting an external PC that does not support hot-plugging

1. Switch off the external PC and the instrument.
See also Chapter 3.10, "Switching on or off", on page 25.

2. NOTICE! Risk of device failure. The R&S SGU is equipped with a single lane PCIe
interface that supports hot plugging.
Do not connect an external PC to the PCIe connector of the instrument during
operation if this external PC does not support hot-plugging!
Connect the instrument and the controller with a permitted PCIe cable as specified
in "Permitted PCIe cables" on page 144.

3. Switch on the instrument.

4. Wait until the instrument has completed the booting (the "POWER" LED on the
instrument's front panel is constantly on).

5. Switch on the external PC.

Connecting an R&S SGS and an R&S SGU

If you use the R&S SGU as an upconverter to the R&S SGS, the R&S SGS acts as a
controller to the R&S SGU. For a description of how to connect the instruments refer to
Chapter 7.2, "Connecting an R&S SGS and an R&S SGU", on page 51.

12.3.5  Enabling fast settings

► To enable the special PCI express feature fast settings, enable the function
rssgu_UseFastSettings (ViSession instrumentHandle, ViBoolean
fastEnabled, ViBoolean asynchronousEnabled) included in the instru-
ment driver.

Settings for some parameters like level and frequency accelerate.

To disable the fast settings, call the function rssgu_UseFastSettings with argu-
ment fastEnabled=false.
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12.4  Advanced remote control using fast socket

Fast settings

The socket interface can be utilized not only to transfer text messages, e.g., SCPI
commands but also to carry register based remote control messages. The latter mode
is called fast settings mode. The fast socket communication is based on the Ethernet
protocol which does not support routing. Therefore a controller PC can only control
devices within its own network segment using the fast socket method.

To use the advantage of the fast settings, the following prerequisites must be fulfilled:
● On Windows operating systems, the fast socket driver must be installed.
● The application program must be run with root/administrator rights.
● The fast settings must be enabled with the function rssgu_useFastSettings

(see also Chapter 12.3.5, "Enabling fast settings", on page 144).

The instrument driver automatically uses the fast settings method whenever possible,
currently for the parameters frequency, level, RF state, I/Q modulator state, crest fac-
tor, host frequency, host level, apply settings. In all other cases, SCPI messages are
sent.

12.4.1  Setting up a remote control connection via fast socket

Download the required archive and extract the files on a remote PC, as described in
Chapter 12.3.2, "Downloading the drivers", on page 141.

Windows operating systems

To set up a remote control connection via fast socket for Windows operating systems,
perform the following steps:

1. Connect the controller and the instrument: See Chapter 3.13.2, "Connecting a
remote PC via LAN", on page 30.

2. Install the protocol driver to the controller: See Chapter 12.4.2, "Installing the proto-
col driver", on page 146.

3. On the controller, start the driver by using one of the following:

a) Start the Windows console user interface as an administrator.
Excute the command net start SGMANDISPROT.

b) Use a program for opening the driver.
See, for example, the example file SguDriverDemo.c.

4. Start the application with administrator rights.

5. Enable fast settings: See Chapter 12.4.3, "Enabling fast settings", on page 146.
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Linux operating systems

To set up a remote control connection via fast socket for Linux operating systems, per-
form the following steps:

1. Connect the controller and the instrument: See Chapter 3.13.2, "Connecting a
remote PC via LAN", on page 30.

2. Start the application as root.

3. Enable fast settings: See Chapter 12.4.3, "Enabling fast settings", on page 146.

12.4.2  Installing the protocol driver

The protocol driver defines the way to communicate with the instrument via the LAN
fast socket interface.

For Linux operating system, no special driver is needed.

For Windows operating systems, the SGMANDISPROT driver is required. The protocol
driver is installed automatically together with the installation of the R&S SGMA-GUI
software. It is also provided in the Low-Level SGU drivers file.

To install the driver manually on a Windows operating system:

1. Open "Control Panel > Network and Sharing Center".

2. Select the network adapter on which you want to install the driver.

The "Local Area Connection Status" dialog opens.

3. Click "Properties" to open the "Local Area Connection Properties" dialog.

4. Click "Install" to open the "Select Network Feature Type" dialog.

5. Select "Protocol".

6. Select "Add".

7. In the "Select Network Protocol" dialog, select "Have Disk".

8. To select the driver, navigate to its storage directory.

9. Click "OK" to install the driver.

12.4.3  Enabling fast settings

► To enable the fast settings for the fast socket, call function
rssgu_UseFastSettings (ViSession instrumentHandle, ViBoolean
fastEnabled, ViBoolean asynchronousEnabled) included in the instru-
ment driver.

Settings for some parameters like level and frequency accelerate.
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To disable the fast settings, call the function rssgu_UseFastSettings with argu-
ment fastEnabled=false.

12.5  Status reporting system

The status reporting system stores all information on the current operating state of the
instrument, and on errors which have occurred. This information is stored in the status
registers and in the error queue.

You can query both with the commands of the STATus subsystem.

12.5.1  Hierarchy of the status registers

The Figure 12-5 shows the hierarchical structure of information in the status registers
(ascending from left to right).
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Figure 12-5: Graphical overview of the status registers hierarchy

OPER = Operation Status Summary Bit
RQS/MSS = Service Request Generation
ESB = Standard Event Status Summary Bit
MAV = Message Available in Output Queue
QUES = Questionable Status Summary Bit
2 = Error- /Event-Queue
1, 0 = not used

Note: This legend explains the abbreviations to the Status Byte Register.

The R&S SGU uses the following status registers:
● Status Byte (STB) and Service Request Enable (SRE), see Chapter 12.5.3, "Sta-

tus byte (STB) and service request enable register (SRE)", on page 151.
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● Standard Event Status, i.e. the Event status Register (ESR) and the Event Status
Enable (ESE), see Chapter 12.5.4, "Event status register (ESR) and event status
enable register (ESE)", on page 152.

● Questionable Status and Operation Status, the (SCPI status registers, see
Chapter 12.5.2, "Structure of a SCPI status register", on page 149, Chapter 12.5.5,
"Questionable status register (STATus:QUEStionable)", on page 152 and Chap-
ter 12.5.6, "Operation status register (STATus:OPERation)", on page 153.

● Output-Queue
The output queue contains the messages the instrument returns to the controller. It
is not part of the status reporting system but determines the value of the MAV bit in
the STB and thus is represented in the overview.

● Error- /Event-Queue
The error-/event-queue contains all errors and events that have occurred in the
past. When reading the queue, the instrument starts with the first occurred error/
event.

All status registers have the same internal structure.

SRE, ESE
The service request enable register SRE can be used as ENABle part of the STB if the
STB is structured according to SCPI. By analogy, the ESE can be used as the ENABle
part of the ESR.

12.5.2  Structure of a SCPI status register

Each SCPI status register consists of five parts. Each part has a width of 16 bits and
has different functions. The individual bits are independent of each other, i.e. each
hardware status is assigned a bit number, which is valid for all five parts. Bit 15 (the
most significant bit) is set to zero for all parts. Thus, the contents of the register parts
can be processed by the controller as positive integers.

Figure 12-6: The status-register model
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Description of the five status register parts

The five parts of a SCPI status register have different properties and functions:

● CONDition
The CONDition part is written directly by the hardware or it mirrors the sum bit of
the next lower register. Its contents reflect the current instrument status. This regis-
ter part can only be read, but not written into or cleared. Its contents are not affec-
ted by reading.

● PTRansition / NTRansition
The two transition register parts define which state transition of the CONDition
part (none, 0 to 1, 1 to 0 or both) is stored in the EVENt part.
The Positive-TRansition part acts as a transition filter. When a bit of the
CONDition part is changed from 0 to 1, the associated PTR bit decides whether
the EVENt bit is set to 1.
– PTR bit =1: the EVENt bit is set.
– PTR bit =0: the EVENt bit is not set.

This part can be written into and read as required. Its contents are not affected by
reading.
The Negative-TRansition part also acts as a transition filter. When a bit of the
CONDition part is changed from 1 to 0, the associated NTR bit decides whether
the EVENt bit is set to 1.
– NTR bit =1: the EVENt bit is set.
– NTR bit =0: the EVENt bit is not set.

This part can be written into and read as required. Its contents are not affected by
reading.

● EVENt
The EVENt part indicates whether an event has occurred since the last reading, it
is the "memory" of the condition part. It only indicates events passed on by the
transition filters. It is permanently updated by the instrument. This part can only be
read by the user. Reading the register clears it. This part is often equated with the
entire register.

● ENABle
The ENABle part determines whether the associated EVENt bit contributes to the
sum bit (see below). Each bit of the EVENt part is "ANDed" with the associated
ENABle bit (symbol '&'). The results of all logical operations of this part are passed
on to the sum bit via an "OR" function (symbol '+').
ENABle bit = 0: the associated EVENt bit does not contribute to the sum bit
ENABle bit = 1: if the associated EVENt bit is "1", the sum bit is set to "1" as well.
This part can be written into and read by the user as required. Its contents are not
affected by reading.

Sum bit

The sum bit is obtained from the EVENt and ENABle part for each register. The result
is then entered into a bit of the CONDition part of the higher-order register.
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The instrument automatically generates the sum bit for each register. Thus an event
can lead to a service request throughout all levels of the hierarchy.

12.5.3  Status byte (STB) and service request enable register (SRE)

The STatus Byte (STB) is already defined in IEEE 488.2. It provides a rough over-
view of the instrument status by collecting the pieces of information of the lower regis-
ters. A special feature is that bit 6 acts as the sum bit of the remaining bits of the status
byte.

The STB is read using the command *STB? or a serial poll.

The STatus Byte (STB) is linked to the Service Request Enable (SRE) register.
Each bit of the STB is assigned a bit in the SRE. Bit 6 of the SRE is ignored. If a bit is
set in the SRE and the associated bit in the STB changes from 0 to 1, a service
request (SRQ) is generated. The SRE can be set using the command *SRE and read
using the command *SRE?.

Table 12-2: Meaning of the bits used in the status byte

Bit No. Meaning

0...1 Not used

2 Error Queue not empty

The bit is set when an entry is made in the error queue. If this bit is enabled by the SRE, each
entry of the error queue generates a service request. Thus an error can be recognized and
specified in greater detail by polling the error queue. The poll provides an informative error mes-
sage. This procedure is to be recommended since it considerably reduces the problems
involved with remote control.

3 QUEStionable status register summary bit

The bit is set if an EVENt bit is set in the QUEStionable status register and the associated
ENABle bit is set to 1. A set bit indicates a questionable instrument status, which can be speci-
fied in greater detail by querying the STATus:QUEStionable status register.

4 MAV bit (message available)

The bit is set if a message is available in the output queue which can be read. This bit can be
used to enable data to be automatically read from the instrument to the controller.

5 ESB bit

Sum bit of the event status register. It is set if one of the bits in the event status register is set
and enabled in the event status enable register. Setting of this bit indicates a serious error which
can be specified in greater detail by polling the event status register.

6 MSS bit (main status summary bit)

The bit is set if the instrument triggers a service request. This is the case if one of the other bits
of this registers is set together with its mask bit in the service request enable register SRE.

7 STATus:OPERation status register summary bit

The bit is set if an EVENt bit is set in the OPERation status register and the associated
ENABle bit is set to 1. A set bit indicates that the instrument is just performing an action. The
type of action can be determined by querying the STATus:OPERation status register.
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12.5.4  Event status register (ESR) and event status enable register (ESE)

The ESR is defined in IEEE 488.2. It can be compared with the EVENt part of a SCPI
register. The event status register can be read out using command *ESR?.

The ESE corresponds to the ENABle part of a SCPI register. If a bit is set in the ESE
and the associated bit in the ESR changes from 0 to 1, the ESB bit in the STB is set.
The ESE register can be set using the command *ESE and read using the command
*ESE?.

Table 12-3: Meaning of the bits used in the event status register

Bit No. Meaning

0 Operation Complete

This bit is set on receipt of the command *OPC exactly when all previous commands have been
executed.

1 Not used

2 Query Error

This bit is set if either the controller wants to read data from the instrument without having sent a
query, or if it does not fetch requested data and sends new instructions to the instrument
instead. The cause is often a query which is faulty and hence cannot be executed.

3 Device-dependent Error

This bit is set if a device-dependent error occurs. An error message with a number between
-300 and -399 or a positive error number, which denotes the error in greater detail, is entered
into the error queue.

4 Execution Error

This bit is set if a received command is syntactically correct but cannot be performed for other
reasons. An error message with a number between -200 and -300, which denotes the error in
greater detail, is entered into the error queue.

5 Command Error

This bit is set if a command is received, which is undefined or syntactically incorrect. An error
message with a number between -100 and -200, which denotes the error in greater detail, is
entered into the error queue.

6 User Request

This bit is set when the instrument is switched over to manual control.

7 Power On (supply voltage on)

This bit is set on switching on the instrument.

12.5.5  Questionable status register (STATus:QUEStionable)

This register contains information on questionable instrument states. Such states may
occur when the instrument is not operated in compliance with its specifications.

To read the register, use the query commands STAT:QUEST:COND? or
STAT:QUEST[:EVEN]?.
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Table 12-4: Meaning of the bits used in the questionable status register

Bit No. Meaning

0–15 Not used

12.5.6  Operation status register (STATus:OPERation)

This condition part contains information on the actions currently being performed by
the instrument, while the event part contains information on the actions performed by
the instrument since the last readout of the register.

To read the register, use the query commands STAT:OPER:COND? or
STAT:OPER[:EVEN]?.

Table 12-5: Meaning of the bits used in the operation status register

Bit No. Meaning

0 Calibrating

The bit is set during the calibration phase.

1–2 Not used

3  

4–15 Not used

12.5.7  Application of the status reporting system

The purpose of the status reporting system is to monitor the status of one or several
devices in a measuring system. To do this and react appropriately, the controller must
receive and evaluate the information of all devices. The following standard methods
are used:

● Service request (SRQ) initiated by the instrument
● Serial poll of all devices in the bus system, initiated by the controller to find out

who sent an SRQ and why
● Query of a specific instrument status by commands
● Query of the error queue

12.5.7.1  Service request

Under certain circumstances, the instrument can send a service request (SRQ) to the
controller. Usually this service request initiates an interrupt at the controller, to which
the control program can react appropriately. An SRQ is always initiated if one or sev-
eral of bits 2, 4 or 5 of the status byte are set and enabled in the SRE. Each of these
bits combines the information of the error queue or the output buffer. To use the possi-
bilities of the service request effectively, all bits should be set to "1" in the enable regis-
ters SRE and ESE.
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Example: 
Use command *OPC to generate an SRQ .
*ESE 1 - set bit 0 of ESE (Operation Complete)
*SRE 32 - set bit 5 of SRE (ESB).
After its settings have been completed, the instrument generates an SRQ.

The SRQ is the only possibility for the instrument to become active on its own. Each
controller program should set the instrument such that a service request is initiated in
the case of malfunction. The program should react appropriately to the service request.

12.5.7.2  Serial poll

In a serial poll, just as with command *STB, the status byte of an instrument is queried.
However, the query is realized via interface messages and is thus clearly faster.

The serial poll method is defined in IEEE 488.1 and used to be the only standard pos-
sibility for different instruments to poll the status byte. The method also works for
instruments which do not adhere to SCPI or IEEE 488.2.

The serial poll is mainly used to obtain a fast overview of the state of several instru-
ments connected to the controller.

12.5.7.3  Query of an instrument status

Each part of any status register can be read using queries. There are two types of
commands:

● The common commands *ESR?, *IDN?, *IST?, *STB? query the higher-level
registers.

● The commands of the STATus system query the SCPI registers
(STATus:QUEStionable...)

The returned value is always a decimal number that represents the bit pattern of the
queried register. This number is evaluated by the controller program.

Queries are usually used after an SRQ in order to obtain more detailed information on
the cause of the SRQ.

12.5.7.4  Error queue

Each error state in the instrument leads to an entry in the error queue. The entries of
the error queue are detailed plain text error messages that can be looked up in the
Error Log or queried via remote control using SYSTem:ERRor[:NEXT]?. Each call of
SYSTem:ERRor[:NEXT]? provides one entry from the error queue. If no error mes-
sages are stored there any more, the instrument responds with 0, "No error".

The error queue should be queried after every SRQ in the controller program as the
entries describe the cause of an error more precisely than the status registers. Espe-
cially in the test phase of a controller program the error queue should be queried regu-
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larly since faulty commands from the controller to the instrument are recorded there as
well.

12.5.8  Reset values of the status reporting system

The following table contains the different commands and events causing the status
reporting system to be reset. None of the commands, except of *RST and
SYSTem:PRESet affect the functional instrument settings. In particular, DCL does not
change the instrument settings.
Table 12-6: Resetting the status reporting system

Event Switching on supply
voltage
Power-On-Status-
Clear

DCL,
SDC
(Device
Clear,
Selected
Device
Clear)

*RST or
SYSTem:
PRESet

STATus:
PRESet

*CLS

Effect 0 1

Clear STB, ESR - Yes - - - Yes

Clear SRE, ESE - Yes - - - -

Clear PPE - Yes - - - -

Clear error queue Yes Yes - - - Yes

Clear output buffer Yes Yes Yes 1) 1) 1)

Clear command processing
and input buffer

Yes Yes Yes - - -

1) The first command in a command line that immediately follows a <PROGRAM MESSAGE TERMINA-
TOR> clears the output buffer.

12.6  LXI configuration

"LAN eXtensions for Instrumentation" (LXI) is an instrumentation platform for measur-
ing instruments and test systems that is based on standard Ethernet technology. LXI is
intended to be the LAN-based successor to GPIB, combining the advantages of Ether-
net with the simplicity and familiarity of GPIB.

On the R&S SGU, the LXI functionality is already installed and enabled. Thus, the
instrument can be accessed via any web browser (like the Microsoft Internet Explorer)
to perform the following tasks:
● Modifying network configurations
● Remote control of the instrument
● Performing SCPI remote diagnostics

LXI configuration
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12.6.1  Default network settings

According to the LXI standard, an LCI must set the following parameters to a default
state.

Parameter Value

TCP/IP mode DHCP + Auto IP Address

Dynamic DNS Enabled

ICMP ping Enabled

Password for LAN configuration LxiWebIfc

The LAN reset also resets the following parameters for the R&S SGU:

Parameter Value

Hostname <Instrument-specific host name>

Description Signal generator

Negotiation Auto detect

VXI-11 discovery Enabled

The LAN settings are configured using the instrument's LXI browser settings.

12.6.2  LXI browser settings

You can access LXI borowser settings via a web browser.

Access:

► Note: Do not add the missing zeros in the IP address, while opening the instru-
ment home page.

The instrument home page (welcome page) opens.

The navigation pane of the browser interface contains the following elements:
● "LXI"

– "Home" opens the instrument home page.
The home page displays the device information required by the LXI stan-
dard, including the VISA resource string in read-only format.

– "Device Indicator" activates or deactivates the LXI status indication.
When activated, the LXI LEDs flash in the browser dialog. A green LXI sta-
tus symbol indicates that a LAN connection has been established; a red
symbol indicates that no LAN cable is connected.

– "Lan Configuration" allows you to configure LAN parameters and to initiate
a ping, see Chapter 12.6.3, "LAN configuration", on page 157.

– "Status" displays information about the LXI status of the instrument.
– "Utilities" provides access to the LXI event log functionality required by the

LXI standard.
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● "Diagnostics"
– "SCPI Remote Trace" records messages exchanged via the remote control

interface, see Chapter 12.6.3.4, "SCPI remote trace", on page 158.
● "Help"

– "Glossary" explains terms related to the LXI standard.
– www.rohde-schwarz.com opens the Rohde & Schwarz home page.

12.6.3  LAN configuration

The "LAN Configuration" web page displays all mandatory LAN parameters and allows
their modification.

It comprises the following navigation entries.

● IP configuration..................................................................................................... 157
● Advanced Config...................................................................................................157
● Ping client..............................................................................................................158
● SCPI remote trace.................................................................................................158

12.6.3.1  IP configuration

The "IP configuration" web page displays all mandatory LAN parameters and allows
their modification.

The "IP Address Mode" selects a configuration mode for the IP address of the instru-
ment. With static configuration, the entered IP address, subnet mask, and default gate-
way are used. With dynamic configuration via DHCP or dynamic link local addressing
(automatic IP), the instrument IP address is assigned automatically.

Password protection
Changing the LAN configuration is password protected and requires the security pass-
word. The default password is "instrument".

12.6.3.2  Advanced Config

The "Advanced Config" web page provides LAN settings that are not declared manda-
tory by the LXI standard.

The following advanced parameters are available:
● "mDNS and DNS-SD": The additional protocols "multicast DNS" and "DNS service

discovery" are used for device communication in zero configuration networks,
working without DNS and DHCP.

● "ICMP Ping": Must be enabled to use the ping utility.
If you disable this setting, the instrument does not answer ping requests. The set-
ting does not affect the LXI ping client. You can ping other hosts from the instru-
ment, even if the setting is disabled.

● "VXI-11 Discovery": Must be enabled to detect the instrument in the LAN.

LXI configuration
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If you disable this setting, the instrument cannot be detected by the VXI-11 discov-
ery protocol mechanism. The setting does not affect other detection mechanisms.
Setting up a VXI-11 connection via the IP address or the host name is independent
of this setting.

Password protection
Changing the LAN configuration is password protected and requires the security pass-
word. The default password is "instrument".

12.6.3.3  Ping client

The "Ping Client" page provides the ping utility to verify the connection between the
LXI-compliant instrument and another device.

The ping is initiated from the instrument. Using the ICMP echo request and echo reply
packets, the function checks whether the communication with a device via LAN is
working. Ping is useful for the diagnosis of IP network or router failures.

To initiate a ping at the instrument:

1. On the "Ping Client" page, enter the IP address of the host in the "Destination
Address" field (for example 10.111.0.125).

2. Select "Submit".

12.6.3.4  SCPI remote trace

The remote trace functionality allows you to trace input and output strings at the
remote control interface of the R&S SGU, see Chapter 12.6.4, "How to record SCPI
commands and messages via LXI", on page 159.

A recorded trace (message log) can be evaluated directly in the dialog. Use the high-
lighting and navigation functions provided by the lower toolbar to locate error mes-
sages and messages containing arbitrary search strings. You can also export the mes-
sage log to a *.csv file and evaluate the file using a suitable program.

To trace and display messages, switch on "logging" and "live mode" in the toolbar.

Toolbars

The toolbar at the top of the dialog provides basic settings and functions.

● "Live mode" / "logging": If logging is switched on, messages are traced. They are
stored in an internal database and can be displayed upon request, using the
refresh button (live mode off) or they can be displayed automatically (live mode
on).

● "Filter": applies a filter to columns and/or rows when working (live mode off)
● "Refresh": reads the message log from the internal database and displays it
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● "Download": stores the SCPI trace log to a *.csv file
● "Clear": deletes all message log entries in the database and at the screen
● "Details": displays details of the selected message, for example a SCPI command

in hex format (also possible by double\-clicking a message)

Columns

The following columns are available if no column filter is applied:

● "Rec": record number of the message within the message log
● "MT": indicates the type of the message. Possible values and related message

contents are:
– > = incoming command
– < = outgoing response to a query
– E = error message, highlighted by red color
– T = execution time, i.e. time required by the instrument to process the com-

mand internally
● I: number of the subinstrument
● "message": indicates the type of the message. Possible values and related mes-

sage contents are:
– > = incoming command
– < = outgoing response to a query
– E = error message, denoted in red
– T = execution time, i.e. time required by the instrument to process the com-

mand internally

12.6.4  How to record SCPI commands and messages via LXI

The remote trace functionality allows you to trace commands and messages
exchanged via a remote control interface of the R&S SGU.

To activate the SCPI remote trace:

1. Start a web browser that supports html5 (W3C compliant).

2. Enter the IP address of the R&S SGU in the browser's address bar.

The R&S SGU's welcome page is displayed.

3. In the navigation pane, select "Diagnostics > SCPI Remote Trace".

4. In the toolbar bar of the "SCPI Remote Trace" page, select "live mode > on" and
"logging > on".

"live mode > on" displays all commands and responses, and "logging > on" also
traces messages.

If you now control the R&S SGU with SCPI commands, using an appropriate tool,
the LXI function records the information sent and received.
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The function records all sent commands, received responses and messages, and
stores them in an internal database. If "live mode" is disabled, you can display the
recent traces upon request, using the "refresh" button. You can also store the log in
a file.

12.7  Monitoring remote control operation with R&S SGMA-
GUI

The R&S SGMA-GUI can be used to monitor the behavior of one or more instruments
while they are remote controlled.

A typical configuration consists of one monitor, controllers and instruments. The moni-
tor is the remote PC on which the R&S SGMA-GUI is installed and the controller is the
remote PC on which the application program runs.

Simultaneous control of an instrument from a controller and a monitor can lead to colli-
sions whenever both the controller and the monitor utilize the same remote channel.
These collisions are indicated by an error message in the "Info" line, e.g. "Query inter-
rupted" or "Resource locked". Simultaneous monitoring and control over the same
remote channel is only possible, if the used protocols support
viLock()/viUnlock() and the remote program use these functions.

The Table 12-7 shows whether a collision-free communication over a particular combi-
nation of remote channels is possible or not and if there are any restrictions.
Table 12-7: Cross reference between used remote channels and collision-free communication

Monitor/
Controller

LAN
(VXI-11)

LAN (HiSLIP) USB LAN (Socket) PCIe

LAN (VXI-11) OK* OK OK OK OK

LAN (HiSLIP) OK OK OK OK OK

USB OK OK viLock/viUnlock OK OK

LAN (Socket) OK OK OK X OK

PCIe OK OK OK OK X

Where:
● OK: communication possible, no collisions

*) the R&S SGMA-GUI always uses the LAN device name instr1, see also Chap-
ter 12.1.2.3, "VXI-11 protocol", on page 135.

● X: communication is not possible without collisions
● viLock/viUnlock: communication is only possible, if the remote control com-

mands are enclosed in a viLock () - viUnlock() pair.

The R&S SGMA-GUI uses the viLock()/viUnlock() functions.

Monitoring remote control operation with R&S SGMA-GUI
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The figure below shows an example of configuration where the monitor and the con-
troller are two different computers, connected to the same instrument over two different
hardware interfaces.

Figure 12-7: Example of a setup for remote control monitoring

Connecting and configuring the monitoring PCs

In the "Setup > Security > Security Settings" dialog, check the state of the LAN and
USB interfaces and enable them if necessary.

1. Connect the monitoring PC to the instrument.

Note: Choose the hardware interface considering the limitations described in
Table 12-7.

2. Configure the instrument in the R&S SGMA-GUI: See Chapter 8.4.2, "Handling
instruments in the R&S SGMA-GUI", on page 73.

3. In the "SGMA-GUI > Setup > Instruments > Edit Instruments" dialog, disable
"Exclusive Access".

Note: The two functions "Exclusive Access" and monitoring are mutually exclusive.

4. Send remote control commands from the controller to the instrument.

5. Open the corresponding dialogs in the R&S SGMA-GUI. Observe the status of the
parameters.

Monitoring remote control operation with R&S SGMA-GUI
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13  Remote control commands
In the following, all remote-control commands are presented in detail with their param-
eters and the ranges of the numerical values.

For an introduction to remote control and the status registers, refer to the following sec-
tions:
● "Information on network operation and remote control" on page 129
● Chapter 12.5, "Status reporting system", on page 147

Conventions used in SCPI Command Descriptions

The following conventions are used in the remote command descriptions:
● Command usage

If not specified otherwise, commands can be used both for setting and for querying
parameters.
If a command can be used for setting or querying only, or if it initiates an event, the
usage is stated explicitly.

● Parameter usage
If not specified otherwise, a parameter can be used to set a value and it is the
result of a query.
Parameters required only for setting are indicated as Setting parameters.
Parameters required only to refine a query are indicated as Query parameters.
Parameters that are only returned as the result of a query are indicated as Return
values.

● Conformity
Commands that are taken from the SCPI standard are indicated as SCPI con-
firmed. All commands used by the R&S SGU follow the SCPI syntax rules.

● Asynchronous commands
A command which does not automatically finish executing before the next com-
mand starts executing (overlapping command) is indicated as an Asynchronous
command.

● Reset values (*RST)
Default parameter values that are used directly after resetting the instrument (*RST
command) are indicated as *RST values, if available.

● Factory preset values
Default parameter values that are reset only by factory preset.

● Default unit
The default unit is used for numeric values if no other unit is provided with the
parameter.

● Manual operation
If the result of a remote command can also be achieved in manual operation, a link
to the description is inserted.

● Programming Examples........................................................................................163
● Common commands.............................................................................................169
● General commands...............................................................................................173
● Preset commands................................................................................................. 174
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● CALibration subsystem......................................................................................... 175
● CONNector subsystem......................................................................................... 180
● DIAGnostic subsystem..........................................................................................180
● Fast speed commands..........................................................................................181
● FORMat Subsystem..............................................................................................181
● MMEMory subsystem............................................................................................183
● OUTPut subsystem...............................................................................................191
● SOURce subsystem..............................................................................................193
● SOURce:IQ subsystem.........................................................................................194
● SOURce:LOSCillator subsystem.......................................................................... 196
● SOURce:POWer subsystem.................................................................................198
● SOURce:PULM subsystem...................................................................................202
● STATus subsystem................................................................................................203
● SYSTem subsystem..............................................................................................207
● TEST subsystem...................................................................................................217
● UNIT subsystem....................................................................................................219
● List of R&S SGU commands.................................................................................219

13.1  Programming Examples

This chapter provides simple programming examples for the R&S SGU. The purpose
of the examples is to present all commands for a given task. In real applications, one
would rather reduce the examples to an appropriate subset of commands.

The programming examples have been tested with a software tool which provides an
environment for the development and execution of remote tests. To keep the examples
as simple as possible, only the "clean" SCPI syntax elements are reported. Non-exe-
cutable command lines (e.g. comments) start with two // characters.

At the beginning of most remote control programs, an instrument (p)reset is recom-
mended to set the R&S SGU to a defined state. The commands *RST and
SYSTem:PRESet are equivalent for this purpose. *CLS also resets the status registers
and clears the output buffer.

It is also recommended to lock the instrument for remote control from the selected con-
troller prior to further configuration. Use the LOCK command for this purpose.

13.1.1  Performing General Tasks for Instrument Setup

In the following example we assume that a remote PC is connected to the instrument,
the remote PC and the instrument are switched on and a connection between them is
established.

// ******************************************************************
// Reset the instrument first
// ******************************************************************

*RST; *CLS
// SYSTem:PRESet

Programming Examples
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// :RESTart
// SYSTem:FPReset

// ******************************************************************
// Lock the instrument to the controller
// ******************************************************************

LOCK? 12345
// Lock the instrument to avoid interference by other controllers
// Use an arbitrary number
// Response: 1
// Request granted, i.e. the instrument is locked
// Abort program if request is refused

// ******************************************************************
// Launch diagnostic 
// ******************************************************************

DIAGnostic:POINt:CATalog?
// Response: : D_TEMP_UP20,D_TEMP_CPU
DIAGnostic:MEASure:POINt? 'D_TEMP_UP20'

// ******************************************************************
// Query the entries in the error queue
// ******************************************************************

SYSTem:SERRor?
// Query static errors
// SYSTem:ERRor:CODE:NEXT?
// SYSTem:ERRor:COUNT?
// SYSTem:ERRor:NEXT?
// STATus:QUEue:NEXT?
// SYSTem:ERRor:CODE:ALL?
SYSTem:ERRor:ALL?
// Query error queue

// ******************************************************************
// Query system information
// ******************************************************************

SYSTem:VERSion?
SYSTem:OSYStem?

// ******************************************************************
// Activate eco mode
// ******************************************************************

SYSTem:EMODe EM1

// ******************************************************************
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// Unlock the instrument
// ******************************************************************

UNL 12345

13.1.2  Generating an I/Q Modulated Signal

In the following example we assume that a remote PC is connected to the instrument,
the remote PC and the instrument are switched on and a connection between them is
established. An external analog signal is provided at the I and Q connectors of the
instrument.

// ******************************************************************
// Reset the instrument first
// ******************************************************************

*RST; *CLS

// ******************************************************************
// Lock the instrument to the controller
// ******************************************************************

LOCK? 12345
// Lock the instrument to avoid interference by other controllers
// Use an arbitrary number
// Response: 1
// Request granted, i.e. the instrument is locked
// Abort program if request is refused

// ******************************************************************
// Set RF frequency and level 
// ******************************************************************

SOURce:FREQuency:CW 2 GHz
SOURce:POWer:-10dBm
SOURce:POWer:PEP?

// ******************************************************************
// Define and enable impairments
// Enable modulation
// ******************************************************************

SOURce:IQ:STATe ON 
SOURce:IQ:IMPairment:STATe ON

SOURce:IQ:IMPairment:LEAKage:I -1
SOURce:IQ:IMPairment:LEAKage:Q 1
SOURce:IQ:IMPairment:IQRatio: 1
SOURce:IQ:IMPairment:QUADrature:ANGLe 2
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SOURce:IQ:CREStfactor 0.05

// ******************************************************************
// Enable output of the generated signal at the RF connector
// ******************************************************************

OUTPut:STATe ON
OUTPut:STATe:PON UNCH

// ******************************************************************
// Query LO frequency and power values and set LO
// ******************************************************************

LOSCillator:FREQuency?
LOSCillator:POWer?

// Set frequency and power on the local oscillator as required

// ******************************************************************
// Switch on the signal
// ******************************************************************

SETTings:APPLy

// ******************************************************************
// Unlock the instrument
// ******************************************************************

UNL 12345

13.1.3  Advanced Task for Optimizing Performance

In the following example we assume that a remote PC is connected to the instrument,
the remote PC and the instrument are switched on and a connection between them is
established.

// ******************************************************************
// Reset the instrument first
// ******************************************************************

*RST; *CLS
// SYSTem:PRESet
// :RESTart
// SYSTem:FPReset

// ******************************************************************
// Lock the instrument to the controller
// ******************************************************************
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LOCK? 12345
// Lock the instrument to avoid interference by other controllers
// Use an arbitrary number
// Response: 1
// Request granted, i.e. the instrument is locked
// Abort program if request is refused

// ******************************************************************
// Query the level that can be set without adjustments of the attenuator 
// ******************************************************************

OUTPut:AFIXed:RANGe:LOWer?
OUTPut:AFIXed:RANGe:UPPer?

// ******************************************************************
// Optimizing the quality characteristics of the RF signal
// ******************************************************************

SOURce:POWer:LMODe LNOise
// optimize the signal to low noise ratio
SOURce:POWer:SCHaracteristic AUTO
// ensure highest dynamic range
SOURce:POWer:LEVel:IMMediate:AMPLitude -30dBm
SOURce:POWer:LIMit:AMPLitude 30dBm

OUTPut:STATe:PON UNCHanged

// ******************************************************************
// Query local oscillator frequency and power values and set LO
// ******************************************************************

LOSCillator:FREQuency?
LOSCillator:POWer?

// Set frequency and power on the local oscillator as required

// ******************************************************************
// Switch on the signal
// ******************************************************************

SETTings:APPLy

// ******************************************************************
// Unlock the instrument
// ******************************************************************

UNL 12345
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13.1.4  Adjusting Network and Remote Channel Settings

In the following example we assume that a remote PC is connected to the instrument,
the remote PC and the instrument are switched on and a connection between them is
established.

// ******************************************************************
// Reset the instrument first
// ******************************************************************

*RST; *CLS

// ******************************************************************
// Lock the instrument to the controller
// ******************************************************************

LOCK? 12345
// Lock the instrument to avoid interference by other controllers
// Use an arbitrary number
// Response: 1
// Request granted, i.e. the instrument is locked
// Abort program if request is refused

// ******************************************************************
// Query the VISA resource strings
// ******************************************************************

SYSTem:COMMunicate:NETWork:RESource?
// Response: TCPIP::10.113.10.187::INSTR
SYSTem:COMMunicate:SOCKet:RESource?
// Response: TCPIP:10.113.10.187::5025::SOCKET
SYSTem:COMMunicate:USB:RESource?
// Response: USB::0x0AAD::0x00ce::100021::INSTR
SYSTem:COMMunicate:PCIexpress:RESource?
// Response: PCIe::0x162f::0x132f::100002::INSTR

// ******************************************************************
// Query network settings
// ******************************************************************

SYSTem:COMMunicate:NETWork:COMMon:HOSTname?
// Response: rssgu100a100002
SYSTem:COMMunicate:NETWork:IPADdress:MODE?
// Response: AUTO
SYSTem:COMMunicate:NETWork:IPADdress?
// Response: 10.113.10.187
SYSTem:COMMunicate:NETWork:IPADdress:SUBNet:MASK?
// Response: 255.255.0.0
SYSTem:COMMunicate:NETWork:IPADdress:GATeway?
// Response: 10.113.0.1
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// ******************************************************************
// Unlock the instrument
// ******************************************************************

UNL 12345

13.2  Common commands

Common commands are described in the IEEE 488.2 (IEC 625-2) standard. These
commands have the same effect and are employed in the same way on different devi-
ces. The headers of these commands consist of "*" followed by three letters. Many
common commands are related to the Status Reporting System.

Available common commands:

*CLS.............................................................................................................................169
*ESE.............................................................................................................................169
*ESR?...........................................................................................................................170
*IDN?............................................................................................................................170
*IST?............................................................................................................................ 170
*OPC............................................................................................................................170
*OPT?...........................................................................................................................171
*PRE............................................................................................................................ 171
*PSC............................................................................................................................ 171
*RCL.............................................................................................................................171
*RST.............................................................................................................................172
*SAV.............................................................................................................................172
*SRE............................................................................................................................ 172
*STB?...........................................................................................................................172
*TRG............................................................................................................................ 172
*WAI.............................................................................................................................173

*CLS

Clear status

Sets the status byte (STB), the standard event register (ESR) and the EVENt part of
the QUEStionable and the OPERation registers to zero. The command does not
alter the mask and transition parts of the registers. It clears the output buffer.

Usage: Setting only

*ESE <Value>

Event status enable

Sets the event status enable register to the specified value. The query returns the con-
tents of the event status enable register in decimal form.
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Parameters:
<Value> Range: 0 to 255

*ESR?

Event status read

Returns the contents of the event status register in decimal form and then sets the reg-
ister to zero.

Return values: 
<Contents> Range: 0  to  255

Usage: Query only

*IDN?

Identification

Returns the instrument identification.

Return values: 
<ID> "Rohde&Schwarz,<device type>,<part number>/<serial num-

ber>,<firmware version>"

Example: Rohde&Schwarz,SGU100A,
1412.0000K02/000000,3.1.17.1-03.01.158

Usage: Query only

*IST?

Individual status query

Returns the contents of the IST flag in decimal form. The IST flag is the status bit
which is sent during a parallel poll.

Return values: 
<ISTflag> 0 | 1

Usage: Query only

*OPC

Operation complete

Sets bit 0 in the event status register when all preceding commands have been execu-
ted. This bit can be used to initiate a service request. The query writes a "1" into the
output buffer when all preceding commands have been executed, which is useful for
command synchronization.
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*OPT?

Option identification query

Queries the options included in the instrument. For a list of all available options and
their description, refer to the data sheet.

Return values: 
<Options> The query returns a list of options. The options are returned at

fixed positions in a comma-separated string. A zero is returned
for options that are not installed.

Usage: Query only

*PRE <Value>

Parallel poll register enable

Sets parallel poll enable register to the indicated value. The query returns the contents
of the parallel poll enable register in decimal form.

Parameters:
<Value> Range: 0  to  255

*PSC <Action>

Power on status clear

Determines whether the contents of the ENABle registers are preserved or reset when
the instrument is switched on. Thus a service request can be triggered when the instru-
ment is switched on, if the status registers ESE and SRE are suitably configured. The
query reads out the contents of the "power-on-status-clear" flag.

Parameters:
<Action> 0 | 1

0
The contents of the status registers are preserved.
1
Resets the status registers.

*RCL <Number>

Recall

Loads the instrument settings from an intermediate memory identified by the specified
number. The instrument settings can be stored to this memory using the command
*SAV with the associated number.

It also activates the instrument settings which are stored in a file and loaded using the
MMEMory:LOAD <number>, <file_name.extension> command.
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*RST

Reset

Sets the instrument to a defined default status. The default settings are indicated in the
description of commands.

The command is equivalent to SYSTem:PRESet.

Usage: Setting only

*SAV <Number>

Save

Stores the current instrument settings under the specified number in an intermediate
memory. The settings can be recalled using the command *RCL with the associated
number.

To transfer the stored instrument settings in a file, use the command :MMEMory:
STORe:STATe.

*SRE <Contents>

Service request enable

Sets the service request enable register to the indicated value. This command deter-
mines under which conditions a service request is triggered.

Parameters:
<Contents> Contents of the service request enable register in decimal form.

Bit 6 (MSS mask bit) is always 0.
Range: 0  to  255

*STB?

Status byte query

Reads the contents of the status byte in decimal form.

Usage: Query only

*TRG

Trigger

Triggers all actions waiting for a trigger event. In particular, *TRG generates a manual
trigger signal. This common command complements the commands of the TRIGger
subsystem.

Usage: Event
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*WAI

Wait to continue

Prevents servicing of the subsequent commands until all preceding commands have
been executed and all signals have settled (see also command synchronization and
*OPC).

Usage: Event

13.3  General commands

:REMote:OPMode..........................................................................................................173
:LOCK?.........................................................................................................................173
:UNLock........................................................................................................................174

:REMote:OPMode <OpMode>

Sets the remote operation mode of the instrument.

Parameters:
<OpMode> STDalone | EXTension

STDalone
The instrument acts standalone.
EXTension
The instrument is controlled by another Rohde&Schwarz instru-
ment. This parameter is used by the SGMA-GUI to disable set-
tings when the instrument is in extension mode.
*RST: STDalone

:LOCK? <Lock Request Id>

Sends a lock request ID which uniquely identifies the controller of the instrument.

Parameters:
<Lock Request Id> Number

0
test query to check whether the instrument is locked
Controller ID
request lock from the controller with the specified Controller ID

Return values: 
<Value> Number

0
request refused; the instrument is already locked to another
<Lock Request Id>, i.e. to another controller
1
request granted
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Example: :LOCK? 12345
Response: 1
:UNL 12345

Usage: Query only

Manual operation: See "Exclusive Access" on page 65

:UNLock <Unlock Id>

Unlocks an instrument locked to a controller with Controller ID = <Unlock Id>.

Setting parameters: 
<Unlock Id> Number

Unlock ID which uniquely identifies the controller of the instru-
ment. The value must match the Controller ID <Lock Request
Id> set with the command :LOCK?.

Usage: Setting only

Manual operation: See "Exclusive Access" on page 65

13.4  Preset commands

The following preset actions are available:
● Activation of the default state of all internal instrument functions (*RST

on page 172). Functions that concern the integration of the instrument into a mea-
surement setup are not changed, e.g. TCP/IP address or remote operating mode.

● Activation of the original state of delivery (factory reset, :SYSTem:FPReset
on page 175). Only functions that are protected by a password remain unchanged
and the passwords themselves.

:SOURce<hw>:PRESet
:SYSTem:PRESet
Triggers an instrument reset. It has the same effect as:
● The *RST command
● The "SGMA-GUI > Instrument Name > Preset" function.

However, the command does not close open GUI dialogs like the function does.

For an overview of the settings affected by the preset function, see Chapter 9.7, "Pre-
set", on page 104.

Example: SYST:PRES
All instrument settings (also the settings that are not currently
active) are reset to their default values.

Usage: Setting only
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:SYSTem:FPReset

The command triggers an instrument reset to the original state of delivery.Only func-
tions that are protected by a password remain unchanged.

The factory preset function resets nearly all instrument settings. In addition to the regu-
lar preset a "Factory Preset" resets also the following values:
● Power on settings ("Level" dialog)
● Network settings including hostname ("Setup > Network Setting" dialog)
● Remote Channel settings ("Setup > Remote Channel" dialog)

For an overview of the settings affected by the factory preset function, see Chap-
ter 10.8, "Factory preset", on page 117.

Example: SYST:FPR
all instrument settings (also those that are not currently active)
are reset to the factory values.

Usage: Event

Manual operation: See "Execute Factory Preset" on page 117

13.5  CALibration subsystem

The CALibration system contains the commands needed for calibrating the R&S SGU.

R&S SGU cannot be calibrated on its own. Therefore a connection with a signal gener-
ator (local oscillator (LO)) is needed. If you use a compatible R&S signal generator,
then the calibration process will be completed automatically after starting the calibra-
tion process. Otherwise you have to follow the steps described in "Calibration process
of the R&S SGU" on page 176. We assume that a remote PC is connected to the
instruments, the remote PC and the instruments are switched on and a connection
between them is established.

The selftest of an R&S SGU also requires a similar instrumental setup. You can per-
form the selftest and read its results using the commands :TEST:ALL:STARt and :
TEST:ALL:RESult?.
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Calibration process of the R&S SGU

Figure 13-1: Calibration process of the R&S SGU. No physical connections between the instruments
are shown in this graphic.

To complete the calibration process, complete the following steps:

1. Start an adjustment request with the SCPI com-
mand :CALibration:xxx:STARt, where xxx stands for IQModulator,
IQModulator:LOCal or LEVel.

2. :CALibration:HREQuest?
a) Query R&S SGU for the required LO settings with the SCPI command :

CALibration:HREQuest?.
b) Interpret the response of the query. A SCPI command returns the response.

For example, a response :SOUR:POW 6 asks for a power of 6 dBm.
For a list of all possible responses see :CALibration:HREQuest?
on page 177.

3. Set the LO according to the required settings.

4. Repeat steps 2 and 3 until the value of step 2b is :CALibration:HREQ:STOP.

5. :CALibration:xxx:RESult?
xxx stands for IQModulator, IQModulator:LOCal or LEVel
a) Query the result of the adjustment request with the SCPI com-

mand :CALibration:xxx:RESult?.
b) The query returns either 0 or 1 signifying pass or fail.

The instrument is calibrated and can be further used.

Table 13-1 shows the described process. If you use a compatible R&S signal generator
the whole process is completed automatically.
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Table 13-1: Programming example of a calibration process

Local Oscillator/ Controller R&S SGU Response Interpretation

1):CALibration:LEVel:
STARt

- R&S SGU starts the Level Adjustment.

2):CALibration:HREQuest? :PROG:CREate Level
Adjustment

To do: create a progress bar with a caption
"Level Adjustment".

3):CALibration:HREQuest? :OUTP:STATe 1 To do: activate the RF output of the LO.

4):CALibration:HREQuest? :PROG:UPDate 5 The progress of the level adjustment is 5
%.

5):CALibration:HREQuest? :SOUR:FREQ 15e9;

:SOUR:POW -10.0
To do: set the frequency of the LO to
15GHZ and its level to -10dBm

6):CALibration:HREQuest? :SOUR:POW 5 To do: set the level of the LO to 5dBm.

7):CALibration:HREQuest? :PROG:UPDate 20 The progress of the level adjustment is 20
%.

8):CALibration:HREQuest? :SOUR:POW 20 To do: set the level of the LO to 5dBm.

9):CALibration:HREQuest? :PROG:UPDate 100 The progress of the level adjustment is 100
%.

10):CALibration:HREQuest? :PROG:REMove To do: delete the progress bar.

11):CALibration:HREQuest? :OUTP:STATe 0 To do: deactivate the RF output of the LO.

12):CALibration:HREQuest? :CAL:HREQ:STOP End of the calibration process.

:CALibration:HREQuest?................................................................................................ 177
:CALibration:IQModulator:STARt......................................................................................178
:CALibration:IQModulator:RESult?...................................................................................178
:CALibration:IQModulator:TEMPerature?..........................................................................178
:CALibration:IQModulator:LOCal:STARt........................................................................... 179
:CALibration:IQModulator:LOCal:RESult?.........................................................................179
:CALibration:LEVel:STARt...............................................................................................179
:CALibration:LEVel:RESult?............................................................................................ 179
:CALibration:LEVel:TEMPerature?................................................................................... 179

:CALibration:HREQuest?

Queries the settings required from the instrument during a calibration or a selftest.

See "Calibration process of the R&S SGU" on page 176 for a step by step description
of the calibration process.

Return values: 
<Command> string

All of the commands described below return the values in the
parameter's default unit.
:VERsion <Number>
Shows the command set version with which the instrument is
compliant
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:OUTP:STATe <Number>
Shows the state required of the local oscillator
:SOUR:FREQ <Number>
Shows the frequency required of the local oscillator
:SOUR:POW<Number>
Shows the power required of the external local oscillator
:PROG:CREate <Text>
Asks the controller to create a progress bar
:PROG:REName <Text>
Asks the controller to rename the progress bar
:PROG:REMove
Asks the controller to delete the most recently created progress
bar
:PROG:UPDate <Number>
Shows the current progress value in percent
:NOP/:NO DATA
Intermediate message. No action is required
:CAL:HREQ:STOP
End of the calibration procedure

Example: See Table 13-1.

Usage: Query only

:CALibration:IQModulator:STARt

Starts an internal I/Q adjustment. Query the result of the adjustment with the SCPI
command :CALibration:IQModulator:RESult?.

See "Calibration process of the R&S SGU" on page 176 for a step by step description
of the calibration process.

Usage: Event

:CALibration:IQModulator:RESult?

Queries the result of the internal I/Q adjustment. Start the adjustment with the SCPI
command :CALibration:IQModulator:STARt.

Return values: 
<Result> 0 | 1 | RUNning | STOPped

Usage: Query only

:CALibration:IQModulator:TEMPerature?

Queries the delta temperature since the last adjustment of the IQ modulator.

Return values: 
<Temperature> string
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Usage: Query only

:CALibration:IQModulator:LOCal:STARt

Starts an adjustment for the I/Q modulator of the current frequency. The I/Q modulator
is adjusted with respect to carrier leakage, I/Q imbalance and quadrature. Query the
result of the adjustment with the SCPI command :CALibration:IQModulator:
LOCal:RESult?.

See "Calibration process of the R&S SGU" on page 176 for a step by step description
of the calibration process.

Usage: Event

:CALibration:IQModulator:LOCal:RESult?

Queries the result of the I/Q modulation adjustment for the current frequency. Start the
adjustment with the SCPI command :CALibration:IQModulator:LOCal:STARt
on page 179.

Return values: 
<Result> 0 | 1 | RUNning | STOPped

Usage: Query only

:CALibration:LEVel:STARt

Starts an internal level adjustment. Query the result of the adjustment with the SCPI
command :CALibration:LEVel:RESult?.

See "Calibration process of the R&S SGU" on page 176 for a step by step description
of the calibration process.

Usage: Event

:CALibration:LEVel:RESult?

Queries the result of the internal level adjustment. Start the adjustment with the SCPI
command :CALibration:LEVel:STARt.

Return values: 
<Result> 0 | 1 | RUNning | STOPped

Usage: Query only

:CALibration:LEVel:TEMPerature?

Queries the delta temperature since the last level adjustment.

Return values: 
<Temperature> string
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Usage: Query only

13.6  CONNector subsystem

:CONNector:TRIGger:OMODe.........................................................................................180

:CONNector:TRIGger:OMODe <Mode>

Sets the operating mode of the trigger connector.

Parameters:
<Mode> SVALid | SNValid | PEMSource

SVALid|SNValid
signal valid /not valid
PEMSource
external pulse modulator source

Manual operation: See "Trigger Connector Mode" on page 102

13.7  DIAGnostic subsystem

:DIAGnostic:POINt:CATalog?...........................................................................................180
:DIAGnostic[:MEASure]:POINt?.......................................................................................180

:DIAGnostic:POINt:CATalog?

Queries the test points available in the instrument.

For description of the test points, see the service manual.

Example: See Chapter 13.1.1, "Performing General Tasks for Instrument
Setup", on page 163.

Usage: Query only

:DIAGnostic[:MEASure]:POINt? <Name>

Triggers a voltage or a temperature measurement at the specified test point and
returns the measured value.

Use the command :DIAGnostic:POINt:CATalog? to retrieve a list of the available
test points.

For description of the test points, see the service manual.

Query parameters: 
<Name> string
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Return values: 
<Value> number

Default unit: V or °C

Example: See Chapter 13.1.1, "Performing General Tasks for Instrument
Setup", on page 163.

Usage: Query only

13.8  Fast speed commands

This section describes special commands that allow a fast frequency and level setting.

:FFASt.......................................................................................................................... 181
:PFASt.......................................................................................................................... 181

:FFASt <Freq>

Special command to set the RF output frequency with minimum latency. No unit (e.g.
Hz) allowed.

Bypasses the status system so command *OPC? cannot be appended.

Parameters:
<Freq> float

Example: FFASt 12750000000

:PFASt <Pow>

Special command to set the RF output level with minimum latency at the RF output
connector. This value does not consider a specified offset. No unit (e.g. dBm) allowed.

Bypasses the status system so command *OPC? cannot be appended.

Parameters:
<Pow> float

Example: :PFASt -20

13.9  FORMat Subsystem

The FORMat subsystem contains the commands which determine the format of the
data that the R&S SGU returns to the controller. This affects all query commands
which return a list of numerical data or block data. Reference is made to this in the
descriptions of the commands.

:FORMat:BORDer..........................................................................................................182
:FORMat[:DATA]............................................................................................................ 182
:FORMat:SREGister.......................................................................................................182
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:FORMat:BORDer <Border>

Determines the sequence of bytes within a binary block. This only affects blocks which
use the IEEE754 format internally.

Parameters:
<Border> NORMal | SWAPped

NORMal
The instrument expects (with setting commands) and sends
(with queries) the least significant byte of each IEEE754 floating-
point number first and the most significant byte last.
SWAPped
The instrument expects (with setting commands) and sends
(with queries) the most significant byte of each IEEE754 floating-
point number first and the least significant byte last.
*RST: NORMal

Example: FORM:BORD SWAP
The data is transferred with the most significant bit first.

:FORMat[:DATA] <Data>

Determines the data format which the R&S SGU uses to return data. When data is
transferred from the control computer to the instrument, the instrument detects the data
format automatically. In this case, the value set here is irrelevant.

Parameters:
<Data> ASCii | PACKed

ASCii
Numerical data is transferred as plain text separated by com-
mas.
PACKed
Numerical data is transferred as binary block data. The format
within the binary data depends on the command. The various
binary data formats are explained in the description of the
parameter types.
*RST: ASCii

Example: FORM ASC
The data is transferred as ASCII data.

:FORMat:SREGister <Format>

Determines the numerical format which is returned when the status registers are quer-
ied.

Parameters:
<Format> ASCii | BINary | HEXadecimal | OCTal

ASCii
The register content is returned as a decimal number.
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BINary
The register content is returned as a binary number. #B is
placed in front of the number.
HEXadecimal
The register content is returned as a hexadecimal number. #H is
placed in front of the number.
OCTal
The register content is returned as an octal number. #Q is
placed in front of the number.
*RST: ASCii

Example: FORM:SREG HEX
The register content is returned as a hexadecimal number.

13.10  MMEMory subsystem

The MMEMory subsystem (Mass Memory) contains the commands for managing files
and directories as well as for loading and storing complete instrument settings in files.

The files are stored on the internal flash memory of the instrument or on external USB
memory devices.

The default directory is determined using the command MMEMory:CDIR.

Use the command :SYSTem:MMEMory:PATH:USER? to query the path of the direc-
tory for user-defined data.

The /opt directory is a protected and therefore a not accessible system directory. The
files on this directory contain data that must not be changed. Therefore, this directory
should not be accessed, since reconstruction of the system partition will lead to data
loss.

13.10.1  File naming conventions

To enable files in different file systems to be used, the following file naming conven-
tions should be observed.

The file name can be of any length and is case-sensitive, meaning it is distinguished
between uppercase and lowercase letters.

The file and the optional file extension are separated by a dot. All letters and numbers
are permitted (numbers are, however, not permitted at the beginning of the file name).
If possible, special characters should not be used. The use of the slashes "\" and "/"
should be avoided since they are used in file paths. A number of names are reserved
for the operating system, e.g. CLOCK$, CON, AUX, COM1...COM4, LPT1...LPT3, NUL
and PRN.
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In the R&S SGU all files in which lists and settings are stored are given a characteristic
extension. The extension is separated from the actual file name by a dot (see Chap-
ter 13.10.2, "Extensions for user files", on page 184 for an overview of the file types).

The two characters "*" and "?" function as "wildcards", meaning they are used for
selecting several files. The "?" character represents exactly one character, while the "*"
character represents all characters up to the end of the file name. "*.*" therefore stands
for all files in a directory.

When used in conjunction with the commands, the parameter <file_name> is speci-
fied as a string parameter with quotation marks. It can contain either the complete path
including the drive, only the path and the file name, or only the file name. The file name
must include the file extension. The same applies for the parameters
<directory_name> and <path>.

Depending on how much information is provided, either the values specified in the
parameter or the values specified with the command MMEM:CDIR (default directory)
are used for the path and the drive settings in the commands.

Before the instrument settings can be stored in a file, they have to be stored in an inter-
mediate memory using common command *SAV <number>. The specified number is
subsequently used in the :MMEMory:STORe:STATe on page 191 command. Also,
subsequently to loading a file with instrument settings with command :MMEMory:
LOAD:STATe on page 189, these settings have to be activated with the common com-
mand *RCL <number>.

13.10.2  Extensions for user files

The following table lists all available file extensions for user files.
Table 13-2: Automatically assigned file extensions in the instrument

Function Contents File suffix

R&S SGMA-GUI Save As/Open Software settings *.savrcl

13.10.3  Examples

In these examples, the current instrument setting is stored in the file
test.savrcltxt in the directory /var/user/..

Storing and Loading Current Settings

1. Store the current setting in an intermediate memory with the number 4. This setting
can be called using command *RCL and the associated number of the memory, for
example *RCL 4.
*SAV 4

2. To store the settings in a file in a specific directory, specify the complete path.
MMEM:STOR:STAT 4,"/var/user/test.savrcltxt"
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3. To store the settings in a file in the default drive, set the default drive and specify
only the file name.
MMEM:CDIR '/var/user/'*SAV 4
MMEM:STOR:STAT 4,"test.savrcltxt"

4. Load the file test.savrcltxt in the user directory.
MMEM:LOAD:STAT 4,'/var/user/test.savrcltxt'

5. Activate the instrument setting of the file test.savrcltxt.
*RCL 4

Working with Files and Directories

1. Read out all files in the specified directory.
MMEM:CAT? '/usb/user'
Response: 127145265,175325184,"test,DIR,0","temp,DIR,0",
"readme.txt,ASC,1324","state.savrcltxt,STAT,5327",
"waveform.wv,BIN,2342"
the directory /usb/user contains the subdirectories test and temp as well as
the files readme.txt, state.savrcltxt and waveform.wv which have differ-
ent file types.

Tip: To query only the subdirectories of the current or specified directory, perform:
MMEM:DCAT? '/usb/user'
Response: 'test', 'temp'
To query only the number of subdirectories in the current or specified directory, per-
form:
MMEM:DCAT:LENG? '/usb/user'
Response: 2

2. To query the number of files in the current or specified directory, perform:
MMEM:CAT:LENG? '/usb/user'
Response: 3

3. Create a new subdirectory for mass memory storage in the specified directory.
MMEM:MDIR '/usb/new'

4. Copy the file state to a new file.
MMEM:COPY '/var/user/state.savrcltxt','/usb/new'

5. Rename the file state.
MMEM:MOVE 'state.savrcltxt','state_new.savrcltxt'

6. Remove the test directory.
MMEM:RDIR 'usbtest'
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13.10.4  Remote control commands

:MMEMory:CATalog?......................................................................................................186
:MMEMory:CATalog:LENGth?......................................................................................... 186
:MMEMory:CDIRectory...................................................................................................187
:MMEMory:COPY...........................................................................................................187
:MMEMory:DATA............................................................................................................188
:MMEMory:DCATalog?....................................................................................................188
:MMEMory:DCATalog:LENGth?....................................................................................... 189
:MMEMory:DELete.........................................................................................................189
:MEMory:HFRee?.......................................................................................................... 189
:MMEMory:LOAD:STATe.................................................................................................189
:MMEMory:MDIRectory...................................................................................................190
:MMEMory:MOVE.......................................................................................................... 190
:MMEMory:MSIS............................................................................................................190
:MMEMory:RDIRectory...................................................................................................191
:MMEMory:STORe:STATe...............................................................................................191

:MMEMory:CATalog? <path>

Returns the content of a particular directory.

Query parameters: 
<path> string

String parameter to specify the directory.
If you leave out the path, the command returns the contents of
the directory selected with :MMEMory:CDIRectory.
The path may be relative or absolute.

Return values: 
<UsedDiskSpace> Byte size of all files in the directory.

<FreeDiskSpace> Remaining disk space in bytes.

<FileInfo> <NameFileN>,<SuffixFileN>,<SizeFileN>
List of files, separated by commas
<NameFileN>
Name of the file.
<SuffixFileN>
Type of the file. Possible suffixes are: ASCii, BINary, DIRectory
<SizeFileN>
Size of the file in bytes.

Example: See "Working with Files and Directories" on page 185.

Usage: Query only

:MMEMory:CATalog:LENGth? <Path>

Returns the number of files in the current or in the specified directory.
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Query parameters: 
<Path> string

String parameter to specify the directory. If the directory is omit-
ted, the command queries the content of the current directory,
queried with :MMEMory:CDIRectory command.

Return values: 
<FileCount> integer

Number of files.

Example: See "Working with Files and Directories" on page 185.

Usage: Query only

:MMEMory:CDIRectory <Directory>

Changes the default directory for mass memory storage. The directory is used for all
subsequent MMEM commands if no path is specified with them.

Parameters:
<Directory> <directory_name>

String containing the path to another directory. The path can be
relative or absolute.
To change to a higher directory, use two dots '..' .

Example: See "Working with Files and Directories" on page 185.

Usage: SCPI confirmed

:MMEMory:COPY <SourceFile>[,<DestinationFile>]

Copies an existing file to a new file. Instead of just a file, this command can also be
used to copy a complete directory together with all its files.

Setting parameters: 
<SourceFile> string

String containing the path and file name of the source file

<DestinationFile> string
String containing the path and name of the target file. The path
can be relative or absolute.
If <DestinationFile> is not specified, the <SourceFile> is
copied to the current directory, queried with the :MMEMory:
CDIRectory command.
Note: Existing files with the same name in the destination direc-
tory are overwritten without an error message.

Example: See "Working with Files and Directories" on page 185.

Usage: Setting only
SCPI confirmed
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:MMEMory:DATA <Filename>, <BinaryBlock>
:MMEMory:DATA? <Filename>

The setting command writes the block data <BinaryBlock> to the file identified by
<Filename>.

Tip: Use this command to read/transfer stored instrument settings or waveforms
directly from/to the instrument.

Parameters:
<BinaryBlock> #<number><length_entry><data>

#: Hash sign; always comes first in the binary block
<number>: the first digit indicates how many digits the subse-
quent length entry has
<length_entry>: indicates the number of subsequent bytes
<data>: binary block data for the specified length.
For files with a size with more than nine digits (gigabytes), the
instrument allows the syntax #(<Length>), where <Length>
is the file size in decimal format.

Parameters for setting and query: 
<Filename> string

String parameter to specify the name of the file.

Example: MMEMory:DATA '/var/user/test.txt',#15hallo
Writes the block data to the file test.txt.
The digit 1 indicates a length entry of one digit; the digit 5 indi-
cate a length of the binary data (hallo) in bytes.
MMEMory:DATA? '/var/user/test.txt'
Sends the data of the file test.txt from the instrument to the
controller in the form of a binary block.
Response: #15hallo

Usage: SCPI confirmed

:MMEMory:DCATalog? <path>

Returns the subdirectories of a particular directory.

Query parameters: 
<path> String parameter to specify the directory. If the directory is omit-

ted, the command queries the content of the current directory,
queried with :MMEMory:CDIRectory command.

Return values: 
<Catalog> <file_entry>

Names of the subdirectories separated by colons. The first two
strings are related to the parent directory.

Example: See "Working with Files and Directories" on page 185.

Usage: Query only
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:MMEMory:DCATalog:LENGth? [<Path>]

Returns the number of subdirectories in the current or specified directory.

Query parameters: 
<Path> String parameter to specify the directory. If the directory is omit-

ted, the command queries the contents of the current directory,
to be queried with :MMEMory:CDIRectory command.

Return values: 
<DirectoryCount> integer

Number of parent and subdirectories.

Example: See "Working with Files and Directories" on page 185.

Usage: Query only

:MMEMory:DELete <Filename>

Removes a file from the specified directory.

Setting parameters: 
<Filename> string

String parameter to specify the name and directory of the file to
be removed.

Example: See "Working with Files and Directories" on page 185.

Usage: Event
SCPI confirmed

:MEMory:HFRee?

Returns the used and available memory in Kb.

Return values: 
<TotalPhysMemKb> integer

Total physical memory.

<ApplicMemKb> integer
Application memory.

<HeapUsedKb> integer
Used heap memory.

<HeapAvailableKb> integer
Available heap memory.

Usage: Query only

:MMEMory:LOAD:STATe <SavRclStateNumb>, <file_name>

Loads the specified file stored under the specified name in an internal memory.
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After the file has been loaded, the instrument setting must be activated using an *RCL
command.

Setting parameters: 
<SavRclStateNumb> Determines to the specific <number> to be used with the *RCL

command, e.g. *RCL 4.

<file_name> String parameter to specify the file name with extension
*.savrcltxt.

Example: See "Storing and Loading Current Settings" on page 184.

Usage: Setting only

:MMEMory:MDIRectory <Directory>

Creates a subdirectory for mass memory storage in the specified directory. If no direc-
tory is specified, a subdirectory is created in the default directory. This command can
also be used to create a directory tree.

Setting parameters: 
<Directory> string

String parameter to specify the new directory.

Example: See "Working with Files and Directories" on page 185.

Usage: Event

:MMEMory:MOVE <SourceFile>, <DestinationFile>

Moves an existing file to a new location or, if no path is specified, renames an existing
file.

Setting parameters: 
<SourceFile> string

String parameter to specify the name of the file to be moved.

<DestinationFile> string
String parameters to specify the name of the new file.

Example: See "Working with Files and Directories" on page 185.

Usage: Event
SCPI confirmed

:MMEMory:MSIS <Msis>

Defines the drive or network resource (in the case of networks) for instruments with
windows operating system, using msis (MSIS = Mass Storage Identification String).

Note: Instruments with Linux operating system ignore this command, since Linux does
not use drive letter assignment.

Usage: SCPI confirmed
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:MMEMory:RDIRectory <Directory>

Removes an existing directory from the mass memory storage system. If no directory
is specified, the subdirectory with the specified name is deleted in the default directory.

Setting parameters: 
<Directory> string

String parameter to specify the directory to be deleted.

Example: See "Working with Files and Directories" on page 185.

Usage: Event

:MMEMory:STORe:STATe <savrcl_state_nr>, <file_name>

Stores the current instrument setting in the specified file.

The instrument setting must first be stored in an internal memory with the same num-
ber using the common command *SAV.

Setting parameters: 
<savrcl_state_nr> Corresponds to the specific <number> defined with the *SAV

command, e.g. *SAV 4.

<file_name> String parameter to specify the file name with extension
*.savrcltxt.

Example: See "Storing and Loading Current Settings" on page 184.

Usage: Event

13.11  OUTPut subsystem

:OUTPut:AMODe........................................................................................................... 191
:OUTPut[:STATe]............................................................................................................192
:OUTPut[:STATe]:PON....................................................................................................192
:OUTPut:AFIXed:RANGe:LOWer?...................................................................................192
:OUTPut:AFIXed:RANGe:UPPer?....................................................................................193
:OUTPut<hw>:PROTection:CLEar................................................................................... 193

:OUTPut:AMODe <AMode>

Sets the mode of the attenuator (Attenuator MODe) at the RF output.

Parameters:
<AMode> AUTO | FIXed

AUTO
The attenuator is switched automatically. The level settings are
made in the full range.
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FIXed
The level settings are made without switching the attenuator.
When this operating mode is switched on, the attenuator is fixed
to its current position and the resulting variation range is defined.
*RST: AUTO

Manual operation: See "Mode" on page 93

:OUTPut[:STATe] <State>

Activates/deactivates the RF output.

Parameters:
<State> 1 | ON | 0 | OFF

Example: See Chapter 13.1.2, "Generating an I/Q Modulated Signal",
on page 165.

Manual operation: See "RF On/Off" on page 72

:OUTPut[:STATe]:PON <Mode>

Selects the state which the RF output takes when the instrument is switched on.

Parameters:
<Mode> OFF | UNCHanged

OFF
When the instrument is switched on, the output is deactivated .
UNCHanged
When the instrument is switched on, the output remains in the
same state as it was before the instrument was switched off.
*RST: UNCHanged

Example: See Chapter 13.1.2, "Generating an I/Q Modulated Signal",
on page 165 .

Manual operation: See "Power-On State" on page 94

:OUTPut:AFIXed:RANGe:LOWer?

Queries the minimum level which can be set without the attenuator being adjusted.

Return values: 
<Lower> float

Default unit: dBm

Example: See Chapter 13.1.3, "Advanced Task for Optimizing Perfor-
mance", on page 166.

Usage: Query only

Manual operation: See "Level Range" on page 93
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:OUTPut:AFIXed:RANGe:UPPer?

Queries the maximum level which can be set without the attenuator being adjusted.

Return values: 
<Upper> float

Default unit: dBm

Example: See Chapter 13.1.3, "Advanced Task for Optimizing Perfor-
mance", on page 166 .

Usage: Query only

Manual operation: See "Level Range" on page 93

:OUTPut<hw>:PROTection:CLEar

Resets the protective circuit after it has been tripped. The state of the output is again
determined by OUTPut:STATe.

Example: OUTP:PROT:CLE
resets the protective circuit for RF output.

Usage: Event

13.12  SOURce subsystem

[:SOURce]:SETTings:APPLy[:IMMediate]......................................................................... 193
[:SOURce]:FREQuency[:CW|FIXed].................................................................................193
[:SOURce]:TRAits<ch>...................................................................................................194
[:SOURce]:TRAits:COUNt?............................................................................................. 194

[:SOURce]:SETTings:APPLy[:IMMediate]

Applies the signal settings and outputs the signal.

See Chapter 13.14, "SOURce:LOSCillator subsystem", on page 196 for a description
of the setting process.

Usage: Event

Manual operation: See "Confirm External LO Settings" on page 103

[:SOURce]:FREQuency[:CW|FIXed] <Cw>

Sets the RF frequency at the RF output connector of the instrument.
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Parameters:
<Cw> float

Range: 1E+6  to  40E+9
Increment: 1E-3
*RST: 1E+9

Example: See Chapter 13.1.2, "Generating an I/Q Modulated Signal",
on page 165.

Manual operation: See "Frequency" on page 72

[:SOURce]:TRAits<ch>

Queries for a list of values for the corresponding trait. The following values values are
available for the channel number:

● 1: queries the upper edge frequencies for the frequency bands
● 2: queries the upconverter frequency multiplication factors for each band
● 3: queries if the bypass mode is active for each band
● 4: queries the pulsmodulation performed in LO for each band
● 5: queries the AM signal allowed for each band
● 6: queries the PM / PhiM signal allowed for each band

[:SOURce]:TRAits:COUNt?

Queries the number of trait lists.

Return values: 
<Count> float

Usage: Query only

13.13  SOURce:IQ subsystem

The IQ Impairment remote commands are available only for R&S SGU-B120V/-B140V.

[:SOURce]:IQ:STATe...................................................................................................... 194
[:SOURce]:IQ:IMPairment:IQRatio................................................................................... 195
[:SOURce]:IQ:IMPairment:LEAKage:I...............................................................................195
[:SOURce]:IQ:IMPairment:LEAKage:Q.............................................................................195
[:SOURce]:IQ:IMPairment:QUADrature[:ANGLe]...............................................................195
[:SOURce]:IQ:IMPairment:STATe.....................................................................................196
[:SOURce]:IQ:CREStfactor..............................................................................................196

[:SOURce]:IQ:STATe <State>

Switches the I/Q modulation on and off.
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Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: See Chapter 13.1.2, "Generating an I/Q Modulated Signal",
on page 165.

Manual operation: See "Mod State" on page 72

[:SOURce]:IQ:IMPairment:IQRatio <IqRatio>

Sets the ratio of I modulation to Q modulation (gain “imbalance”). The input may be
either in dB or %. An input in percent is rounded to the closest valid value in dB. A
query returns the value in dB.

Parameters:
<IqRatio> float

Range: -1  to  1
Increment: 1E-3
*RST: 0

Example: See Chapter 13.1.2, "Generating an I/Q Modulated Signal",
on page 165.

Manual operation: See "Gain Imbalance" on page 100

[:SOURce]:IQ:IMPairment:LEAKage:I <I>
[:SOURce]:IQ:IMPairment:LEAKage:Q <Q>
Sets the carrier leakage amplitude for the I-signal/ Q-signal component.

Parameters:
<Q> float

Range: -5  to  5
Increment: 0.01
*RST: 0
Default unit: PCT

Example: See Chapter 13.1.2, "Generating an I/Q Modulated Signal",
on page 165.

Manual operation: See "Offset" on page 100

[:SOURce]:IQ:IMPairment:QUADrature[:ANGLe] <Angle>

Sets the quadrature offset for the digital I/Q signal.
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Parameters:
<Angle> float

Range: -8  to  8
Increment: 0.01
*RST: 0
Default unit: DEG

Example: See Chapter 13.1.2, "Generating an I/Q Modulated Signal",
on page 165.

Manual operation: See "Quadrature Offset" on page 100

[:SOURce]:IQ:IMPairment:STATe <State>

Activates/deactivates the impairment or correction values LEAKage, QUADrature and
IQRatio for the baseband signal prior to input to the I/Q modulator.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: See Chapter 13.1.2, "Generating an I/Q Modulated Signal",
on page 165.

Manual operation: See "State" on page 99

[:SOURce]:IQ:CREStfactor <Crest>

Sets the crest factor of the I/Q modulation signal.

Parameters:
<Crest> float

Range: 0  to  35
Increment: 0.01
*RST: 0
Default unit: dB

Example: See Chapter 13.1.2, "Generating an I/Q Modulated Signal",
on page 165

Manual operation: See "Crest Factor" on page 98

13.14  SOURce:LOSCillator subsystem

R&S SGU as an extension to a compatible R&S signal generator

If a R&S SGU is connected to a compatible R&S signal generator the R&S SGU acts
as an extension to the signal generator extending its frequency range. In this setup a
controller does not need to access the R&S SGU directly. Instead, the signal generator
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acts as a controller to the R&S SGU and depending on the required output signal
parameters performs all required settings automatically.

For example, if the signal generator is set to an output frequency of 15 GHz it passes
this value on to the R&S SGU. During reception of the new frequency, the R&S SGU
blanks its output and computes the necessary settings for the local oscillator (signal
generator). Next, the signal generator queries R&S SGU for the required frequency
and level values of the local oscillator, which answers with, for example, 7.5 GHz and
-10 dBm. The signal generator applies these settings to its own oscillator hardware.
Also, it confirms that the required signal is now present at its output connector by send-
ing the apply command to the R&S SGU. The R&S SGU unblanks its own output thus
finishing the cycle.

R&S SGU as an upconverter for any signal generator

If the R&S SGU is connected to an incompatible signal generator, the controller has to
perform the above steps instead of the signal generator. We assume that a remote PC
(controller) is connected to both the R&S SGU and the signal generator (local oscilla-
tor). When changing any parameters which affect the output signal of the combined
system of local oscillator and R&S SGU the controller has to follow these steps:

Setting the signal of the R&S SGU

1. Set the parameters of the R&S SGU like frequency and level as needed.

2. Query the local oscillator frequency and the local oscillator level from R&S SGU
with the SCPI commands [:SOURce]:LOSCillator:FREQuency? and [:
SOURce]:LOSCillator:POWer?.

3. Interpret the result.

4. Apply the required changes to the LO.

5. Send the SCPI command [:SOURce]:SETTings:APPLy[:IMMediate] to
R&S SGU to output the signal.

See Chapter 13.1.3, "Advanced Task for Optimizing Performance", on page 166 for an
example.

[:SOURce]:LOSCillator:FREQuency?...............................................................................197
[:SOURce]:LOSCillator:POWer?...................................................................................... 198

[:SOURce]:LOSCillator:FREQuency?

Queries the frequency of the local oscillator input signal.

See Chapter 13.14, "SOURce:LOSCillator subsystem", on page 196 for a description
of the setting process.
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Return values: 
<Frequency> float

Range: 1E+6  to  20E+9
Increment: 1E-3
*RST: 1E+9

Usage: Query only

Manual operation: See "Frequency" on page 103

[:SOURce]:LOSCillator:POWer?

Queries the level of the local oscillator input signal.

See Chapter 13.14, "SOURce:LOSCillator subsystem", on page 196 for a description
of the setting process.

Return values: 
<Amplitude> float

Range: -120  to  25
Increment: 0.01
*RST: -10

Usage: Query only

Manual operation: See "Level" on page 103

13.15  SOURce:POWer subsystem

[:SOURce]:POWer:ALC[:STATe]...................................................................................... 198
[:SOURce]:POWer:ALC:DSENsitivity............................................................................... 199
[:SOURce]:POWer:ALC:SONCe...................................................................................... 199
[:SOURce]:POWer:ATTenuation:RFOFf:MODE................................................................. 199
[:SOURce]:POWer:ATTenuation:SOVer[:OFFSet]..............................................................199
[:SOURce]:POWer:LMODe............................................................................................. 200
[:SOURce]:POWer:SCHaracteristic..................................................................................200
[:SOURce]:POWer[:LEVel][:IMMediate][:AMPLitude]..........................................................200
[:SOURce]:POWer[:LEVel][:IMMediate]:OFFSet................................................................ 201
[:SOURce]:POWer:LIMit[:AMPLitude]...............................................................................201
[:SOURce]:POWer:PEP?................................................................................................ 201
[:SOURce]:POWer:POWer..............................................................................................202
[:SOURce]:POWer:RANGe:LOWer?................................................................................ 202
[:SOURce]:POWer:RANGe:UPPer?................................................................................. 202

[:SOURce]:POWer:ALC[:STATe] <State>

Activates/deactivates the automatic level control.
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Parameters:
<State> 1 | OFFTable | ONTable | ON

*RST: ONTable

Manual operation: See "State" on page 95

[:SOURce]:POWer:ALC:DSENsitivity <Sensitivity>

Sets the sensitivity of the power detector.

Parameters:
<Sensitivity> OFF | LOW | MED | HIGH

*RST: OFF

[:SOURce]:POWer:ALC:SONCe

Briefly activates automatic level control for correction purposes.

Usage: Event

Manual operation: See "Readjust" on page 92

[:SOURce]:POWer:ATTenuation:RFOFf:MODE <Mode>

Selects the state which the attenuator assumes when the instrument is switched on.

Parameters:
<Mode> MAX | FIXed

MAX
Sets attenuation to maximum when the RF signal is switched off.
This setting is recommended for applications that require a high
level of noise suppression.
FIXed
Retains the current setting and keeps the output impedance
constant during RF off.
*RST: MAX

Manual operation: See "RF-Off-Mode" on page 94

[:SOURce]:POWer:ATTenuation:SOVer[:OFFSet] <Offset>

Sets the switch-over offset value of the attenuator.

Parameters:
<Offset> float

*RST: 0

Manual operation: See "SATT Switch-Over Offset" on page 94

SOURce:POWer subsystem



Remote control commandsR&S®SGU100A

200User Manual 1176.7726.02 ─ 10

[:SOURce]:POWer:LMODe <LevMode>

Selects the level mode.

Parameters:
<LevMode> NORMal | LNOise | LDIStortion

NORMal
automatic selection of the best settings
LNOISe
settings for lowest noise
LDIStortion
settings for lowest distortions
*RST: n.a. (factory preset: NORMal)

Example: see Chapter 13.1.3, "Advanced Task for Optimizing Perfor-
mance", on page 166

Manual operation: See "Mode" on page 91

[:SOURce]:POWer:SCHaracteristic <Characteristic>

Selects the characteristic for the level setting.

Parameters:
<Characteristic> AUTO | UNINterrupted | CVSWr | USER | MONotone

UNINterrupted: Uninterrupted Level setting, CVSWr: Con-
stant-VSWR, MONotone: Strictly Monotone
*RST: AUTO

Example: see Chapter 13.1.3, "Advanced Task for Optimizing Perfor-
mance", on page 166

Manual operation: See "Setting Characteristic" on page 91

[:SOURce]:POWer[:LEVel][:IMMediate][:AMPLitude] <Amplitude>

Sets the RF level at the RF output connector of the instrument.

Parameters:
<Amplitude> float

Range: -120  to  25
Increment: 0.01
*RST: -10

Example: See Chapter 13.1.3, "Advanced Task for Optimizing Perfor-
mance", on page 166.

Manual operation: See "Level/Level Offset" on page 72
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[:SOURce]:POWer[:LEVel][:IMMediate]:OFFSet <Offset>

Specifies the constant level offset of a downstream attenuator/amplifier. If a level offset
is entered, the level entered with [:SOURce]:POWer:POWer no longer corresponds
to the RF output level.

The following correlation applies:

:POWer = RF output level + POWer:OFFSet.

Entering a level offset does not change the RF output level, but rather the query value
of :POWer.

Only dB is permitted as the unit here. The linear units (V, W, etc.) are not permitted.

Parameters:
<Offset> float

Range: -100  to  100
Increment: 0.1
*RST: 0

Manual operation: See "Offset" on page 91

[:SOURce]:POWer:LIMit[:AMPLitude] <Amplitude>

Sets the upper limit of the RF signal power.

The value is not affected by an instrument preset and *RST function. This parameter is
influenced only by the factory preset (SYST:FPR) and its factory value is equal to the
upper limit.

Parameters:
<Amplitude> float

Range: -300  to  30
Increment: 0.01
*RST: 30
Default unit: dBm

Manual operation: See "Limit" on page 92

[:SOURce]:POWer:PEP?

Queries the RF signal's peak envelope power at the DUT.

Return values: 
<PEP> float

Range: -120  to  25
Increment: 0.01
*RST: -10

Example: see Chapter 13.1.3, "Advanced Task for Optimizing Perfor-
mance", on page 166

Usage: Query only

SOURce:POWer subsystem



Remote control commandsR&S®SGU100A

202User Manual 1176.7726.02 ─ 10

Manual operation: See "PEP" on page 72

[:SOURce]:POWer:POWer <Power>

Sets the level at the RF output connector.

This value does not consider a specified offset. The command [:SOURce]:POWer[:
LEVel][:IMMediate]:OFFSet sets the level of the "Level" display, that means the
level containing offset.

Parameters:
<Power> float

Range: -120  to  25
Increment: 0.01
*RST: -10

Example: POW:POW 15
sets the RF level at output to 15 dBm.

Manual operation: See "Level/Level Offset" on page 72

[:SOURce]:POWer:RANGe:LOWer?
[:SOURce]:POWer:RANGe:UPPer?
Queries the minimum/maximum level range in the current level mode

Return values: 
<Upper> float

Range: -300  to  30
Increment: 0.01
*RST: 30

Usage: Query only

Manual operation: See "Level Range" on page 92

13.16  SOURce:PULM subsystem

[:SOURce<hw>]:PULM:STATe.........................................................................................202
[:SOURce<hw>]:PULM:POLarity..................................................................................... 203

[:SOURce<hw>]:PULM:STATe <State>

Activates the pulse modulation.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: PULM:STAT ON
activates pulse modulation.
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Manual operation: See "State" on page 101

[:SOURce<hw>]:PULM:POLarity <Polarity>

Sets the polarity of the pulse modulator signal. This command is effective only for an
external modulation signal.

Parameters:
<Polarity> NORMal | INVerted

NORMal
The RF signal is suppressed during the pulse pause.
INVerted
The RF signal is suppressed during the pulse.
*RST: NORMal

Example: PULM:POL INV
selects inverted polarity.

Manual operation: See "Polarity" on page 101

13.17  STATus subsystem

This system contains the commands for the status reporting system. See also Chap-
ter 12.5, "Status reporting system", on page 147 for detailed information.

*RST on page 172 has no effect on the status registers.

Value ranges

● Queries return the current value of the respective register, which permits a check of
the device status.
Return values: A decimal value in the range 0 to 32767 (=215-1)

● The configuration commands set the respective register thus determining which
status changes of the R&S SGU cause the status registers to be changed.
Setting values: A decimal value in the range 0 to 32767 (=215-1)

:STATus:OPERation:CONDition?.....................................................................................204
:STATus:OPERation:ENABle...........................................................................................204
:STATus:OPERation[:EVENt]...........................................................................................204
:STATus:OPERation:NTRansition.................................................................................... 204
:STATus:OPERation:PTRansition.....................................................................................205
:STATus:PRESet............................................................................................................205
:STATus:QUEStionable:CONDition.................................................................................. 205
:STATus:QUEStionable:ENABle.......................................................................................205
:STATus:QUEStionable[:EVENt]...................................................................................... 206
:STATus:QUEStionable:NTRansition................................................................................ 206
:STATus:QUEStionable:PTRansition................................................................................ 206
:STATus:QUEue[:NEXT]?................................................................................................206
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:STATus:OPERation:CONDition?

Quieries the content of the CONDition part of the STATus:OPERation register.

This part contains information on the action currently being performed in the instru-
ment. The content is not deleted after being read out because it indicates the current
hardware status.

Return values: 
<Condition> string

Example: :STATus:OPERation:CONDition?

Usage: Query only

:STATus:OPERation:ENABle <Enable>

Sets the bits of the ENABle part of the STATus:OPERation register. This setting deter-
mines which events of the Status-Event part are forwarded to the sum bit in the status
byte. These events can be used for a service request.

Parameters:
<Enable> string

Example: :STAT:OPER:ENAB 32767
all events are forwarded to the sum bit of the status byte.

:STATus:OPERation[:EVENt] <Event>

Queries the content of the EVENt part of the STATus:OPERation register. This part
contains information on the actions performed in the instrument since the last readout.
The content of the EVENt part is deleted after being read out.

Parameters:
<Event> string

Example: :STAT:OPER:EVEN?
queries the STATus:OPERation:EVENt register.

:STATus:OPERation:NTRansition <Ntransition>

Sets the bits of the NTRansition part of the STATus:OPERation register. If a bit is set, a
transition from 1 to 0 in the condition part causes an entry to be made in the EVENt
part of the register. The disappearance of an event in the hardware is thus registered,
for example the end of an adjustment.

Parameters:
<Ntransition> string

Example: :STAT:OPER:NTR 0
a transition from 1 to 0 in the condition part of the Status:Opera-
tion register does not cause an entry to be made in the EVENt
part.
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:STATus:OPERation:PTRansition <Ptransition>

Sets the bits of the PTRansition part of the STATus:OPERation register. If a bit is set, a
transition from 0 to 1 in the condition part causes an entry to be made in the EVENt
part of the register. A new event in the hardware is thus registered, for example the
start of an adjustment.

Parameters:
<Ptransition> string

Example: :STAT:OPER:PTR 32767
all transitions from 0 to 1 in the condition part of the Status:Oper-
ation register cause an entry to be made in the EVENt part.

:STATus:PRESet <Preset>

Resets the status registers. All PTRansition parts are set to FFFFh (32767), i.e. all
transitions from 0 to 1 are detected. All NTRansition parts are set to 0, i.e. a transition
from 1 to 0 in a CONDition bit is not detected. The ENABle parts of STATus:OPERation
and STATus:QUEStionable are set to 0, i.e. all events in these registers are not passed
on.

Parameters:
<Preset> string

Example: STAT:PRES
resets the status registers.

:STATus:QUEStionable:CONDition <Condition>

Queries the content of the CONDition part of the STATus:QUEStionable register. This
part contains information on the action currently being performed in the instrument.
The content is not deleted after being read out since it indicates the current hardware
status.

Parameters:
<Condition> string

Example: :STATus:QUEStionable:CONDition?
queries the Status:Questionable:Condition register.

:STATus:QUEStionable:ENABle <Enable>

Sets the bits of the ENABle part of the STATus:QUEStionable register. The enable part
determines which events of the STATus:EVENt part are enabled for the summary bit in
the status byte. These events can be used for a service request.

If a bit in the ENABle part is 1, and the correesponding EVENt bit is true, a positive
transition occurs in the summary bit. This transition is reportet to the next higher level.

Parameters:
<Enable> string
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Example: STAT:QUES:ENAB 1
Problems when performing an adjustment cause an entry to be
made in the sum bit.

:STATus:QUEStionable[:EVENt] <Event>

Queries the content of the EVENt part of the STATus:QUEStionable register. This
part contains information on the actions performed in the instrument since the last
readout. The content of the EVENt part is deleted after being read out.

Parameters:
<Event> string

Example: STAT:QUES:EVEN?
queries the Status:Questionable:Event register.

:STATus:QUEStionable:NTRansition <Ntransition>

Sets the bits of the NTRansition part of the STATus:QUEStionable register. If a bit is
set, a transition from 1 to 0 in the condition part causes an entry to be made in the
EVENt part of the register.

Parameters:
<Ntransition> string

Example: STAT:QUES:NTR 0
a transition from 1 to 0 in the condition part of the STA-
Tus:QUEStionable register does not cause an entry to be made
in the EVENt part

:STATus:QUEStionable:PTRansition <PTransition>

Sets the bits of the NTRansition part of the STATus:QUEStionable register. If a bit is
set, a transition from 1 to 0 in the condition part causes an entry to be made in the
EVENt part of the register.

Parameters:
<PTransition> string

Example: STAT:QUES:PTR 32767
all transitions from 0 to 1 in the condition part of the STA-
Tus:QUEStionable register cause an entry to be made in the
EVENt part

:STATus:QUEue[:NEXT]?

Queries the oldest entry in the error queue and then deletes it. Positive error numbers
denote device-specific errors, and negative error numbers denote error messages
defined by SCPI. If the error queue is empty, 0 ("No error") is returned.

The command is identical to :SYSTem:ERRor[:NEXT]? on page 210.

STATus subsystem



Remote control commandsR&S®SGU100A

207User Manual 1176.7726.02 ─ 10

Return values: 
<Next> string

Example: :STATus:QUEue?
queries the oldest entry in the error queue.
Response: 0, 'no error'
no errors have occurred since the error queue was last read out

Usage: Query only

13.18  SYSTem subsystem

The SYSTem subsystem contains a series of commands for general functions which do
not directly affect signal generation.

:SYSTem:EMODe.......................................................................................................... 208
:SYSTem:ERRor:ALL?....................................................................................................208
:SYSTem:ERRor:CODE:ALL?......................................................................................... 208
:SYSTem:ERRor:CODE[:NEXT]?.....................................................................................209
:SYSTem:ERRor:COUNt?...............................................................................................209
:SYSTem:ERRor[:NEXT]?...............................................................................................210
:SYSTem:SERRor?........................................................................................................ 210
:SYSTem:STANdby:STATe?............................................................................................ 210
:SYSTem:VERSion?....................................................................................................... 211
:SYSTem:COMMunicate:NETWork:IPADdress.................................................................. 211
:SYSTem:COMMunicate:NETWork:IPADdress:MODE........................................................211
:SYSTem:COMMunicate:NETWork:MACaddress...............................................................211
:SYSTem:COMMunicate:NETWork:RESTart..................................................................... 212
:SYSTem:COMMunicate:NETWork:STATus?.................................................................... 212
:SYSTem:COMMunicate:NETWork[:COMMon]:HOSTname................................................212
:SYSTem:COMMunicate:NETWork[:IPADdress]:GATeway..................................................212
:SYSTem:COMMunicate:NETWork[:IPADdress]:SUBNet:MASK..........................................213
:SYSTem:COMMunicate:NETWork:RESource?.................................................................213
:SYSTem:COMMunicate:HISLip:RESource?..................................................................... 213
:SYSTem:COMMunicate:PCIexpress:RESource?.............................................................. 213
:SYSTem:COMMunicate:SOCKet:PORT...........................................................................214
:SYSTem:COMMunicate:SOCKet:RESource?...................................................................214
:SYSTem:COMMunicate:SERial:RESource?.....................................................................214
:SYSTem:COMMunicate:SERial:BAUD............................................................................ 214
:SYSTem:COMMunicate:SERial:PARity............................................................................215
:SYSTem:COMMunicate:SERial:SBITs.............................................................................215
:SYSTem:COMMunicate:USB:RESource?........................................................................ 215
:SYSTem:HARDware:ASSembly<dir>:SNUMber?............................................................. 215
:SYSTem:MMEMory:PATH:USER?.................................................................................. 216
:SYSTem:NINFormation?................................................................................................216
:SYSTem:OSYStem?......................................................................................................216
:SYSTem:REBoot...........................................................................................................216
:SYSTem:RESTart..........................................................................................................216
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:SYSTem:SHUTdown..................................................................................................... 217
:SYSTem:PROTect<ch>[:STATe]......................................................................................217
:SYSTem:STARtup:COMPlete?....................................................................................... 217

:SYSTem:EMODe <Mode>

Enables and selects the eco mode.

Parameters:
<Mode> OFF | EM1

*RST: OFF

Example: See Chapter 13.1.1, "Performing General Tasks for Instrument
Setup", on page 163.

:SYSTem:ERRor:ALL?

Queries the error/event queue for all unread items and removes them from the queue.

Return values: 
<All> string

Error/event_number,"Error/event_description>[;Device-depend-
ent info]"
A comma separated list of error number and a short description
of the error in FIFO order.
If the queue is empty, the response is 0,"No error"
Positive error numbers are instrument-dependent. Negative
error numbers are reserved by the SCPI standard.
Volatile errors are reported once, at the time they appear. Identi-
cal errors are reported repeatedly only if the original error has
already been retrieved from (and hence not any more present in)
the error queue.

Example: SYST:ERR:ALL?
Queries all entries in the error queue.
Response: 0, 'no error'
No errors have occurred since the error queue was last read out.

Usage: Query only

:SYSTem:ERRor:CODE:ALL?

Queries the error numbers of all entries in the error queue and then deletes them.

Return values: 
<All> string

Returns the error numbers. To retrieve the entire error text, send
the command :SYSTem:ERRor:ALL?.
0
"No error", i.e. the error queue is empty
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Positive value
Positive error numbers denote device-specific errors
Negative value
Negative error numbers denote error messages defined by
SCPI.

Example: SYST:ERR:CODE:ALL
Queries all entries in the error queue.
Response: 0
No errors have occurred since the error queue was last read out.

Usage: Query only

:SYSTem:ERRor:CODE[:NEXT]?

Queries the error number of the oldest entry in the error queue and then deletes it.

Return values: 
<Next> string

Returns the error number. To retrieve the entire error text, send
the command :SYSTem:ERRor:ALL?.
0
"No error", i.e. the error queue is empty
Positive value
Positive error numbers denote device-specific errors
Negative value
Negative error numbers denote error messages defined by
SCPI.

Example: SYST:ERR:CODE
Queries the oldest entry in the error queue.
Response: 0
No errors have occurred since the error queue was last read out.

Usage: Query only

:SYSTem:ERRor:COUNt?

Queries the number of entries in the error queue.

Return values: 
<Count> integer

0
The error queue is empty.

Example: SYST:ERR:COUN
Queries the number of entries in the error queue.
Response: 1
One error has occurred since the error queue was last read out.

Usage: Query only
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:SYSTem:ERRor[:NEXT]?

Queries the error/event queue for the oldest item and removes it from the queue.

Return values: 
<Next> string

Error/event_number,"Error/event_description>[;Device-depend-
ent info]"
Error number and a short description of the error.
If the queue is empty, the response is 0,"No error"
Positive error numbers are instrument-dependent. Negative
error numbers are reserved by the SCPI standard.
Volatile errors are reported once, at the time they appear. Identi-
cal errors are reported repeatedly only if the original error has
already been retrieved from (and hence not any more present in)
the error queue.

Example: SYST:ERR?
Queries the oldest entry in the error queue.
Response: 0, 'no error'
No errors have occurred since the error queue was last read out.

Usage: Query only

:SYSTem:SERRor?

Returns a list of all errors existing at the time when the query is started. This list corre-
sponds to the display on the info page under manual control.

Return values: 
<Serror> string

Example: SYST:SERR
queries all errors existing in the error queue.

Example: Response: -221, 'Settings conflict', 153,
'Input voltage out of range'
The two returned errors have occurred since the error queue
was last queried.

Usage: Query only

:SYSTem:STANdby:STATe?

Queries the standby state of the R&S SGU.

Suffix: 
<dir>

.
1..2

Return values: 
<State> 1 | ON | 0 | OFF

0|OFF
The R&S SGU is in ready state, standby is not active.
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1|ON
The R&S SGU is in standby state, the ready state is not active.
*RST: 0

Usage: Query only

:SYSTem:VERSion?

Queries the SCPI version the instrument's command set complies with.

Return values: 
<Version> string

Example: SYST:VERS
queries the SCPI version.
Response: "1996"
The instrument complies with the SCPI version from 1996.

Usage: Query only

:SYSTem:COMMunicate:NETWork:IPADdress <IpAddress>

Sets the IP address.

Parameters:
<IpAddress> string

Range: 0.0.0.0.  to  ff.ff.ff.ff

Example: SYSTem:COMMunicate:NETWork:IPADdress "7.8.9.10"
sets the IP address of the instrument.

Manual operation: See "IP Address" on page 115

:SYSTem:COMMunicate:NETWork:IPADdress:MODE <Mode>

Selects manual or automatic setting of the IP address.

Parameters:
<Mode> AUTO | STATic

*RST: n.a. (factory preset: AUTO)

Example: SYSTem:COMMunicate:NETWork:IPADdress:MODE AUTO
The IP address is assigned automatically (DHCP)

Manual operation: See "Address Mode" on page 115

:SYSTem:COMMunicate:NETWork:MACaddress <MacAddress>

Queries the MAC address of the network adapter.

Parameters:
<MacAddress> string
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Example: SYST:COMM:NETW:MAC
queries the MAC address.

:SYSTem:COMMunicate:NETWork:RESTart

Restarts the network connection to the instrument, terminates the connection and sets
it up again.

Example: SYSTem:COMMunicate:NETWork:RESTart
Usage: Event

:SYSTem:COMMunicate:NETWork:STATus?

Queries the network configuration state.

Return values: 
<State> 0 | 1 | OFF | ON

Usage: Query only

:SYSTem:COMMunicate:NETWork[:COMMon]:HOSTname <Hostname>

Sets the individual host name of the R&S SGU.

Note: it is recommended that you do not change the host name in order to avoid prob-
lems with the networdk connection. However, if you change the host name be sure to
use an unique name.

The host name is a protected parameter, To change it, first disable protection level 1
with command :SYSTem:PROTect<ch>[:STATe] on page 217.

Parameters:
<Hostname> string

Example: SYSTem:PROTect1:STATe OFF,123456
SYSTem:COMMunicate:NETWork:HOSTname 'SIGGEN'
sets the individual computer name of the R&S SGU.

Manual operation: See "Hostname" on page 114

:SYSTem:COMMunicate:NETWork[:IPADdress]:GATeway <Gateway>

Sets the IP address of the default gateway.

Parameters:
<Gateway> string

Range: 0.0.0.0  to  ff.ff.ff.ff

Example: SYSTem:COMMunicate:NETWork:IPADdress:GATeway
'1.2.3.4'
sets the IP address of the default gateway.

Manual operation: See "Default Gateway" on page 116
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:SYSTem:COMMunicate:NETWork[:IPADdress]:SUBNet:MASK <Mask>

Sets the subnet mask.

Parameters:
<Mask> string

Example: SYSTem:COMMunicate:NETWork:IPADdress:SUBNet:
MASK '255.255.0.0'
determines the subnet mask.

Manual operation: See "Subnet Mask" on page 115

:SYSTem:COMMunicate:NETWork:RESource?

Queries the VISA resource string, used for remote control of the instrument with VXI-11
protocol.

Return values: 
<Resource> string

Example: SYSTem:COMMunicate:NETWork:RESource?
Response: "TCPIP::192.1.2.3::INSTR"

Usage: Query only

Manual operation: See "Visa Resource Strings" on page 116

:SYSTem:COMMunicate:HISLip:RESource?

Queries the VISA resource string, used for remote control of the instrument with
HiSLIP protocol.

Return values: 
<Resource> string

Example: SYSTem:COMMunicate:HISLip:RESource?
Response: "TCPIP::192.1.2.3::hislip0::INSTR"

Usage: Query only

Manual operation: See "Visa Resource Strings" on page 116

:SYSTem:COMMunicate:PCIexpress:RESource?

Queries the visa resource string for remote control via the PCIe interface.

Return values: 
<Resource> string

Usage: Query only

Manual operation: See "Visa Resource Strings" on page 116
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:SYSTem:COMMunicate:SOCKet:PORT <ScpiEthPort>

Sets the port number for remote control via socket communication.

Parameters:
<ScpiEthPort> integer

Range: 1000  to  65535
*RST: n.a. (factory preset: 5025)

Example: SYSTem:COMMunicate:SOCKet:PORT 5030
// specifies the socket port number.

Manual operation: See "SCPI Port" on page 67

:SYSTem:COMMunicate:SOCKet:RESource?

Queries the VISA resource string for remote control via LAN interface, using TCP/IP
socket protocol.

Return values: 
<Resource> string

Example: SYSTem:COMMunicate:SOCKet:RESource?
Response: "TCPIP::10.113.1.150::5025::SOCKET"

Usage: Query only

Manual operation: See "Visa Resource Strings" on page 116

:SYSTem:COMMunicate:SERial:RESource?

Queries the VISA resource string for the serial remote control interface. This string is
used for remote control of the instrument.

Return values: 
<Resource> string

Example: SYSTem:COMMunicate:SERial:RESource?
queries the VISA resource string.
Response: "ASRL1::INSTR"

Usage: Query only

:SYSTem:COMMunicate:SERial:BAUD <Baud>

Sets the baudrate for the serial remote control interface.

Parameters:
<Baud> 2400 | 4800 | 9600 | 19200 | 38400 | 57600 | 115200

*RST: n.a. (factory preset: 115200)

Example: SYSTem:COMMunicate:SERial:BAUD 115200
Sets 115200 baudrate.
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:SYSTem:COMMunicate:SERial:PARity <Parity>

Sets the parity for the serial remote control interface.

Parameters:
<Parity> NONE | ODD | EVEN

*RST: n.a. (factory preset: NONE)

Example: SYST:COMM:SER:PAR NONE
Selects parity NONE.

:SYSTem:COMMunicate:SERial:SBITs <SBits>

Sets the number of stop bits for the serial remote control interface.

Parameters:
<SBits> 1 | 2

*RST: n.a. (factory preset: 1)

Example: SYST:COMM:SER:SBIT 2
Selects 2 stop bits.

:SYSTem:COMMunicate:USB:RESource?

Queries the VISA resource string for remote control via the USB interface.

Return values: 
<Resource> string

Example: SYSTem:COMMunicate:USB:RESource?
queries the VISA resource string for remote control via the USB
interface.
Response: "USB::72::000000::INSTR"

Usage: Query only

Manual operation: See "Visa Resource Strings" on page 116

:SYSTem:HARDware:ASSembly<dir>:SNUMber?

Queries the list of hardware module serial numbers.

Suffix: 
<dir>

.
1 | 2
Defines the section: 1 = common assembly, 2 = RF assembly.

Return values: 
<SNumber> string

Example: SYSTem:HARDware:ASSembly1:SNUMber?

Usage: Query only

Manual operation: See " Assembly" on page 106
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:SYSTem:MMEMory:PATH:USER?

Queries the user directory, that means the directory the instrument stores user files on.

Return values: 
<PathUser> string

Example: SYSTem:MMEMory:PATH:USER?
Response: "/var/user/"'

Usage: Query only

:SYSTem:NINFormation?

Queries the oldest information message ("Error History > Level > Info") in the error/
event queue.

Return values: 
<NextInfo> string

Example: :SYSTem:NINFormation?
Queries the oldest entry in the info message queue.
Response: 90,"Info;=== Instrument startup...
==="
Information message containing error number 90, that states,
that the instrument startup is complete.

Usage: Query only

:SYSTem:OSYStem?

Queries the operating system of the instrument.

Return values: 
<OperSystem> string

Example: SYSTem:OSYStem?
Response: "Linux"

Usage: Query only

:SYSTem:REBoot

Restarts the firmware and the operating system.

Usage: Event

:SYSTem:RESTart

Restarts the firmware. The operating system remains active.

Usage: Event
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:SYSTem:SHUTdown

Shuts down the instrument.

Usage: Event

:SYSTem:PROTect<ch>[:STATe] <State>[, <Key>]

Activates and deactivates the specified protection level.

Suffix: 
<ch>

.
Indicates the protection level.

Parameters:
<State> select

*RST: n.a. (factory preset: 1)

Setting parameters: 
<Key> integer

The respective functions are disabled when the protection level
is activated. No password is required for activation of a level. A
password must be entered to deactivate the protection level.
The password for the first level is 123456.

Example: // to activate protection level
SYSTem:PROTect1:STATe 1
// internal adjustments or hostname cannot be changed
// to unlock protection level 1
SYSTem:PROTect1:STATe 0,123456
// internal adjustments are accessible

:SYSTem:STARtup:COMPlete?

Queries if the startup of the instrument is completed.

Return values: 
<Complete> 0 | 1 | OFF | ON

*RST: 0

Example: SYST:STAR:COMP?
// 1
// the startup of the instrument is completed

Usage: Query only

13.19  TEST subsystem

The TEST system contains the commands for performing the routines. R&S SGU can-
not perform the selftest on its own. Therefore a connection with a signal generator is
needed. If you use a compatible R&S signal generator, then the calibration process will
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be completed automatically after starting the calibration process. Otherwise you have
to follow the steps described in "Calibration process of the R&S SGU" on page 176. In
the given example, replace the :CALibration:xxx:STARt SCPI command
with :TEST:ALL:STARt and :CALibration:xxx:RESult
with :TEST:ALL:RESult. We assume that a remote PC is connected to the instru-
ments, the remote PC and the instruments are switched on and a connection between
them is established.

The self tests returns a "0" if the test is performed successfully, otherwise a value other
than "0" is returned. None of the commands of this system has a *RST value.

Improper use can destroy the assembly
The respective hardware assembly responds directly to the :TEST:DIRect command;
any safety mechanisms are bypassed. The command is intended for servicing purpo-
ses and should be used only by the Rohde & Schwarz service personnel.

:TEST:ALL:STARt...........................................................................................................218
:TEST:ALL:RESult?........................................................................................................218
:TEST:KEYBoard[:STATe]............................................................................................... 218

:TEST:ALL:STARt

Starts a selftest. Use the command :TEST:ALL:RESult? to query the result.

Use :CALibration:HREQuest? to query for settings required by the instrument.

Usage: Event

:TEST:ALL:RESult?

Queries the result of the performed selftest. Start the selftest with :TEST:ALL:STARt.

Return values: 
<Result> 0 | 1 | RUNning | STOPped

*RST: STOPped

Example: See Chapter 13.1.1, "Performing General Tasks for Instrument
Setup", on page 163.

Usage: Query only

:TEST:KEYBoard[:STATe] <State>

Enables/disables the keyboard and the LED test state.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: OFF
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13.20  UNIT subsystem

The UNIT subsystem contains the commands specifying which units are valid if no unit
is indicated in a command. These settings are valid for the entire instrument.

:UNIT:ANGLe <Angle>

Sets the default angle unit for remote control. Does not influence the manual control
parameter units and the display.

Parameters:
<Angle> DEGRee | RADian

*RST: RADian

Example: UNIT:ANGL DEG
sets DEG as a default unit for all commands which determine
angle values.

:UNIT:POWer <Power>

Defines the default unit for power parameters. This setting affects the GUI, as well as
all remote control commands that determine power values.

Parameters:
<Power> V | DBUV | DBM

*RST: DBM

Example: UNIT:POW V
sets V as a default unit for all commands which determine power
values.

13.21  List of R&S SGU commands
:CALibration:HREQuest?...............................................................................................................................177
:CALibration:IQModulator:LOCal:RESult?.....................................................................................................179
:CALibration:IQModulator:LOCal:STARt........................................................................................................179
:CALibration:IQModulator:RESult?................................................................................................................ 178
:CALibration:IQModulator:STARt...................................................................................................................178
:CALibration:IQModulator:TEMPerature?......................................................................................................178
:CALibration:LEVel:RESult?...........................................................................................................................179
:CALibration:LEVel:STARt............................................................................................................................. 179
:CALibration:LEVel:TEMPerature?................................................................................................................ 179
:CONNector:TRIGger:OMODe...................................................................................................................... 180
:DIAGnostic:POINt:CATalog?.........................................................................................................................180
:DIAGnostic[:MEASure]:POINt?.....................................................................................................................180
:FFASt............................................................................................................................................................181
:FORMat:BORDer..........................................................................................................................................182
:FORMat:SREGister...................................................................................................................................... 182
:FORMat[:DATA]............................................................................................................................................ 182

List of R&S SGU commands



Remote control commandsR&S®SGU100A

220User Manual 1176.7726.02 ─ 10

:LOCK?.......................................................................................................................................................... 173
:MEMory:HFRee?.......................................................................................................................................... 189
:MMEMory:CATalog:LENGth?....................................................................................................................... 186
:MMEMory:CATalog?..................................................................................................................................... 186
:MMEMory:CDIRectory..................................................................................................................................187
:MMEMory:COPY.......................................................................................................................................... 187
:MMEMory:DATA........................................................................................................................................... 188
:MMEMory:DCATalog:LENGth?.....................................................................................................................189
:MMEMory:DCATalog?...................................................................................................................................188
:MMEMory:DELete.........................................................................................................................................189
:MMEMory:LOAD:STATe............................................................................................................................... 189
:MMEMory:MDIRectory..................................................................................................................................190
:MMEMory:MOVE..........................................................................................................................................190
:MMEMory:MSIS............................................................................................................................................190
:MMEMory:RDIRectory..................................................................................................................................191
:MMEMory:STORe:STATe............................................................................................................................. 191
:OUTPut:AFIXed:RANGe:LOWer?................................................................................................................ 192
:OUTPut:AFIXed:RANGe:UPPer?.................................................................................................................193
:OUTPut:AMODe........................................................................................................................................... 191
:OUTPut[:STATe]............................................................................................................................................192
:OUTPut[:STATe]:PON...................................................................................................................................192
:OUTPut<hw>:PROTection:CLEar.................................................................................................................193
:PFASt............................................................................................................................................................181
:REMote:OPMode..........................................................................................................................................173
:SOURce<hw>:PRESet................................................................................................................................. 174
:STATus:OPERation:CONDition?.................................................................................................................. 204
:STATus:OPERation:ENABle.........................................................................................................................204
:STATus:OPERation:NTRansition..................................................................................................................204
:STATus:OPERation:PTRansition..................................................................................................................205
:STATus:OPERation[:EVENt].........................................................................................................................204
:STATus:PRESet............................................................................................................................................205
:STATus:QUEStionable:CONDition................................................................................................................205
:STATus:QUEStionable:ENABle.................................................................................................................... 205
:STATus:QUEStionable:NTRansition.............................................................................................................206
:STATus:QUEStionable:PTRansition............................................................................................................. 206
:STATus:QUEStionable[:EVENt]....................................................................................................................206
:STATus:QUEue[:NEXT]?.............................................................................................................................. 206
:SYSTem:COMMunicate:HISLip:RESource?.................................................................................................213
:SYSTem:COMMunicate:NETWork:IPADdress..............................................................................................211
:SYSTem:COMMunicate:NETWork:IPADdress:MODE..................................................................................211
:SYSTem:COMMunicate:NETWork:MACaddress..........................................................................................211
:SYSTem:COMMunicate:NETWork:RESource?............................................................................................213
:SYSTem:COMMunicate:NETWork:RESTart.................................................................................................212
:SYSTem:COMMunicate:NETWork:STATus?................................................................................................ 212
:SYSTem:COMMunicate:NETWork[:COMMon]:HOSTname......................................................................... 212
:SYSTem:COMMunicate:NETWork[:IPADdress]:GATeway........................................................................... 212
:SYSTem:COMMunicate:NETWork[:IPADdress]:SUBNet:MASK.................................................................. 213
:SYSTem:COMMunicate:PCIexpress:RESource?.........................................................................................213
:SYSTem:COMMunicate:SERial:BAUD.........................................................................................................214
:SYSTem:COMMunicate:SERial:PARity........................................................................................................ 215
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:SYSTem:COMMunicate:SERial:RESource?.................................................................................................214
:SYSTem:COMMunicate:SERial:SBITs..........................................................................................................215
:SYSTem:COMMunicate:SOCKet:PORT.......................................................................................................214
:SYSTem:COMMunicate:SOCKet:RESource?.............................................................................................. 214
:SYSTem:COMMunicate:USB:RESource?.................................................................................................... 215
:SYSTem:EMODe.......................................................................................................................................... 208
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14  Error messages and troubleshooting
This chapter describes the error messages of the R&S SGU. The error messages are
output in the "Info" line on the screen and entered in the error/event queue of the sta-
tus reporting system.

A great variety of different messages such as status messages, error messages, warn-
ings or information are displayed in the header field of the screen. Some error mes-
sages require that the error must be eliminated before correct instrument operation can
be ensured. The "Info" window with a list of current messages and a detailed descrip-
tion of each message can be opened with the "Info" button (see also Chapter 8.2.1,
"Info dialog", on page 68).

14.1  Status information

The status messages are displayed in the Info line of the R&S SGMA-GUI main panel.
The status information gives the user an overview of the main operating states and set-
tings of the instrument. The states are indicated for information only and do not neces-
sitate any action by the user.

Status Information displayed in the Info line

AttFixed
Attenuator fixed mode is active.
The uninterrupted level settings are made in a fixed range without attenuator switching.
The variation range is set automatically when this mode is activated. The range is dis-
played with the parameter "SGMA-GUI > Instrument Name > Level > Attenuator Fixed
Range".

14.2  Error messages

Messages indicate errors in the instrument. They are displayed in the info line in differ-
ent colors depending on their importance and display duration. Errors (e.g. no calibra-
tion data) are displayed in red, information (e.g. file not found) and warnings in black.
Warnings indicate less significant errors (e.g. the instrument operates outside specified
data).

See also Chapter 8.2.1, "Info dialog", on page 68 and Chapter 8.2.2, "Understanding
the messages in the info bar", on page 69.

14.2.1  Volatile messages

Volatile messages report automatic settings in the instrument (e.g. switching off of
incompatible types of modulation) or on illegal entries that are not accepted by the

Error messages
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instrument (e.g. range violations). They are displayed in the info line on a yellow back-
ground. They are displayed on top of status information or permanent messages.

Volatile messages do not normally demand user actions and disappear automatically
after a brief period of time. They are stored in the history, however.

SCPI command: :SYSTem:ERRor:ALL? and :SYSTem:ERRor[:NEXT]?.

14.2.2  Permanent messages

Permanent messages are displayed if an error occurs that impairs further instrument
operation, e.g. a hardware fault. The error signaled by a permanent message must be
eliminated before correct instrument operation can be ensured.

The message is displayed until the error is eliminated. It covers the status display in
the info line. After error elimination, the message automatically disappears and is also
recorded in the history.

SCPI command: :SYSTem:SERRor?

14.3  SCPI-Error messages

The SCPI error messages are the same in all SCPI instruments. Detailed information
and an overview of all error messages as defined in SCPI standard can be found in the
corresponding documentation.

The errors are assigned negative numbers. The error text being entered into the error/
event queue or being displayed is printed in bold face on the left together with the error
code. Below the error text, there is an explanation as to the respective error.

14.4  Device-Specific error messages

The following table contains all error messages specific for the instrument in alphabeti-
cal order, and an explanation of the error situation. The positive error codes mark the
errors specific of the instrument.

The device-specific error messages set bit 3 in the ESR register.

The index provides a list of the error messages sorted according to their error codes.

Device-Specific error messages
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Error
Code

Error Description Remedy

180 Adjustment failed Adjustment could not be executed The adjustment data have to be
generated first by an internal or
external adjustment or to be loa-
ded into the device.

182 Adjustment data miss-
ing

Adjustment data are missing. The adjustment data have to be
generated first by an internal or
external adjustment or to be loa-
ded into the instrument.

183 Adjustment data inva-
lid

Adjustment data are invalid and must
be restored.

The adjustment data have to be
generated again by an internal or
external adjustment or to be loa-
ded into the instrument.

200 Cannot access hard-
ware

The data transmission to a module
was unsuccessful.

The module is not installed, not
properly installed or missing.

201 Hardware revision out
of date

A later version of certain parts of the
instrument is necessary to execute
the function selected.

The driver does not support the
installed version of a module.

202 Cannot access the
EEPROM

An error occurs when writing or read-
ing a EEPROM.

The EEPROM can be defective
and requires replacement.

203 Invalid EEPROM data   

204 Driver initialization
failed

Initialization of a driver fails when
booting the instrument firmware.

The driver is not compatible with
the hardware or software config-
uration of the instrument.

241 No current list There is no list selected. To execute the required opera-
tion, a list has to be selected in
the related dialog. If no list is
available, a new list must be cre-
ated.

242 Unknown list type
specified

The list type selected is not valid for
the required operation.

For instance, the file extension for
mapping files is *.map. It is not possi-
ble to enter another file extension
when selecting a list.

Check the selected list type.

460 Cannot open file The selected file cannot be opened. Check the path and file name.

461 Cannot write file The file cannot be written. Check if the file is read-only.

462 Cannot read file The file cannot be read. Check if the file contents are
compatible with the file type.

463 Filename missing The required operation cannot be
executed because the file name is not
specified.

A file name has to be entered
when creating a list.

464 Invalid filename exten-
sion

The file extension is not valid for the
required operation.

Check the file extension.

For instance, the file extension
for the mapping files is *.map. It
is not possible to enter another
file extension when storing a list.

Device-Specific error messages
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Error
Code

Error Description Remedy

465 File contains invalid
data

The selected file contains data that is
not valid for the file type.

Check the file extension.

The file extension determines the
data that is valid for this file type.
If the file extension is changed,
the lists are no longer recognized
and the data are therefore inva-
lid.

468 Cannot find directory Required folder cannot be found. Check drive and path.

469 No files found Folder is empty  

14.5  Contacting customer support

Technical support – where and when you need it

For quick, expert help with any Rohde & Schwarz product, contact our customer sup-
port center. A team of highly qualified engineers provides support and works with you
to find a solution to your query on any aspect of the operation, programming or applica-
tions of Rohde & Schwarz products.

Contact information

Contact our customer support center at www.rohde-schwarz.com/support, or follow this
QR code:

Figure 14-1: QR code to the Rohde & Schwarz support page

Contacting customer support

https://www.rohde-schwarz.com/support
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15  Transporting
Lifting and carrying

See:
● "Lifting and carrying the product" on page 11
● Chapter 3.1, "Lifting and carrying", on page 19.

Packing

Use the original packaging material. It consists of antistatic wrap for electrostatic pro-
tection and packing material designed for the product.

If you do not have the original packaging, use similar materials that provide the same
level of protection.

Securing

When moving the R&S SGU in a vehicle or using transporting equipment, make sure
that the R&S SGU is properly secured. Only use items intended for securing objects.

Transport altitude

Unless otherwise specified in the data sheet, the maximum transport altitude without
pressure compensation is 4500 m above sea level.
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16  Maintenance, storage and disposal
The product does not require regular maintenance. It only requires occasional clean-
ing. It is however advisable to check the nominal data from time to time.

16.1  Cleaning

How to clean the product is described in "Cleaning the product" on page 13.

Do not use any liquids for cleaning. Cleaning agents, solvents, acids and bases can
damage the front panel labeling, plastic parts and display.

16.2  Storage

Protect the product against dust. Ensure that the environmental conditions, e.g. tem-
perature range and climatic load, meet the values specified in the data sheet.

16.3  Disposal

Rohde & Schwarz is committed to making careful, ecologically sound use of natural
resources and minimizing the environmental footprint of our products. Help us by dis-
posing of waste in a way that causes minimum environmental impact.

Disposing electrical and electronic equipment

A product that is labeled as follows cannot be disposed of in normal household waste
after it has come to the end of its service life. Even disposal via the municipal collection
points for waste electrical and electronic equipment is not permitted.

Figure 16-1: Labeling in line with EU directive WEEE

Rohde & Schwarz has developed a disposal concept for the eco-friendly disposal or
recycling of waste material. As a manufacturer, Rohde & Schwarz completely fulfills its
obligation to take back and dispose of electrical and electronic waste. Contact your
local service representative to dispose of the product.

Disposal
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Annex
A  Telnet program examples

The following program example shows a simple TcpClient class that is intended to
explain on how to get started with programming of sockets.

The example sets up a socket communication to R&S SGU and opens a simple user
interface, very similar to the telnet, which allows input of commands. To enable real
automation, further development of the program is required.

TcpClient.h

#include <string>
//defines structs for socket handling
#include <netinet/in.h>
using namespace std;
typedef struct sockaddr_in SockAddrStruct;
typedef struct hostent     HostInfoStruct;
class TcpClient
{
  public:
    TcpClient();
    ~TcpClient();
    void connectToServer( string &hostname, int port );
    void disconnect( );
    void transmit( string &txString );
    void receive( string &rxString );
    string getCurrentHostName( ) const;
    int    getCurrentPort( ) const;
  private:
    string           currentHostName;
    int              currentPort;
    int              currentSocketDescr;
    SockAddrStruct   serverAddress;
    HostInfoStruct * currentHostInfo;
    bool             clientIsConnected;
    int              receiveBufferSize;
};

TcpClient.cpp

#include <string>
//defines structs for socket handling
#include <netinet/in.h>
using namespace std;
typedef struct sockaddr_in SockAddrStruct;
typedef struct hostent     HostInfoStruct;
class TcpClient
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{
  public:
    TcpClient();
    ~TcpClient();
    void connectToServer( string &hostname, int port );
    void disconnect( );
    void transmit( string &txString );
    void receive( string &rxString );
    string getCurrentHostName( ) const;
    int    getCurrentPort( ) const;
  private:
    string           currentHostName;
    int              currentPort;
    int              currentSocketDescr;
    SockAddrStruct   serverAddress;
    HostInfoStruct * currentHostInfo;
    bool             clientIsConnected;
    int              receiveBufferSize;
};

#include <netdb.h>
#include <netinet/in.h>
#include <unistd.h>
#include "TcpClient.h"
TcpClient::TcpClient()
: currentHostName( "" )
, currentPort( 0 )
, currentSocketDescr( 0 )
, serverAddress ( )
, currentHostInfo( NULL )
, clientIsConnected( false )
, receiveBufferSize( 1024 )
{
}
TcpClient::~TcpClient()
{
  currentHostInfo = NULL;
}

void TcpClient::connectToServer( string &hostname, int port )
{
  currentHostInfo = gethostbyname( hostname.c_str( ) );
  if( currentHostInfo == NULL )
  {
    currentHostName   = "";
    currentPort       = 0;
    currentHostInfo   = NULL;
    clientIsConnected = false;
    printf("error connecting host\n" );
  }
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  currentHostName = hostname;
  currentPort     = port;
  currentSocketDescr = socket(AF_INET, SOCK_STREAM, 0);
  if( currentSocketDescr == 0 )
  {
    currentHostName   = "";
    currentPort       = 0;
    currentHostInfo   = NULL;
    clientIsConnected = false;
    printf("can't create socket\n" );
  }
  serverAddress.sin_family = currentHostInfo->h_addrtype;
  serverAddress.sin_port   = htons( currentPort );
  memcpy( (char *) &serverAddress.sin_addr.s_addr, 
  currentHostInfo->h_addr_list[0], currentHostInfo->h_length );
  if( connect( currentSocketDescr, ( struct sockaddr *) &serverAddress, 
  sizeof( serverAddress ) ) < 0 )
  {
   throw string("can't connect server\n" );
  }
  clientIsConnected = true;
}
void TcpClient::disconnect( )
{
  if( clientIsConnected )
  {
    close( currentSocketDescr );
  }
  currentSocketDescr = 0;
  currentHostName    = "";
  currentPort        = 0;
  currentHostInfo    = NULL;
  clientIsConnected  = false;
}
void TcpClient::transmit( string &txString )
{
  if( !clientIsConnected )
  {
  throw string("connection must be established before any data can be sent\n");
  }
  char * transmitBuffer = new char[txString.length() +1];
  memcpy( transmitBuffer, txString.c_str(), txString.length() );
  transmitBuffer[txString.length()] = '\n'; //newline is needed!
  if( send( currentSocketDescr, transmitBuffer, txString.length() + 1, 0 ) < 0 )
  {
    throw string("can't transmit data\n");
  }
  delete [] transmitBuffer;
}
void TcpClient::receive( string &rxString )
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{
  if( !clientIsConnected )
  {
  throw string("connection must be established before any data can be received\n");
  }
  char * receiveBuffer = new char[receiveBufferSize];
  memset( receiveBuffer, 0, receiveBufferSize );
  bool receiving = true;
  while( receiving )
  {
    int receivedByteCount = recv( currentSocketDescr, 
    receiveBuffer, receiveBufferSize, 0 );
    if( receivedByteCount < 0 )
    {
      throw string("error while receiving data\n");
    }
    rxString += string( receiveBuffer );
    receiving = ( receivedByteCount == receiveBufferSize );
  }
  delete [] receiveBuffer;
}
string TcpClient::getCurrentHostName( ) const
{
  return currentHostName;
}
int TcpClient::getCurrentPort( ) const
{
  return currentPort;
}

TelnetClient.cpp

#include <iostream>
#include "TcpClient.h"
void printUsage()
{
  cout<<"usage: EthernetRawCommand <server-ip> [scpi-command]"<<endl;
}
int main( int argc, char *argv[] )
{
  int errorCode         = 0; //no error
  bool useSingleCommand = false;
  string singleCommand  = "";
  string hostname       = "";
  int    port           = 5025;
  string input          = "";
  TcpClient client;
  switch( argc )
  {
    case 3:
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      useSingleCommand = true;
      singleCommand    = argv[2];
    case 2:
      hostname         = argv[1];
      break;
    default:
        printUsage();
        return(-1);
  }
  try
  {
    client.connectToServer( hostname, port );
    bool terminate = false;
    while( !terminate )
    {
      char buffer[1024];
      if( useSingleCommand )
      {
        input =  singleCommand; //send string
      }
      else
      {
        cin.getline( buffer, 1024 );
        input = buffer;
        if( input == "end" )
        {
          terminate = true;
        }
      }
      if( !terminate)
      {
        client.transmit( input ); //send string
        int qPos = input.find( "?", 0 );
        //receive string only when needed
        if( qPos > 0 )
        {
          string rcStr = "";
          client.receive( rcStr );
          cout << rcStr << endl;
        }
      }
      if( useSingleCommand )
      {
        terminate = true;
      }
    }
  }catch( const string errorString )
  {
    cout<<errorString<<endl;
  }
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  client.disconnect( );
  return errorCode;
}
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